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About This Manual

Use this manual to familiarize yourself with LabVIEW SignalExpress 
interactive measurements and the basic LabVIEW SignalExpress features 
that you use to acquire and analyze signals.

This manual contains exercises that help you begin working with 
LabVIEW SignalExpress. These exercises teach you how to run projects, 
configure steps, work with signals, configure sweep measurements, log 
data, and extend LabVIEW SignalExpress with LabVIEW graphical 
programming.

Conventions
The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

This icon denote a tip, which alerts you to advisory information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes input and 
output names, parameter names, dialog boxes, sections of dialog boxes, and 
menu names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard. This font is also used for the proper names of disk drives, paths, 
directories, programs, subprograms, subroutines, device names, functions, 
operations, variables, filenames, and extensions.
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Related Documentation
Refer to the LabVIEW SignalExpress Help, available by selecting Help»
LabVIEW SignalExpress Help, for more information as you read this 
manual.
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1
Getting Started with 
LabVIEW SignalExpress

National Instruments provides innovative solutions for scientists 
and engineers to build automated measurement systems based on 
industry-standard computers and platforms. National Instruments develops 
robust, industry-leading programming environments for automating 
measurement systems, such as LabVIEW for graphical development, 
LabWindows™/CVI™ for ANSI C programming, and Measurement Studio 
for Microsoft Visual Studio programming. You can use these programming 
tools with National Instruments measurement hardware and interfaces to 
traditional instruments to build custom, advanced virtual instrumentation 
systems.

LabVIEW SignalExpress optimizes virtual instrumentation for design 
engineers by offering instant interactive measurements that require no 
programming. You can use LabVIEW SignalExpress interactively to 
acquire, generate, analyze, compare, import, and log signals. You can 
compare design data with measurement data in one step. LabVIEW 
SignalExpress extends the ease of use and performance of virtual 
instrumentation to those who must acquire or analyze signals without 
programming applications. You also can extend the functionality of 
LabVIEW SignalExpress by importing a custom virtual instrument (VI) 
created in the LabVIEW Development System or by converting a 
LabVIEW SignalExpress project to a LabVIEW block diagram so you can 
continue development in LabVIEW. Refer to Chapter 6, Extending 
LabVIEW SignalExpress Projects with LabVIEW, for more information 
about advanced functionality in LabVIEW SignalExpress.

This chapter provides information about LabVIEW SignalExpress system 
requirements, installation instructions, version availability, and available 
licensing options.



Chapter 1 Getting Started with LabVIEW SignalExpress

Getting Started with LabVIEW SignalExpress 1-2 ni.com

Installing LabVIEW SignalExpress
Before you begin the exercises in this manual, you must install 
LabVIEW SignalExpress. The LabVIEW SignalExpress setup program 
installs the software in about 10 minutes.

Minimum System Requirements
To run LabVIEW SignalExpress, National Instruments recommends that 
your system meet the following requirements:

• 512 MB of memory

• Pentium 4 processor or equivalent (Pentium III or Celeron 600 MHz 
minimum)

Installation Instructions
Complete the following steps to install LabVIEW SignalExpress on 
Windows 2000/XP/Vista.

Note If you installed LabVIEW SignalExpress from the LabVIEW 8.6 Platform DVD, 
you do not need to reinstall using the media described in this section. Refer to the LabVIEW 
Release Notes for DVD installation instructions.

1. Exit all programs before you run the LabVIEW SignalExpress installer. 
Applications that run in the background, such as virus scanning utilities, 
might cause the installer to take longer than average to complete.

2. Log on as an administrator or as a user with administrator privileges.

3. Insert the LabVIEW SignalExpress installation media and follow the 
instructions that appear on the screen.

Note Unless you specify another location during installation, the LabVIEW 
SignalExpress installation program copies files to the <Program Files>\National 
Instruments\SignalExpress directory.

4. After installation, check the hard disk for viruses and enable any virus 
detection programs you disabled.

The example projects you use with this manual are located in the <Program 
Files>\National Instruments\SignalExpress\Examples\

Tutorial directory. The solutions for each exercise are located in the 
<Program Files>\National Instruments\SignalExpress\

Examples\Tutorial\Solutions directory.
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LabVIEW SignalExpress Version Availability
LabVIEW SignalExpress is available in both a full and limited (LE) 
version. Refer to the following table for a list of features available in each 
version. 

Table 1-1.  Differences in LabVIEW SignalExpress Full and LE Versions

Full LE

Instrument Support

Over 300 common standalone instruments ✓ —

Visualization and Documentation

Customizable graphing ✓ ✓

Interactive cursors ✓ ✓

Save signals to file ✓ ✓

Print and export graphs ✓ ✓

Drag and drop data into Microsoft Excel, Word, 
and WordPad

✓ ✓

Operator mode with limited user-editing ✓ —

Signal Processing

Software filters ✓ —

Scalar and waveform math ✓ —

Analog and digital conversion ✓ —

Interactive signal comparisons ✓ —

Load simulation data from PSPICE, Multisim, 
and other SPICE packages

✓ —

Time and Frequency Measurements

Amplitude and level ✓ —

Timing and transition ✓ —

Power spectrum ✓ —
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Frequency response ✓ —

Distortion measurements ✓ —

Tone extraction ✓ —

Data Logging

Limited data logging (one log per project) ✓ ✓

Unlimited data logging ✓ —

Logging alarms and events ✓ —

Logging with start or stop conditions ✓ —

Measurement Automation

Parameter sweeping ✓ —

Limit testing ✓ —

Software triggering ✓ —

Sequencing ✓ —

Remote Data Access

Read/Write shared variables ✓ —

Table 1-1.  Differences in LabVIEW SignalExpress Full and LE Versions (Continued)

Full LE
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LabVIEW SignalExpress Licensing Options
This section assists you in understanding the licensing policies for 
LabVIEW SignalExpress. This document does not replace the National 
Instruments Software License Agreement. Use this document only as a 
reference.

LabVIEW SignalExpress LE
The limited, unlicensed LE version of LabVIEW SignalExpress gives you 
access to all features in Table 1-1 for 30 days. After that period, 
LabVIEW SignalExpress runs in unlicensed mode. If you do not activate a 
valid license within 30 days and you create a project that contains licensed 
steps, the following occurs:

• Each time you drop a step that is licensed, a dialog box prompts you to 
activate the software. 

• You cannot save a project.

• Projects close after 10 minutes.

Refer to the National Instruments Web site at ni.com/signalexpress to 
purchase LabVIEW SignalExpress Full version.

LabVIEW Signal Express Full Version
The full version of LabVIEW SignalExpress provides you with the full 
functionality shown in Table 1-1. You can activate the full version of 
LabVIEW SignalExpress using the National Instruments License Manager, 
the LabVIEW SignalExpress installer, or the National Instruments Web 
site at ni.com/activate.
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2
Working with Projects

You can use LabVIEW SignalExpress to define measurement procedures 
by adding and configuring steps in an interactive measurement 
environment. A step is a configurable function that acquires, generates, 
analyzes, loads, or stores signals. The Add Step menu and the Add Step 
palette show the steps available in LabVIEW SignalExpress. 

Most steps process input signals and produce output signals. You can 
configure the operation of a step by specifying values on the Step Setup tab 
for the step. A saved sequence of configured steps is a LabVIEW 
SignalExpress project.

This chapter teaches you how to load and run existing projects and how to 
configure steps in these projects.

Opening a Project
Complete the following steps to load a sample project in LabVIEW 
SignalExpress.

1. Launch LabVIEW SignalExpress.

Notice that LabVIEW SignalExpress is split into views that display 
various types of information. The primary view appears in the middle 
of the application window and contains tabs. If LabVIEW 
SignalExpress opens in the default configuration, the Data View tab, 
the Recording Options tab, and the Project Documentation tab 
appear in the primary view. 

The primary view is surrounded by supplementary views. In the 
default configuration, the Project View appears on the left, and the 
context help appears on the right.

Note If LabVIEW SignalExpress detects a supported hardware device, the Channel View 
appears across the bottom of the LabVIEW SignalExpress application window.

2. If LabVIEW SignalExpress does not open in the default configuration, 
select View»Reset Layout to reset the application to the default 
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configuration. You can use the View menu to display tabs and views or 
reset the layout at any time.

3. Select Help»Open Example, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click First 
Project.seproj to open the example project. 

4. Examine the window that appears, as shown in Figure 2-1 with the 
context help closed, to learn about different components of LabVIEW 
SignalExpress. 

Figure 2-1.  First Project.seproj

The LabVIEW SignalExpress environment consists of views that 
display various types of information. The primary view appears in the 
middle of the application window and contains tabs, such as the Data 
View tab. Supplementary views surround the primary view and appear 
with individual title bars. For example, the Project View is a 
supplementary view.

1 Run button
2 Work Area pull-down menu
3 Step

4 Input
5 Output
6 Project View

7 Logged Data window
8 Primary view with Data View tab visible
9 Record button

5

8

5

3

4

2

91

6

7
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Running a Project and Displaying Signals
LabVIEW SignalExpress has multiple execution or run modes. You can 
run projects once, continuously, for a number of iterations you specify, or 
for an amount of time you specify. When you run a project once, LabVIEW 
SignalExpress executes all the steps in the project one time. When you run 
a project continuously, LabVIEW SignalExpress executes all the steps in 
the project continuously. Click the down arrow on the Run button, shown 
at left, and select Configure Run from the pull-down menu to configure 
the run mode for a project.

Displays on the Data View tab update continuously while a project runs. 
When a project is running, you can change measurement configuration settings 
by changing settings on the Step Setup tab and view the results immediately. 
Projects you run continuously run until you click the Stop button, shown at left. 
The Stop button appears in place of the Run button as a project runs. 

Complete the following steps to run the sample project and display signals.

1. Click the Run button. If the Run Information dialog box appears, 
click the Run button in the dialog box to execute all the steps in the 
project continuously.

The project loads a signal from a text file and performs two operations 
on the signal—an amplitude and levels measurement and a distortion 
measurement. The Amplitude and Levels step and the Distortion step 
perform these measurements, respectively. When you run a project, 
steps analyze input signals and generate new output signals as a result 
of the analysis. In this project, the Load from ASCII step loads a 
distorted sine wave, the Amplitude and Levels step and the Distortion 
step analyze the sine wave, and both steps return new outputs. In the 
Project View, LabVIEW SignalExpress indicates inputs with red 
arrows and outputs with blue arrows.

The graph display on the Data View tab still contains the loaded 
signal, which is a time-domain signal. Graphs display time-domain, 
frequency-domain, or XY signals. 

2. Drag the exported spectrum output signal of the Distortion step from 
the Project View to the Data View tab to display the signal. 

LabVIEW SignalExpress creates a new graph display on the Data 
View tab. LabVIEW SignalExpress does not display the exported 
spectrum signal on the same display as the time-domain signal 
because the exported spectrum signal is a frequency-domain signal. 
LabVIEW SignalExpress automatically recognizes different types of 
signals and renders them in the appropriate displays.
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Tip Refer to the LabVIEW SignalExpress Help for more information about signal types 
by selecting Help»LabVIEW SignalExpress Help, clicking the Search tab, and entering 
"signal types". The help provides information about using LabVIEW SignalExpress 
functionality such as projects, steps, and signals.

3. Drag the dc output of the Amplitude and Levels step to the Data View 
tab. 

LabVIEW SignalExpress creates both a graph and a Legend table to 
display the scalar measurement from the dc output. The Legend table 
displays the value of each output and the color LabVIEW 
SignalExpress uses to plot the output on the adjoining graph.

4. Drag the rms output of the Amplitude and Levels step to the Legend 
table to display the scalar RMS measurement.

LabVIEW SignalExpress creates a new row in the table to display the 
second measurement. The project appears as shown in Figure 2-2.

Figure 2-2.  Outputs of First Project.seproj
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Configuring a Step
A step is a configurable function that acquires, generates, analyzes, loads, 
or stores signals. Steps process input signals and produce output signals. 
You can configure the operation of a step in LabVIEW SignalExpress by 
specifying values on the Step Setup tab for the step. While a project runs, 
you can modify the configuration of steps and see immediate feedback on 
the Data View tab, and you can adjust measurements until you achieve the 
results you need.

Complete the following steps to configure the Distortion step and the 
Amplitude and Levels step.

1. Double-click the Distortion step in the Project View. LabVIEW 
SignalExpress displays the Step Setup tab for the Distortion step, as 
shown in Figure 2-3.

Figure 2-3.  Distortion Step Setup Tab

On the Configuration page of the Step Setup tab, the Export signals 
(THD) field indicates that the Distortion step exports the input signal, 
and the Exported Signal graph displays a preview of the signal. The 



Chapter 2 Working with Projects

Getting Started with LabVIEW SignalExpress 2-6 ni.com

Exported Power Spectrum graph indicates that the step performs a 
power spectrum on the input signal to convert it to the frequency 
domain, and the Measurement Results field displays the fundamental 
frequency and total harmonic distortion (THD) of the signal. The step 
generates the exported signal and three measurements as outputs—the 
spectrum, the THD, and the fundamental frequency of the original 
time-domain waveform input.

2. If the context help does not appear on the right side of the screen, select 
Help»Context Help to display complete reference information about 
the step. 

The upper section of the context help displays information about the 
step, and the lower section of the context help displays information 
about specific parameters of the step when you move the cursor over a 
parameter. Move the cursor over the THD (%) parameter to display 
information about the parameter.

3. On the Configuration page, select Fundamental Tone from the 
Export signals (THD) pull-down menu.

The Exported Power Spectrum graph changes from displaying the 
frequency-domain spectrum of the entire input signal to displaying 
only the frequency spectrum of the fundamental tone of the input 
signal. Both the output signal of the Distortion step and the graph 
display of the exported spectrum output on the Data View tab update 
to reflect the change you made.

4. Select Harmonics only from the Export signals (THD) pull-down 
menu.

The Exported Power Spectrum graph on the Step Setup tab and the 
graph of the output on the Data View tab both change to display only 
the spectrum of the harmonic signals from the input signal.

5. Click the Amplitude and Levels step in the Project View. 

The Step Setup tab changes from displaying the configuration of the 
Distortion step to displaying the configuration of the Amplitude and 
Levels step.



Chapter 2 Working with Projects

© National Instruments Corporation 2-7 Getting Started with LabVIEW SignalExpress

6. Select the Input/Output page to display the list of possible inputs and 
outputs for this step, as shown in Figure 2-4.

Figure 2-4.  Amplitude and Levels Step Setup Tab

7. Place checkmarks in the Export +peak value, Export -peak value, 
and Export peak-peak value checkboxes to configure the Amplitude 
and Levels step to return three additional measurements.

Three additional outputs appear in the Project View.

8. Switch to the Data View tab.

9. Drag the three new outputs from the Project View to the Legend table 
of scalar measurements. The new outputs appear on the adjoining 
graph.

Note If you have been running the project for a while, you might need to stop and restart 
the project to see all the scalar signals on the graph. LabVIEW SignalExpress accumulates 
points of data for signals that you add to a graph, and new signals you add do not have as 
many data points to display on the graph. 
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10. Click the Stop button to stop the project.

When you click the Stop button, the project stops running after 
completing the current cycle of operations, or the current iteration. 
Click the down arrow on the Stop button and select Abort from the 
pull-down menu to completely stop the project without finishing the 
current iteration.

11. Select File»Save Project As and save the project as My First 
Project.seproj in the SignalExpress\Examples\Tutorial 
directory.

12. Select File»Close Project to close the project.

Ordering, Moving, and Deleting Steps
Most steps in LabVIEW SignalExpress projects require input data. Steps 
can operate only on signals exported from previous steps in the Project 
View, so the order in which steps appear in the Project View can effect 
project functionality. 

For steps that have an Input or Input/Output page on the Step Setup tab, 
the Input signal pull-down menu on that page displays only compatible 
signals exported from a previous step. When the output of a step becomes 
the input of another step, the steps become dependent on each other, and the 
two steps execute sequentially at the same rate. The first step generates an 
output signal that the second step must receive as an input before the second 
step can execute.

You can move a step within a project by dragging it up or down in the 
Project View. You can delete a step by right-clicking it in the Project View 
and selecting Delete from the shortcut menu. When you move or delete a 
step, the status of signals in the project changes. For example, if you delete 
a step that generates output signals, the operation of the project breaks if 
any of the deleted output signals are inputs for other steps, and an error 
indicator appears in the Project View. You also can cut, copy, and paste 
steps within a project by pressing the <Ctrl-X>, <Ctrl-C>, and <Ctrl-V> 
keys, respectively, or by right-clicking a step in the Project View and 
selecting Cut, Copy, Paste Before Selected Step, or Paste After Selected 
Step from the shortcut menu.
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Handling Errors and Warnings
If an error occurs while a project runs, an error indicator, shown at left, 
appears in the Project View on the step that encountered the error. 
Double-click the step with the error to display an error description across 
the bottom of the Step Setup tab. Click the Details button to the right of 
the error description to display the full error description.

LabVIEW SignalExpress logs all errors and warnings on the Event Log tab 
while a project runs. To display the Event Log tab, select View»Event 
Log. Refer to the LabVIEW SignalExpress Help for more information 
about errors and warnings by selecting Help»LabVIEW SignalExpress 
Help, clicking the Search tab, and entering errors.
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3
Working with Signals

You can use LabVIEW SignalExpress to generate and analyze signals 
without programming. This chapter teaches you how to work with signals 
in LabVIEW SignalExpress, including how to plot signals on graphs, 
import signals from a file, interactively align and compare two signals, and 
save signals to a file.

Graphing Signals
Complete the following steps to plot signals in a sample project and 
examine the signals visually using cursors.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click 
Signals.seproj. This project configures the Create Analog Signal 
step to create a square wave signal and the Filter step to perform a 
lowpass Butterworth filter.

2. Drag the step signal output of the Create Analog Signal step to the 
Data View tab.

3. Drag the filtered step output of the Filter step to the Data View tab.

Both the step signal and the filtered step signals are time-domain 
signals, so they appear on the same graph display. If you try to plot 
signals of different types by dragging the signals to the same display, 
LabVIEW SignalExpress creates a new display.

4. Click the Add Display button, shown at left, to create a new display.

5. Drag the filtered step output of the Filter step to the new display.
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6. Right-click the new display and select Visible Items»Cursors from 
the shortcut menu to display two interactive cursors, as shown in 
Figure 3-1.

Figure 3-1.  Signals.seproj

As you drag the cursors, LabVIEW SignalExpress displays the x- and 
y-values of the cursors in the cursor table at the bottom of the Data 
View tab.

7. Select File»Save Project As and save the project as 
My Signals.seproj in the SignalExpress\Examples\
Tutorial directory.
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Importing a Signal from a File
You can import signals from standard file formats such as ASCII comma- 
or tab-delimited files and LabVIEW measurement data files (.lvm). You 
also can import signals from simulated results of electronic design 
automation tools such as SPICE simulators.

Complete the following steps to import a signal from a file.

1. Right-click in the Project View and select Load/Save Signals»Analog 
Signals»Load from ASCII from the shortcut menu to add the Load 
from ASCII step to the Project View. The Step Setup tab for the Load 
from ASCII step appears. This step parses an ASCII file and displays 
the signals in the file.

Note You can add steps to a project from the Add Step menu, the Add Step palette, or the 
shortcut menu that appears when you right-click in the Project View.

2. On the Step Setup tab, click the browse button, shown at left, navigate 
to the SignalExpress\Examples\Tutorial directory, and 
double-click Step Response.txt.

In the File preview section, column 1 shows the time stamp data, and 
column 2 shows the actual voltage values of the signal.

3. Switch to the Import Signals page of the Step Setup tab to display the 
available signals in the file.

4. Place a checkmark in the Column 2 checkbox to import that signal, 
and remove the checkmark from the Column 1 checkbox.

The Step Setup tab displays a preview of the signal on the Imported 
Signal graph.

5. Select Column 1 (Column 1) from the Input X values pull-down 
menu to set the x-axis data of the waveform to the appropriate values.

6. Switch to the Data View tab.

7. In the Project View, expand the Step Response.txt output of the Load 
from ASCII step.

8. Right-click the Column 2 output and select Rename from the shortcut 
menu.

9. Enter step response and press the <Enter> key to rename the output.

10. Drag the new step response output of the Load from ASCII step to the 
lower display on the Data View tab.
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The filtered step signal resembles the rising edge of the step response 
output, as shown in Figure 3-2.

Figure 3-2.  Signals of Signals.seproj

11. Select File»Save Project to save the project.

Aligning and Comparing Signals
Although the filtered step signal and the step response output both show 
an overshoot in the rising edge, assessing the similarity between the two 
is difficult because the signals come from different sources and vary in 
amplitude and timing. However, you can use the Interactive Alignment step 
to align and compare two signals, so you can choose which type of 
information you want to export from the operation to use in the project.

Complete the following steps to align two signals in the 
My Signals.seproj project.

1. Expand the Step Response.txt output, right-click the step response 
output and select Send To»Processing»Analog Signals»
Interactive Alignment from the shortcut menu to pass the step 
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response signal from the Load from ASCII step to the Interactive 
Alignment step.

The step selects the two most recent signals from the project to use as 
inputs and displays the signals on the graphs on the Step Setup tab, as 
shown in Figure 3-3.

Figure 3-3.  Interactive Alignment Step Setup Tab

When you add a step to a project, LabVIEW SignalExpress selects 
input signals based on the signal types the step can accept. For 
example, the Interactive Alignment step can operate only on 
time-domain waveform signals. Therefore, the step selects as inputs 
the last two time-domain signals created in the project. 

Note To change the input signals for a step, select different signals from the pull-down 
menu of compatible signals on the Input or Input/Output page of the Step Setup tab, or 
click the down arrow that appears next to the step input name on the step in the Project 
View.
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2. Click the red signal in the Input Signals graph and drag it to another 
point within the graph. The Comparison Result Signal graph updates 
to show the new calculated difference between the signals.

You can drag, expand, and contract signals on the graph.

3. Try to align the rising edges of the two signals by dragging a signal 
within the graph. Click a signal to set an anchor point and press and 
hold the <Alt> key while dragging the signal to stretch the signal 
around that anchor point along the x- and y-axes.

On the Alignment page of the Step Setup tab, the step computes and 
displays the x- and y-gain and offset values you need to achieve the 
alignment specifications as you drag the signals.

4. Select Auto - Step from the Mode pull-down menu to align the 
signals. LabVIEW SignalExpress computes the alignment using 
built-in algorithms.

The Comparison Result Signal graph on the Step Setup tab displays 
the difference between the two signals.

5. On the Input/Output page, place a checkmark in the Export aligned 
signals checkbox to add the signals to the outputs of the step.

6. Switch to the Data View tab.

7. Click the Add Display button to add a third display.

8. Drag the aligned reference and aligned test outputs of the Interactive 
Alignment step to the new graph to view the aligned signals.

9. Select File»Save Project to save the project.

Signal Types in LabVIEW SignalExpress
Some steps, such as the Arithmetic step, can operate on multiple signal 
types. For example, you can use the Arithmetic step to operate on 
time-domain or frequency-domain waveforms. The Arithmetic step 
changes behavior based on the type of input signals you select for the 
step. For example, if you add two time-domain signals, LabVIEW 
SignalExpress adds only their amplitudes. However, if you add two 
frequency-domain phase signals, LabVIEW SignalExpress adds the 
appropriate phase shift.

Refer to the LabVIEW SignalExpress Help for more information about 
signal types by selecting Help»LabVIEW SignalExpress Help, clicking 
the Search tab, and entering "signal types".
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Exporting and Printing Signals
You can use LabVIEW SignalExpress to document signals or continue 
analysis in another software application. This section teaches you how to 
export signals, including sending signals to an ASCII file, sending data to 
Microsoft Excel, printing signals, and using the built-in project 
documentation feature to document the LabVIEW SignalExpress project.

Saving Signals to File
Complete the following steps to save a signal from My Signals.seproj 
to a file.

1. Click the Add Step button, shown at left, to display the Add Step 
palette.

2. Select Load/Save Signals»Save to ASCII/LVM to add the Save to 
ASCII/LVM step to the Project View. The Step Setup tab for the Save 
to ASCII/LVM step appears.

3. Click the Signals page on the Step Setup tab and select filtered step 
from the Input Data pull-down menu.

4. On the File Settings page, specify where to save the text file you are 
creating. Click the Browse button next to the Export file path field 
and navigate to the SignalExpress\Examples\Tutorial 
directory, and enter filtered signal.txt as the filename.

5. Select Overwrite from the If file already exists pull-down menu.

6. Select Generic ASCII (.txt) from the Export file type pull-down 
menu.

You can use a Load/Save Signals step to save data to a file every time 
the project runs.

7. Click the down arrow on the Run button and select Run Once to run 
the project and save the resulting signal to the specified ASCII file.

8. Select File»Save Project to save the project.

9. Select File»Close Project to close the project.

10. Browse to the filtered signal.txt and open the file in a text 
editor to see the values of the signal. In LabVIEW SignalExpress, you 
can use the Load from ASCII step to import the signal back into a 
project.
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Exporting Signals to Microsoft Excel
To export signal data to Microsoft Excel, launch Excel and drag the output 
signal of a step in LabVIEW SignalExpress to an Excel spreadsheet. You 
also can right-click a display on the Data View tab and select Export To»
Microsoft Excel to export all the data on the display.

Printing Signals
To print an image of a graph, display the Data View tab and select File»
Print»Print Data View.

Creating Reports in LabVIEW SignalExpress
Select View»Project Documentation to display the Project 
Documentation tab. You can use this tab to describe a project using text and 
images such as graphs. You can drag a step output from the Project View to 
the Project Documentation tab to display a graph of the output signal. If the 
project is running, the graph on the Project Documentation tab 
automatically updates to match the current value of the step output. 

To print the documentation, display the Project Documentation tab 
and select File»Print»Print Documentation or click the Print 
Documentation button. To export the documentation to HTML, display 
the Project Documentation tab and select File»Export»Export 
Documentation to HTML.
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4
Logging Data

You can use LabVIEW SignalExpress to record and analyze 
measurements. You can record any time-domain, double, 32-bit unsigned 
integer, or Boolean step output. You also can analyze and process logged 
data by playing it through analysis steps. 

This chapter teaches you how to record data using the integrated data 
logging features in LabVIEW SignalExpress. You learn how to record a 
specified signal, play back that signal, and analyze the signal using analysis 
steps. You also learn how to use the Recording Options tab to log signals 
based on specified start or stop conditions. 

Recording a Signal
You can use the Record button to configure a data logging process. 

Complete the following steps to specify a signal to record and to record the 
signal.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click 
Logging.seproj.

This project uses the Create Analog Signal step to generate a signal 
based on a formula.

2. Click the Record button, shown at left, to open the Logging Signals 
Selection dialog box.

The Logging Signals Selection dialog box displays the signals in the 
project available for recording. You can select one signal or multiple 
signals to record. You also can specify a name and description for 
the log.

3. Place a checkmark in the signal checkbox to record the formula signal 
generated in the Create Analog Signal step.

4. Click the OK button to close the Logging Signals Selection dialog 
box and begin recording the signal. The logging operation continues 
until you click the Stop button.
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5. Click the Stop button, shown at left, to stop logging the signal. If you 
have not logged a signal before, the First Log Complete dialog box 
appears. Click the OK button to close the dialog box.

The logged data appears in the Logged Data window at the bottom of 
the Project View, as shown in Figure 4-1.

Figure 4-1.  Logged Data Window

By default, LabVIEW SignalExpress names the logged data according 
to the date and time you recorded the data. LabVIEW SignalExpress 
saves logged data in the .tdms file format in the directory you specify 
in the Options dialog box. 

6. Select Tools»Options and select the Logging option to specify the 
directory for LabVIEW SignalExpress to save the logged data and to 
customize various preferences for logged data.

7. Click the OK button to close the Options dialog box.

8. Select File»Save Project As and save the project as 
My Logging.seproj in the SignalExpress\Examples\
Tutorial directory.

Viewing a Logged Signal
Complete the following steps to view the logged data.

1. If the Data View tab is not visible, select View»Data View to display 
the Data View tab. 

2. The Logged Data window displays a list of all logged data in the 
current project. Select the data log you just recorded from the Logged 
Data window and drag it to the Data View tab. The Data View tab 
displays the logged data and a Preview Graph, as shown in Figure 4-2. 
The signal displayed on the Data View tab might differ from the signal 
displayed in Figure 4-2, depending on how long you recorded the 
signal.
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Figure 4-2.  Logging.seproj

The Preview Graph provides a method for zooming and panning 
through data on the Data View tab. The Preview Graph appears by 
default when you view logged data. When viewing live or non-logged 
data, right-click a display on the Data View tab and select Visible 
Items»Preview from the shortcut menu to display the Preview Graph.

3. Click the Zoom In button next to the Preview Graph to zoom in on the 
logged signal. The cursors on the Preview Graph show the subset of 
data currently displayed on the Data View tab. Use the scroll bar 
beneath the Preview Graph to scroll through the data. Click and drag 
the cursors on the Preview Graph to increase or decrease the subset of 
data you are viewing.

1 Logged Data 2 Preview Graph

1

2
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Logging Signals with Predefined Start and Stop 
Conditions

You can configure start and stop conditions that signals must meet before 
LabVIEW SignalExpress records or stops recording the signals. Complete 
the following steps to log data based on start and stop conditions.

1. If the Recording Options tab is not visible, select View»Recording 
Options to open the Recording Options tab.

2. Select Signal Selection from the Category list on the Recording 
Options tab.

3. Place a checkmark next to the signal in the Record column, as shown 
in Figure 4-3.

Figure 4-3.  Signal Selection

The Record button changes to the Record While Running button, 
shown at left. Ensure the Record While Running button is pressed. 
When the Record While Running button is pressed, LabVIEW 
SignalExpress records the selected signal when you click the Run 
button.

4. Select Start Conditions from the Category list on the Recording 
Options tab. 
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5. Click the Add button under the Start condition list to customize a 
start condition for the logging task.

a. In the Condition type pull-down menu, verify that Signal trigger 
is selected to specify that LabVIEW SignalExpress begins 
recording when the input signal meets the specified condition.

b. In the Signal pull-down menu, verify that signal is selected.

c. In the Trigger type pull-down menu, verify that Rising slope is 
selected to specify to begin recording the signal based on the value 
of the edge of the signal on a positive slope.

d. Enter 1 in the Trigger value field to begin recording when the 
signal crosses 1 on a rising slope.

6. Select Stop Conditions from the Category list on the Recording 
Options tab.

7. Click the Add button under the Stop condition list to customize a stop 
condition for the logging task.

a. In the Condition type pull-down menu, verify that Duration is 
selected to specify that LabVIEW SignalExpress stops recording 
after a specified amount of time passes.

b. In the Duration control, verify that 5 appears to specify to record 
the signal for 5 seconds after the signal meets the start condition.

8. Click the Run button, shown at left. LabVIEW SignalExpress begins 
recording the signal when the signal crosses level 1 on a rising slope 
and continues recording the signal for 5 seconds. 

The following indicators in the Recording status section of the 
Recording Options tab update while the project runs:

• Recording displays ON when the signal meets the start condition 
and logging is in progress. 

• Disk information displays the available hard disk space on the 
computer for the log. 

• Current estimated log size displays the size of the log file on 
disk.

• Recording time left displays the amount of time you can continue 
recording the log before running out of disk space.

• Current log started on displays the start time of the current log.

The Start Conditions, Stop Conditions, Alarms, and Events pages 
of the Recording Options tab also include indicators that display the 
status of start and stop conditions, alarms, and events that you 
configure.
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Analyzing Logged Signals
After you log a signal, you can play back the logged data or run the logged 
signal through analysis steps, just as you can with live data. Complete the 
following steps to analyze a logged signal.

1. Locate the Work Area pull-down menu above the Project View, as 
shown in Figure 4-4. Click the down arrow and select Playback to 
switch to the Playback work area.

Figure 4-4.  Work Area pull-down menu

Use work areas to perform multiple LabVIEW SignalExpress 
operations from within the same project. You can acquire data, process 
signals, record data, and perform measurements on logged data 
without opening a new project. When you save a project, LabVIEW 
SignalExpress saves every work area within the project in the same 
project file.

The default work area, Monitor/Record, allows you to take 
measurements, analyze live data, and log data. The Playback work area 
allows you to use logged data that you record in the Monitor/Record 
work area as an input for an analysis step.

2. Click the Add Step button, shown at left, and select the Filter step from 
Processing»Analog Signals»Filter. LabVIEW SignalExpress 
automatically selects the first signal you logged as the input to the 
Filter step.

3. Switch to the Data View tab, and drag the filtered data output of the 
Filter step to the Data View tab to view the resulting signal.

4. Click the Run button. The Data View tab displays the resulting 
filtered signal and LabVIEW SignalExpress plays back the entire log.

Advanced Playback
You can use the Playback Options tab to configure advanced data 
playback options. The Playback Options tab displays a preview of the 
logged data and allows you to select a subset of that data to play back or run 
through analysis steps.

1. Select View»Playback Options to display the Playback Options tab, 
as shown in Figure 4-5. 
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Figure 4-5.  Playback Options View

2. In the Logged signal listbox, select signal from the second log you 
created.

3. Enter 1 in the Start time (s) field to play back or analyze a subset of 
the logged signal beginning 1 second after the start of the log. 

4. Enter 4 in the Stop time (s) field to play back or analyze a subset of 
the logged signal ending four seconds after the start of the log. If the 
log is not at least 4 seconds long, enter an appropriate value in the Stop 
time (s) field. 

5. In the Logged signal listbox, right-click the signal from the second log 
and select Activate from the shortcut menu to make that signal the 
active log.

Note You also can right-click a log in the Logged Data window and select Make Active 
Log from the shortcut menu to make that log the active log.

6. Switch to the Data View tab. The graph display on the Data View tab 
automatically updated to display the signal from the second log when 
you made that signal the active signal. 

7. Click the Run button, shown at left. LabVIEW SignalExpress filters 
the subset of the signal you specified on the Playback Options tab and 
displays the resulting filtered signal on the Data View tab.

Refer to the LabVIEW SignalExpress Help for more information about 
logging data, such as specifying alarm conditions, events, and playback 
options.



© National Instruments Corporation 5-1 Getting Started with LabVIEW SignalExpress

5
Performing Sweep Measurements

You can use LabVIEW SignalExpress to automate measurements to 
characterize and validate designs by creating sweep operations. A design 
can be anything you create and want to characterize and validate with 
LabVIEW SignalExpress. You can use the sweep measurements to gather 
data from designs over a range of conditions to document the performance 
of the designs. For example, you can use sweep operations to vary the 
frequency of a stimulus signal or vary the level of a supply voltage while 
taking measurements to characterize designs.

This chapter teaches you how to set up sweep operations using the Sweep 
step in LabVIEW SignalExpress. You learn how to characterize the 
performance of a filter by sweeping through a range of frequency values 
and measuring the output of the filter. You also learn how to display sweep 
results and perform multidimensional sweeps for more complex 
measurements.

Defining Sweep Ranges and Outputs
You can use the Sweep step in LabVIEW SignalExpress to define 
automated measurements for complex, repeatable sweep operations.

Complete the following steps to define a frequency range in a sample 
project to sweep through a filter.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click Sweep.seproj.

2. Click the Run button, shown at left, to run the project continuously.

The project generates a sine wave stimulus signal using the Create 
Analog Signal step, passes it through a bandpass elliptic filter using the 
Filter step, measures the RMS level of the filter output using the 
Amplitude and Levels step, and converts the level to decibels (dB) 
using the Formula step. The Filter step acts as a simulated unit under 
test, so the project uses no hardware. However, you also can sweep 
physical signals generated from a National Instruments arbitrary 
waveform generator, function generator, dynamic signal analyzer, or 
multifunction I/O (MIO) device.
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3. Click the Stop button to stop the project.

4. Click the Add Step button, shown at left, and select Execution 
Control»Sweep to add the Sweep step to the Project View.

5. On the Step Setup tab, click the Add button to display the list of 
sweepable parameters from each step in the project, as shown in 
Figure 5-1.

Figure 5-1.  Sweep Parameter Selection Dialog Box

6. Select the Frequency (Hz) parameter under Create Analog Signal 
and click the OK button.

The Sweep step encloses the Create Analog Signal step, which 
provides the signal to sweep.

7. On the Sweep Configuration page of the Step Setup tab, select 
Exponential from the Type pull-down menu.

8. Enter 1k in the Start: Frequency (Hz) field, and enter 40k in the 
Stop: Frequency (Hz) field.

9. Enter 150 in the Number of points field.
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The Sweep Configuration page appears as shown in Figure 5-2.

Figure 5-2.  Sweep Step Setup Tab

You use the Sweep step to specify a range of values to iterate through 
the Frequency (Hz) parameter of the Create Analog Signal step. The 
Create Analog Signal step uses the defined frequency range to 
generate a sine wave at each of these frequencies. You can use the 
Sweep step to iterate through any sweepable parameter value of any 
sweepable step in a project.

10. Switch to the Sweep Output page.

11. Click the Add button to display the list of sweepable outputs from each 
step in the project.

12. Select the response amplitude in dB output under Formula and click 
the OK button to plot this measurement against the swept Frequency 
(Hz) parameter.

The Sweep step creates a loop around all the steps in the Project View 
to include all the steps in the sweep operation.
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Running Sweep Measurements
Complete the following steps to run the sweep measurement.

1. Switch to the Data View tab, click the down arrow on the Run button, 
and select Run Once to execute the sweep measurement.

The white stimulus signal output on the graph display iterates through 
the specified range of frequencies.

2. Drag the response amplitude in dB vs. Frequency signal from the 
bottom of the Sweep loop to the Data View tab to display the output 
of the sweep.

LabVIEW SignalExpress creates a new graph display. The data from a 
sweep operation is an XY array that requires a separate display, as 
shown in Figure 5-3.

Figure 5-3.  Sweep.seproj
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3. Select the Run Once option again to execute the sweep.

The frequency response of the Filter step plots on the new graph 
display while the project runs. The graph shows the transfer function 
of the filter, or the amplitude output expressed in decibels versus the 
frequency.

Note By default, LabVIEW SignalExpress does not clear displays on the Data View tab 
between iterations of a sweep. Because the frequency response of the Filter step is the same 
for each iteration, the graph that displays the signal does not appear to update when you 
run the project. You can use the Data page of the Options dialog box to specify whether 
LabVIEW SignalExpress clears displays between iterations of a sweep. Select Tools»
Options to display the Options dialog box.

4. Double-click the Filter step to display the filter specifications on the 
Step Setup tab.

The frequency response of the filter in the Filter Magnitude 
Response (dB) graph matches the graph in the Data View.

5. Select File»Save Project As and save the project as 
My Sweep.seproj in the SignalExpress\Examples\Tutorial 
directory.

You can use the Sweep step to sweep multiple parameters simultaneously 
by adding additional parameters on the Sweep Configuration page of the 
Sweep Step Setup tab. Sweeping two or more parameters simultaneously 
is called a parallel sweep. For example, if you want to vary the amplitude 
of a stimulus signal, you can run a parallel sweep to maximize the precision 
of the acquisition by varying the input range of a digitizer or MIO device 
as you vary the signal level. As the signal level increases, you can increase 
the input range of the measurement device to ensure you use the entire 
resolution for the measurement.

Running Multidimensional Sweeps
Use multidimensional, or nested, sweeps to iterate through one range while 
you vary another range. For example, if you want to sweep through 
frequencies of a stimulus signal at different amplitudes, run a nested sweep. 
You can set the amplitude to level 1 and sweep through frequencies, then 
set the amplitude to level 2 and sweep through frequencies, and so on. You 
can build a nested sweep by right-clicking a Sweep step in a project and 
selecting Add nested sweep from the shortcut menu to add another sweep 
loop. 
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Complete the following steps to run a sample nested sweep project.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click Nested 
Sweep.seproj.

2. Click the Run button to run the project.

Each iteration of the inner sweep loop sweeps the frequency of the 
stimulus signal. The outer sweep loop varies the low and high cutoff 
frequencies of the Filter step. Each iteration appears in real time on the 
upper graph display, and then appears on the lower display to show all 
the sweeps at each cutoff frequency setting, as shown in Figure 5-4.

Figure 5-4.  Nested Sweep.seproj

3. Click the Stop button, shown at left, to stop the project.
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6
Extending LabVIEW SignalExpress 
Projects with LabVIEW

You can use LabVIEW SignalExpress to define automated measurements 
by using built-in steps for acquiring, generating, analyzing, or logging 
signals. You can extend the functionality of LabVIEW SignalExpress 
projects using LabVIEW in the following ways:

• Build a VI in LabVIEW and import the VI into LabVIEW 
SignalExpress to provide custom step functionality and expand the 
number of steps available in LabVIEW SignalExpress.

• Convert a LabVIEW SignalExpress project to a LabVIEW block 
diagram to continue development in LabVIEW.

You must have LabVIEW 7.1 or later to complete the exercises in this 
chapter.

Importing LabVIEW VIs into LabVIEW SignalExpress 
as Steps

Use the Run LabVIEW VI step in LabVIEW SignalExpress to call custom 
LabVIEW VIs. You can call a LabVIEW VI from LabVIEW 
SignalExpress to do the following:

• Control GPIB instruments

• Control National Instruments hardware that LabVIEW SignalExpress 
does not support

• Read or write data to more file formats

• Display operator instructions in a pop-up dialog box

• Define a measurement algorithm
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Complete the following steps to import a VI from LabVIEW with the Run 
LabVIEW VI Step.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click User 
Step.seproj.

This project uses the Create Analog Signal step to generate a signal.

2. Click the Add Step button, shown at left, and select Run LabVIEW 
VI»Run LabVIEW 8.6 VI. 

The VI you run in this exercise was saved in LabVIEW 8.6. You must 
use the version of the Run LabVIEW VI step that matches the version 
of LabVIEW in which you saved the VI.

3. On the Step Setup tab, click the browse button in the Select VI section 
and select Limiter-LV86.vi in the LabVIEW SignalExpress\
Examples\Tutorial directory. The Limiter-LV86 VI accepts a 
time-domain waveform as an input, clips the signal above and below 
values that you specify on the Step Setup tab, and returns the clipped 
waveform as an output signal.

When you import a LabVIEW VI, LabVIEW SignalExpress maps the 
inputs of the VI as parameters and the outputs of the VI as output 
signals in LabVIEW SignalExpress.

You can define whether the inputs for VIs become input signals or 
parameters. An input signal appears in the Project View as an input to 
a step, which means you can pass signals as inputs to a VI. A parameter 
is a value you can configure on the Step Setup tab of a step. You also 
can sweep parameters dynamically using the Sweep step. In this 
project, the VI has an input signal, Time waveform in, and scalar 
parameters, Upper limit and Lower limit.
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Verify that the Step Setup tab appears as shown in Figure 8-1.

Figure 6-1.  Limiter VI Step Setup Tab

4. Click the Run button, shown at left, to run the project. 

5. Switch to the Data View tab and drag the Clipped waveform out 
output signal from the Run LabVIEW 8.6 VI step to the Data View 
tab.

6. Double-click the Run LabVIEW 8.6 VI step to display the Step Setup 
tab.

7. Select the Configure VI page to display the VI. 

8. Enter new values in the Upper limit and Lower limit fields. For 
example, enter 100 in the Upper limit field.

9. Switch to the Data View tab. The Clipped waveform out signal 
changes to reflect the changes you made.

10. Click the Stop button, shown at left, to stop the project.

11. Select File»Save As and save the project as My User Step.seproj.

12. Select File»Close Project to close the project.
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Refer to the LabVIEW SignalExpress Help for more information about 
using LabVIEW VIs in LabVIEW SignalExpress and building VIs that 
work well in LabVIEW SignalExpress.

Converting LabVIEW SignalExpress Projects to 
LabVIEW Block Diagrams

LabVIEW SignalExpress can convert LabVIEW SignalExpress projects 
into LabVIEW block diagrams.

Note To convert a LabVIEW SignalExpress project to a LabVIEW VI, you must have the 
LabVIEW 7.1 Full Development System or later installed.

Complete the following steps to convert a LabVIEW SignalExpress project 
to a LabVIEW block diagram.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial\Solutions and double-click My First 
Project.seproj.

2. Select Tools»Generate Code»LabVIEW Diagram.

3. Specify a filename and location for the new LabVIEW VI and click the 
OK button. LabVIEW SignalExpress generates the new VI and opens 
the VI in the last version of LabVIEW you opened on the machine.

The resulting LabVIEW block diagram reflects the execution of the 
project in LabVIEW SignalExpress. The LabVIEW block diagram 
consists of LabVIEW Express VIs wired together. Each Express VI 
correlates to a step in the LabVIEW SignalExpress project. You can 
double-click an Express VI to display a configuration dialog box that 
is identical to the Step Setup tab in LabVIEW SignalExpress. You also 
can right-click an Express VI and select Open Front Panel from the 
shortcut menu to convert the Express VI into a LabVIEW subVI. You 
can view the block diagram to see how the LabVIEW block diagram 
executes and modify the functionality of the VI. When you convert an 
Express VI into a subVI, you cannot convert the subVI back into an 
Express VI.

Note When you convert a LabVIEW SignalExpress project with logging, LabVIEW 
SignalExpress generates a LabVIEW block diagram with one Express VI. You cannot 
convert the generated Express VI into a subVI.
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7
Where to Go from Here

Refer to the following resources for more information about LabVIEW 
SignalExpress.

LabVIEW SignalExpress Sample Projects
LabVIEW SignalExpress provides a variety of sample projects that 
demonstrate more capabilities of LabVIEW SignalExpress. These projects 
are located in the SignalExpress\Examples directory. Review these 
examples to learn more about the features of LabVIEW SignalExpress or 
to start with a project that closely resembles your needs.

Using Hardware with LabVIEW SignalExpress
LabVIEW SignalExpress supports a variety of National Instruments 
hardware for acquiring and generating signals. You can generate or acquire 
and log analog signals in LabVIEW SignalExpress using National 
Instruments MIO devices, dynamic signal acquisition devices, high-speed 
digitizers, or arbitrary waveform generator and function generator devices. 
You also can synchronize multiple devices in a system by sharing clocks 
and trigger signals between devices. Refer to the LabVIEW SignalExpress 
Help by selecting Help»LabVIEW SignalExpress Help for more 
information about using hardware with LabVIEW SignalExpress.

Web Resources
Refer to the National Instruments Web site at ni.com/signalexpress 
for resources such as example projects, technical documents, and 
LabVIEW VIs written for use in LabVIEW SignalExpress.

http://www.ni.com/signalexpress
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A
Technical Support and 
Professional Services

Visit the following sections of the award-winning National Instruments 
Web site at ni.com for technical support and professional services:

• Support—Technical support resources at ni.com/support include 
the following:

– Self-Help Technical Resources—For answers and solutions, 
visit ni.com/support for software drivers and updates, a 
searchable KnowledgeBase, product manuals, step-by-step 
troubleshooting wizards, thousands of example programs, 
tutorials, application notes, instrument drivers, and so on. 
Registered users also receive access to the NI Discussion Forums 
at ni.com/forums. NI Applications Engineers make sure every 
question submitted online receives an answer.

– Standard Service Program Membership—This program 
entitles members to direct access to NI Applications Engineers 
via phone and email for one-to-one technical support as well as 
exclusive access to on demand training modules via the Services 
Resource Center. NI offers complementary membership for a full 
year after purchase, after which you may renew to continue your 
benefits. 

For information about other technical support options in your 
area, visit ni.com/services, or contact your local office at 
ni.com/contact. 

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local 
NI office or visit ni.com/alliance.

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp04
http://www.ni.com/forums
http://www.ni.com/services
http://www.ni.com/contact
http://www.ni.com
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp04
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp08
http://digital.ni.com/productpages/nialliance.nsf/main?readform
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If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.

http://www.ni.com
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp10
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À propos de ce manuel

Utilisez ce manuel pour vous familiariser avec les mesures interactives dans 
LabVIEW SignalExpress et les fonctionnalités de base de LabVIEW 
SignalExpress que vous utilisez pour acquérir et analyser des signaux.

Ce manuel contient des exercices qui vous aident à prendre en main 
LabVIEW SignalExpress. Ces exercices vous apprennent comment 
exécuter des projets, configurer des étapes, manipuler des signaux, 
configurer des mesures de balayage, enregistrer des données et étendre les 
possibilités de LabVIEW SignalExpress avec l’environnement de 
programmation graphique LabVIEW.

Conventions
Les conventions suivantes apparaissent dans ce manuel :

» Le symbole » vous guide à travers les éléments de menu imbriqués et les 
options de boîte de dialogue pour une action finale. Ainsi, la séquence 
Fichier»Mise en page»Options indique qu’il vous faut dérouler le menu 
Fichier, sélectionner l’élément Mise en page et sélectionner Options dans 
la dernière boîte de dialogue.

Cette icône représente une remarque qui vous donne des informations 
importantes.

Cette icône représente une astuce qui vous donne des recommandations.

gras Du texte en caractères gras représente un élément que vous devez 
sélectionner ou sur lequel vous devez cliquer dans le logiciel, comme les 
éléments de menu ou les options de boîte de dialogue. Du texte gras indique 
également des noms d’entrées et de sorties, des noms de paramètres, des 
boîtes de dialogue, des sections de boîte de dialogue et des noms de menus.

Le texte en italique Signale les variables, la mise en valeur, une référence croisée ou une 
introduction à un concept-clé. Il indique également du texte que vous devez 
remplacer par un mot ou une valeur.

monospace Du texte dans cette police indique du texte ou des caractères qui doivent 
être entrés avec le clavier. Cette police est également utilisée pour les noms 
des disques durs, des chemins, des répertoires, des programmes, des 
sous-programmes, des noms des périphériques, des fonctions, des 
opérations, des variables et des noms de fichiers et d’extensions.
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Documentation associée
Reportez-vous à l’Aide LabVIEW Signal Express, disponible en 
sélectionnant Aide»Aide LabVIEW Signal Express, pour obtenir des 
informations complémentaires.
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1
Initiation à LabVIEW 
SignalExpress

National Instruments offre des solutions innovatrices aux scientifiques et 
aux ingénieurs pour construire des systèmes de mesure automatisés basés 
sur les plates-formes et les ordinateurs conformes aux normes de 
l’industrie. National Instruments développe des environnements de 
programmation robustes, à la pointe de la technologie, comme LabVIEW 
pour le développement graphique, LabWindows™/CVI™ pour la 
programmation en C ANSI et Measurement Studio pour la programmation 
avec Microsoft Visual Studio. Vous pouvez utiliser ces outils de 
programmation avec le matériel de mesure de National Instruments et des 
interfaces pour instruments traditionnels afin de construire des systèmes 
d’instrumentation virtuelle avancés.

LabVIEW SignalExpress optimise l’instrumentation virtuelle pour les 
ingénieurs concepteurs en offrant des mesures interactives instantanées qui 
ne requièrent aucune programmation. Vous pouvez utiliser LabVIEW 
SignalExpress de manière interactive pour acquérir, générer, analyser, 
comparer, importer et enregistrer des signaux. Vous pouvez comparer des 
données de conception avec des données de mesure en une étape. 
LabVIEW SignalExpress apporte la simplicité d’utilisation et les 
performances de l’instrumentation virtuelle aux personnes qui doivent 
acquérir ou analyser des signaux sans programmer des applications. Vous 
pouvez aussi étendre les fonctionnalités de LabVIEW SignalExpress en 
important un VI (instrument virtuel) personnalisé créé dans 
l’environnement de développement graphique LabVIEW ou en 
convertissant un projet LabVIEW SignalExpress en un diagramme 
LabVIEW ce qui vous permet de poursuivre le développement dans 
l’environnement LabVIEW. Reportez-vous au chapitre 6, Extension des 
projets LabVIEW SignalExpress avec LabVIEW, pour obtenir des 
informations complémentaires sur les fonctionnalités avancées de 
LabVIEW SignalExpress.

Ce chapitre offre des informations sur la configuration système requise, les 
instructions d’installation, les versions et les options de licences 
disponibles pour LabVIEW SignalExpress.
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Installation de LabVIEW SignalExpress
Avant de commencer les exercices de ce manuel, vous devez installer 
LabVIEW SignalExpress. Le programme d’installation de LabVIEW 
SignalExpress installe le logiciel en 10 minutes environ.

Configuration système minimale requise
National Instruments recommande la configuration suivante afin 
d’optimiser les performances d’exécution de LabVIEW SignalExpress :

• 512 Mo de mémoire

• Un processeur Pentium 4 ou équivalent (Pentium III ou Celeron 
600 MHz minimum)

Installation
Effectuez les étapes suivantes pour installer LabVIEW SignalExpress sous 
Windows 2000/XP/Vista.

Remarque Si vous installez LabVIEW SignalExpress à partir du DVD de la plate-forme 
LabVIEW 8.6, vous n’avez pas besoin d’effectuer de réinstallation en utilisant le média 
comme cela est décrit dans cette section. Reportez-vous aux Notes d’information 
LabVIEW pour consulter des instructions sur l’installation au moyen du DVD.

1. Quittez tous les programmes avant d’exécuter l’installeur de 
LabVIEW SignalExpress. Il se peut que des applications qui 
s’exécutent en arrière-plan, comme des utilitaires de détection de 
virus, ralentissent le processus d’installation.

2. Ouvrez une session en tant qu’administrateur ou en tant qu’utilisateur 
jouissant de privilèges d’administrateur.

3. Insérez le média d’installation de LabVIEW SignalExpress et suivez 
les instructions qui s’affichent à l’écran.

Remarque Le programme d’installation de LabVIEW SignalExpress copie les fichiers 
dans le répertoire <Program Files>\National Instruments\SignalExpress à 
moins que vous ne spécifiiez un autre emplacement.

4. Une fois l’installation terminée, vérifiez que le disque dur ne contient 
pas de virus et activez les programmes de détection de virus que vous 
aviez éventuellement désactivés.
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Les projets d’exemple que vous utilisez avec ce manuel sont situés dans le 
répertoire <Program Files>\National Instruments\
SignalExpress\Examples\Tutorial. Les solutions des exercices se 
trouvent dans le répertoire <Program Files>\National 
Instruments\SignalExpress\Examples\Tutorial\Solutions.

Versions de LabVIEW SignalExpress disponibles
LabVIEW SignalExpress est disponible dans les versions complète et 
limitée (LE). Reportez-vous au tableau suivant pour consulter une liste des 
fonctionnalités disponibles dans chaque version. 

Tableau 1-1.  Différences entre les versions complète et LE de LabVIEW SignalExpress

Complète LE

Support d’instruments

Plus de 300 instruments autonomes communs ✓ —

Visualisation et documentation

Traçage personnalisable ✓ ✓

Curseurs interactifs ✓ ✓

Enregistrer des signaux dans un fichier ✓ ✓

Imprimer et exporter des graphes ✓ ✓

Glisser - Déposer de données dans Microsoft Excel, Word et 
WordPad

✓ ✓

Mode opérateur avec édition par l’utilisateur limitée ✓ —

Traitement du signal

Filtres logiciels ✓ —

Mathématiques sur scalaires et waveforms ✓ —

Conversion analogique et numérique ✓ —

Comparaison interactive de signaux ✓ —

Chargement de données de simulation à partir de PSPICE, 
Multisim et d’autres logiciels SPICE

✓ —
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Mesures de temps et fréquence

Amplitude et niveaux ✓ —

Cadencement et transition ✓ —

Spectre de puissance ✓ —

Réponse en fréquence ✓ —

Mesures de distorsion ✓ —

Extraction de ton ✓ —

Fichier journal

Enregistrement limité des données (un journal par projet) ✓ ✓

Enregistrement illimité des données ✓ —

Alarmes et événements d’enregistrement ✓ —

Enregistrement avec conditions de démarrage et d’arrêt ✓ —

Automatisation des mesures

Balayage de paramètres ✓ —

Test de limite ✓ —

Déclenchement logiciel ✓ —

Mise en séquence ✓ —

Accès distant à des données

Lecture/Écriture de variables partagées ✓ —

Tableau 1-1.  Différences entre les versions complète et LE de LabVIEW SignalExpress (suite)

Complète LE
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Options relatives aux licences de LabVIEW 
SignalExpress

Cette section a pour but d’expliquer les polices relatives aux licences de 
LabVIEW SignalExpress. Ce document ne remplace pas le Contrat de 
licence logiciel National Instruments. Utilisez ce document seulement 
comme référence.

LabVIEW SignalExpress LE
La version limitée (LE), sans licence de LabVIEW SignalExpress vous 
donne accès à toutes les fonctionnalités qui figurent dans le tableau 1-1 
pendant 30 jours. Passée cette période, LabVIEW SignalExpress s’exécute 
en mode sans licence. Si vous n’activez pas une licence valide dans la 
période de 30 jours et que vous créez un projet qui contient des étapes sous 
licence, voici ce qui se passe :

• Chaque fois que vous ajoutez une étape sous licence, une boîte de 
dialogue vous demande d’activer le logiciel. 

• Vous ne pouvez pas enregistrer des projets.

• Les projets se ferment après 10 minutes.

Reportez-vous au site Web de National Instruments à ni.com/
signalexpress pour acheter la version complète de LabVIEW 
SignalExpress.

Version complète de LabVIEW SignalExpress
La version complète de LabVIEW SignalExpress vous offre toutes les 
fonctionnalités qui figurent dans le tableau 1-1. Vous pouvez activer la 
version complète de LabVIEW SignalExpress en utilisant le Gestionnaire 
de licences National Instruments, l’installeur de LabVIEW SignalExpress 
ou le site Web de National Instruments en vous rendant sur ni.com/
activate.
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2
Travailler avec des projets

Vous pouvez utiliser LabVIEW SignalExpress pour définir des procédures 
de mesure en ajoutant et en configurant des étapes dans un environnement 
de mesure interactif. Une étape est une fonction configurable qui acquiert, 
génère, analyse, charge ou enregistre des signaux. Le menu Ajouter une 
étape et la palette Ajouter une étape affichent les étapes disponibles dans 
LabVIEW SignalExpress. 

La plupart des étapes traitent des signaux en entrée et produisent des 
signaux en sortie. Vous pouvez configurer le fonctionnement d’une étape 
en spécifiant des valeurs dans l’onglet Configuration de l’étape propre à 
l’étape. Une séquence enregistrée d’étapes configurées constitue un projet 
LabVIEW SignalExpress.

Ce chapitre vous apprend à charger et à exécuter des projets existants et à 
configurer des étapes dans ces projets.

Ouverture d’un projet
Effectuez les étapes suivantes pour charger un projet d’exemple dans 
LabVIEW SignalExpress.

1. Lancez LabVIEW SignalExpress.

Notez que LabVIEW SignalExpress est divisé en affichages qui 
présentent différents types d’informations. L’affichage principal 
apparaît au milieu de la fenêtre d’application et contient des onglets. 
Si LabVIEW SignalExpress s’ouvre avec la configuration par défaut, 
les onglets Affichage des données, Options d’enregistrement et 
Documentation du projet apparaissent dans l’affichage principal. 

L’affichage principal est entouré d’affichages supplémentaires. Dans 
la configuration par défaut, la Vue du projet apparaît à gauche et l’aide 
contextuelle à droite.

Remarque Si LabVIEW SignalExpress détecte un périphérique matériel supporté, 
l’Affichage des voies apparaît en bas de la fenêtre d’application de LabVIEW 
SignalExpress.
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2. Si LabVIEW SignalExpress ne s’ouvre pas dans la configuration par 
défaut, sélectionnez Affichage»Réinitialiser la mise en page pour 
réinitialiser la configuration par défaut de l’application. Vous pouvez 
utiliser le menu Affichage pour afficher des onglets et des affichages 
ou réinitialiser la mise en page à tout moment.

3. Sélectionnez Aide»Ouvrir un exemple, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur le 
projet d’exemple First Project.seproj pour l’ouvrir. 

4. Observez la fenêtre qui apparaît, montrée avec l’aide contextuelle 
fermée dans la figure 2-1, pour vous familiariser avec les différents 
composants de LabVIEW SignalExpress. 

Figure 2-1.  First Project.seproj

1 Bouton Exécuter
2 Menu déroulant Zone de travail
3 Étape
4 Entrée

5 Sortie
6 Vue du projet
7 Fenêtre Données enregistrées

8 Affichage principal avec l’onglet 
Affichage des données visible

9 Bouton Enregistrer

5

8

5

3

4

2

91

6

7



Chapitre 2 Travailler avec des projets

© National Instruments Corporation 2-3 Initiation à LabVIEW SignalExpress

L’environnement LabVIEW SignalExpress est composé d’affichages 
qui présentent différents types d’informations. L’affichage principal 
apparaît au milieu de la fenêtre d’application et contient des onglets 
comme l’onglet Affichage des données. Des affichages 
supplémentaires entourent l’affichage principal et apparaissent avec 
des barres de titres individuelles. Par exemple, la Vue du projet est un 
affichage supplémentaire.

Exécution d’un projet et affichage de signaux
LabVIEW SignalExpress a plusieurs modes d’exécution. Vous pouvez 
exécuter des projets une fois, en continu ou pendant un nombre d’itérations 
ou une durée que vous spécifiez. Quand vous exécutez un projet une fois, 
LabVIEW SignalExpress exécute toutes les étapes du projet une fois. 
Quand vous exécutez un projet en continu, LabVIEW SignalExpress 
exécute toutes les étapes du projet en continu. Cliquez sur la flèche vers le 
bas du bouton Exécuter, montré à gauche, et sélectionnez Configurer 
l’exécution à partir du menu déroulant pour configurer le mode 
d’exécution d’un projet.

Les affichages de l’onglet Affichage des données se mettent à jour 
continuellement pendant qu’un projet s’exécute. Quand un projet 
s’exécute, vous pouvez changer les paramètres de configuration de la 
mesure en changeant les paramètres sur l’onglet Configuration de l’étape 
et voir les résultats immédiatement. Les projets qui s’exécutent en continu 
s’exécutent jusqu’à ce que le bouton Arrêter, montré à gauche, soit 
actionné. Le bouton Arrêter apparaît à la place du bouton Exécuter 
lorsqu’un projet s’exécute. 

Effectuez les étapes suivantes pour exécuter le projet d’exemple et afficher 
des signaux.

1. Cliquez sur le bouton Exécuter. Si la boîte de dialogue Informations 
sur l’exécution apparaît, cliquez sur le bouton Exécuter dans cette 
boîte de dialogue pour exécuter toutes les étapes du projet en continu.

Le projet charge un signal à partir d’un fichier texte et effectue deux 
opérations sur le signal : une mesure de l’amplitude et des niveaux et 
une mesure de distorsion. L’étape Amplitude et niveaux et l’étape 
Distorsion effectuent ces mesures, respectivement. Lorsque vous 
exécutez un projet, les étapes analysent des signaux en entrée et 
génèrent de nouveaux signaux en sortie comme résultat de l’analyse. 
Dans ce projet, l’étape Charger un fichier ASCII charge un signal 
sinusoïdal déformé, l’étape Amplitude et niveaux et l’étape Distorsion 
analysent le signal sinusoïdal et les deux étapes renvoient de nouvelles 
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sorties. Dans la Vue du projet, LabVIEW SignalExpress indique les 
entrées avec des flèches rouges et les sorties avec des flèches bleues.

L’affichage graphe dans l’onglet Affichage des données contient 
toujours le signal chargé, qui est un signal du domaine temporel. Les 
graphes affichent des signaux XY, du domaine fréquentiel ou du 
domaine temporel. 

2. Faites glisser le signal en sortie spectre exporté de l’étape Distorsion 
de la Vue du projet vers l’Affichage des données pour afficher le 
signal. 

LabVIEW SignalExpress crée un nouvel affichage graphe dans 
l’Affichage des données. LabVIEW SignalExpress n’affiche pas le 
signal spectre exporté sur le même graphe que le signal du domaine 
temporel car le signal spectre exporté est un signal du domaine 
fréquentiel. LabVIEW SignalExpress reconnaît automatiquement les 
différents types de signaux et les affiche en fonction de leur type.

Astuce Reportez-vous à l’Aide LabVIEW SignalExpress pour obtenir des informations 
complémentaires sur des types de signaux en sélectionnant Aide»Aide LabVIEW 
SignalExpress, en cliquant sur l’onglet Rechercher et en entrant "types de signaux". 
L’aide offre des informations sur l’utilisation des fonctionnalités de LabVIEW 
SignalExpress telles que les projets, les étapes et les signaux.

3. Faites glisser la sortie cc de l’étape Amplitude et niveaux vers l’onglet 
Affichage des données. 

LabVIEW SignalExpress crée à la fois un graphe et une table Légende 
pour afficher la mesure scalaire de la sortie cc. La table Légende 
affiche la valeur de chaque sortie et la couleur que LabVIEW 
SignalExpress utilise pour tracer la sortie sur le graphe attenant.

4. Faites glisser la sortie Veff de l’étape Amplitude et niveaux vers la 
table Légende pour afficher la mesure scalaire efficace.

LabVIEW SignalExpress crée une nouvelle ligne dans la table pour 
afficher la deuxième mesure. Le projet apparaît tel que le montre la 
figure 2-2.
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Figure 2-2.  Sorties de First Project.seproj

Configuration d’une étape
Une étape est une fonction configurable qui acquiert, génère, analyse, 
charge ou enregistre des signaux. Les étapes traitent des signaux en entrée 
et produisent des signaux en sortie. Vous pouvez configurer le 
fonctionnement d’une étape dans LabVIEW SignalExpress en spécifiant 
des valeurs dans l’onglet Configuration de l’étape de l’étape. Pendant 
qu’un projet s’exécute, vous pouvez modifier la configuration des étapes et 
afficher immédiatement le retour d’informations sur l’onglet Affichage 
des données. Ainsi, vous pouvez ajuster les mesures jusqu’à ce que vous 
obteniez les résultats escomptés.
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Effectuez les étapes suivantes pour configurer l’étape Distorsion et l’étape 
Amplitude et niveaux.

1. Double-cliquez sur l’étape Distorsion dans la Vue du projet. LabVIEW 
SignalExpress affiche l’onglet Configuration de l’étape pour l’étape 
Distorsion, comme le montre la figure 2-3.

Figure 2-3.  Onglet Configuration de l’étape Distorsion

Sur la page Configuration de l’onglet Configuration de l’étape, le 
champ Signaux à exporter (DHT) indique que l’étape Distorsion 
exporte le signal en entrée, et le graphe Signal exporté affiche un 
aperçu du signal. Le graphe Spectre de puissance exporté indique 
que l’étape applique un spectre de puissance sur le signal en entrée 
pour le convertir en signal du domaine fréquentiel, et le champ 
Résultats de la mesure affiche la fréquence fondamentale et la 
distorsion harmonique totale (DHT) du signal. L’étape génère le signal 
exporté et trois mesures sous forme de sorties : le spectre, la DHT et la 
fréquence fondamentale de l’entrée du signal du domaine temporel 
d’origine.
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2. Si l’aide contextuelle n’apparaît pas à droite de l’écran, sélectionnez 
Aide»Aide contextuelle pour afficher des informations de référence 
complètes sur l’étape. 

La partie supérieure de l’aide contextuelle affiche des informations sur 
l’étape, et la partie inférieure de l’aide contextuelle affiche des 
informations sur des paramètres spécifiques lorsque le curseur passe 
dessus. Déplacez le curseur sur le paramètre DHT (%) pour afficher 
des informations sur le paramètre.

3. Sur la page Configuration, sélectionnez Ton fondamental dans le 
menu déroulant Signaux à exporter (DHT).

Le graphe Spectre de puissance exporté passe de l’affichage du 
spectre du domaine fréquentiel du signal en entrée complet à 
l’affichage du spectre de fréquence du ton fondamental du signal en 
entrée uniquement. Le signal en sortie de l’étape Distorsion et 
l’affichage graphe de la sortie spectre exporté sur l’onglet Affichage 
des données des données se mettent à jour pour refléter la 
modification que vous avez apportée.

4. Sélectionnez Harmoniques uniquement dans le menu déroulant 
Signaux à exporter (DHT).

Le graphe Spectre de puissance exporté de l’onglet Configuration 
de l’étape et le graphe de la sortie sur l’onglet Affichage des données 
changent tous les deux pour afficher uniquement le spectre des signaux 
harmoniques du signal en entrée.

5. Cliquez sur l’étape Amplitude et niveaux dans la Vue du projet. 

L’onglet Configuration de l’étape qui affichait la configuration de 
l’étape Distorsion, affiche désormais la configuration de l’étape 
Amplitude et niveaux.
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6. Sélectionnez la page Entrée/Sortie pour afficher la liste des entrées et 
des sorties possibles pour cette étape, comme le montre la figure 2-4.

Figure 2-4.  Onglet Configuration de l’étape Amplitude et niveaux

7. Cochez les cases Exporter la valeur max., Exporter la valeur min. 
et Exporter la valeur de pic à pic pour configurer l’étape Amplitude 
et niveaux pour renvoyer trois mesures supplémentaires.

Trois sorties supplémentaires apparaissent dans la Vue du projet.

8. Passez à l’onglet Affichage des données.

9. Faites glisser les trois nouvelles sorties de la Vue du projet vers la table 
Légende de mesures scalaires. Les nouvelles sorties apparaissent sur 
le graphe attenant.

Remarque Si le projet s’exécute depuis quelques minutes, il se peut que vous deviez 
l’arrêter et le redémarrer pour voir tous les signaux scalaires sur le graphe. LabVIEW 
SignalExpress accumule des points de données pour des signaux que vous ajoutez à un 
graphe et de nouveaux signaux que vous ajoutez n’ont pas autant de points de données à 
afficher sur le graphe. 
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10. Cliquez sur le bouton Arrêter pour arrêter le projet.

Lorsque vous cliquez sur le bouton Arrêter, le projet arrête de 
s’exécuter après avoir terminé le cycle de fonctionnement actuel ou 
l’itération actuelle. Cliquez sur la flèche vers le bas à droite du bouton 
Arrêter et sélectionnez Abandonner dans le menu déroulant pour 
arrêter complètement le projet sans terminer l’itération en cours.

11. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le 
projet sous Mon premier projet.seproj dans le répertoire 
SignalExpress\Examples\Tutorial.

12. Sélectionnez Fichier»Fermer le projet pour fermer le projet.

Organisation, déplacement et suppression d’étapes
La plupart des étapes dans des projets LabVIEW SignalExpress requièrent 
des données en entrée. Certaines étapes ne peuvent fonctionner que si elles 
reçoivent des signaux d’étapes les précédant dans la Vue du projet. L’ordre 
dans lequel les étapes apparaissent dans la Vue du projet peut donc affecter 
le fonctionnement d’un projet. 

Pour les étapes qui ont une page Entrée ou Entrée/Sortie sur l’onglet 
Configuration de l’étape, le menu déroulant Signal en entrée de cette 
page n’affiche que des signaux compatibles exportés par une étape 
précédente. Lorsque la sortie d’une étape devient l’entrée d’une autre étape, 
les deux étapes deviennent dépendantes l’une de l’autre et s’exécutent de 
manière séquentielle, à la même fréquence. La première étape génère un 
signal en sortie que la deuxième étape doit recevoir comme entrée avant de 
pouvoir s’exécuter.

Vous pouvez déplacer une étape dans un projet en la faisant glisser vers le 
haut ou vers le bas dans la Vue du projet. Vous pouvez supprimer une étape 
en faisant un clic droit dessus dans la Vue du projet et en sélectionnant 
Supprimer dans le menu local. Lorsque vous déplacez ou supprimez une 
étape, l’état des signaux du projet change. Par exemple, si vous supprimez 
une étape qui génère des signaux en sortie, le fonctionnement du projet est 
brisé si l’un des signaux en sortie supprimés est l’entrée d’une autre étape 
et un indicateur d’erreur apparaît dans la Vue du projet. Vous pouvez aussi 
couper, copier et coller des étapes dans un projet en appuyant 
respectivement sur les touches <Ctrl-X>, <Ctrl-C> et <Ctrl-V>, ou en 
cliquant avec le bouton droit sur la Vue du projet et en sélectionnant 
Couper, Copier, Coller avant l’étape sélectionnée ou Coller après 
l’étape sélectionnée dans le menu local.
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Gestion des erreurs et des mises en garde
Si une erreur se produit pendant qu’un projet s’exécute, un indicateur 
d’erreur, montré à gauche, apparaît dans la Vue du projet sur l’étape dans 
laquelle l’erreur s’est produite. Double-cliquez sur l’étape où l’erreur s’est 
produite pour afficher sa description au bas de l’onglet Configuration de 
l’étape. Cliquez sur le bouton Détails à droite de la description de l’erreur 
pour afficher la description complète.

LabVIEW SignalExpress enregistre toutes les erreurs et les mises en garde 
dans l’onglet Journal d’événements pendant l’exécution d’un projet. Pour 
afficher l’onglet Journal d’événements, sélectionnez Affichage»Journal 
d’événements. Reportez-vous à l’Aide LabVIEW SignalExpress pour 
obtenir des informations complémentaires sur les erreurs et les mises en 
garde en sélectionnant Aide»Aide LabVIEW SignalExpress, en cliquant 
sur l’onglet Rechercher et en entrant erreurs.
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3
Manipulation de signaux

Vous pouvez utiliser LabVIEW SignalExpress pour générer et analyser des 
signaux afin d’évaluer des projets de conception sans programmation. Ce 
chapitre vous apprend à travailler avec des signaux dans LabVIEW 
SignalExpress, en vous indiquant notamment comment tracer des signaux 
sur des graphes, importer des signaux d’un fichier, aligner et comparer 
deux signaux de manière interactive et enregistrer des signaux dans un 
fichier.

Représentation de signaux dans des graphes
Effectuez les étapes suivantes pour tracer des signaux dans un projet 
d’exemple et examiner visuellement les signaux à l’aide de curseurs.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur 
Signals.seproj. Ce projet configure l’étape Créer un signal 
analogique pour qu’elle permette de créer un signal carré et l’étape 
Filtre pour réaliser un filtre Butterworth passe-bas.

2. Faites glisser la sortie step signal de l’étape Créer un signal analogique 
vers l’onglet Affichage des données.

3. Faites glisser la sortie filtered step de l’étape Filtre vers l’onglet 
Affichage des données.

Comme les signaux step signal et filtered step sont tous deux des 
signaux temporels, ils apparaissent sur le même affichage graphe. Si 
vous essayez d’afficher des signaux de types différents en les faisant 
glisser sur le même affichage, LabVIEW SignalExpress crée un nouvel 
affichage.

4. Cliquez sur le bouton Ajouter un affichage, montré à gauche, pour 
créer un nouvel affichage.

5. Faites glisser la sortie filtered step de l’étape Filtre vers le nouvel 
affichage.
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6. Faites un clic droit sur le nouvel affichage et sélectionnez Éléments 
visibles»Curseurs dans le menu local pour afficher deux curseurs 
interactifs, comme le montre la figure 3-1.

Figure 3-1.  Signals.seproj

Quand vous déplacez les curseurs, LabVIEW SignalExpress affiche 
les valeurs x et y des curseurs dans le tableau de curseurs au bas de 
l’onglet Affichage des données.

7. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le 
projet sous Mes signaux.seproj dans le répertoire 
SignalExpress\Examples\Tutorial.
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Importation d’un signal à partir d’un fichier
Vous pouvez importer des signaux de formats de fichier standard comme 
des fichiers ASCII délimités par des virgules ou des tabulations et des 
fichiers de données de mesures LabVIEW (.lvm). Vous pouvez aussi 
importer des signaux à partir de résultats simulés d’outils EDA 
(de conception électronique assistée par ordinateur) comme des 
simulateurs SPICE.

Suivez les étapes ci-après pour importer un signal à partir d’un fichier.

1. Cliquez avec le bouton droit sur la Vue du projet et sélectionnez 
Charger/Enregistrer des signaux»Signaux analogiques»Charger 
un fichier ASCII dans le menu local pour ajouter l’étape Charger un 
fichier ASCII à la Vue du projet. L’onglet Configuration de l’étape 
de l’étape Charger un fichier ASCII apparaît. Cette étape analyse un 
fichier ASCII et affiche les signaux dans le fichier.

Remarque Vous pouvez ajouter des étapes à un projet à partir du menu Ajouter une étape, 
de la palette Ajouter une étape ou à partir du menu local qui apparaît quand vous cliquez 
avec le bouton droit sur la Vue du projet.

2. Sur l’onglet Configuration de l’étape, cliquez sur le bouton Parcourir, 
montré à gauche puis naviguez vers le répertoire SignalExpress\
Examples\Tutorial et double-cliquez sur le fichier Step 
Response.txt.

Dans la section Aperçu du fichier, la colonne 1 affiche les 
informations d’horodatage et la colonne 2 indique les valeurs de 
tension réelles du signal.

3. Passez à la page Signaux à importer de l’onglet Configuration de 
l’étape pour afficher les signaux disponibles dans le fichier.

4. Cochez l’option Colonne 2 pour importer ce signal et désélectionnez 
l’option Colonne 1.

L’onglet Configuration de l’étape affiche un aperçu du signal sur le 
graphe Signal importé.

5. Sélectionnez Colonne 1 dans le menu déroulant Valeurs X en entrée 
pour définir les données de l’axe des x du signal aux valeurs 
appropriées.

6. Passez à l’onglet Affichage des données.

7. Dans la Vue du projet, développez la sortie Step Response.txt de 
l’étape Charger un fichier ASCII.



Chapitre 3 Manipulation de signaux

Initiation à LabVIEW SignalExpress 3-4 ni.com

8. Faites un clic droit sur la sortie Colonne 2 dans la Vue du projet et 
sélectionnez Renommer dans le menu local.

9. Entrez réponse indicielle et appuyez sur la touche <Entrée> pour 
renommer la sortie.

10. Faites glisser la nouvelle sortie réponse indicielle de l’étape Charger 
un fichier ASCII vers l’affichage inférieur sur l’onglet Affichage des 
données.

Le signal filtered step ressemble au front montant de la sortie réponse 
indicielle, comme le montre la figure 3-2.

Figure 3-2.  Signaux de Signals.seproj

11. Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.

Alignement et comparaison de signaux
Bien que le signal filtered step et la sortie réponse indicielle montrent tous 
les deux un overshoot sur le front montant, il est difficile d’évaluer leur 
similarité car ces signaux proviennent de sources différentes et ont une 
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amplitude et un cadencement différents. Toutefois, vous pouvez utiliser 
l’étape Alignement interactif pour aligner et comparer deux signaux, de 
sorte que vous puissiez choisir quel type d’informations vous voulez 
exporter de l’opération pour pouvoir les utiliser dans le projet.

Suivez les étapes ci-après pour aligner deux signaux dans le projet Mes 
signaux.seproj.

1. Développez la sortie Step Response.txt, cliquez avec le bouton droit 
sur la sortie réponse indicielle et sélectionnez Envoyer vers»
Traitement»Signaux analogiques»Alignement interactif dans le 
menu local pour transmettre le signal réponse indicielle de l’étape 
Charger un fichier ASCII à l’étape Alignement interactif.

L’étape sélectionne les deux signaux les plus récents dans le projet à 
utiliser comme entrées et affiche les signaux sur les graphes de l’onglet 
Configuration de l’étape, comme le montre la figure 3-3.

Figure 3-3.  Onglet de configuration de l’étape Alignement interactif

Lorsque vous ajoutez une étape à un projet, LabVIEW SignalExpress 
sélectionne les signaux en entrée en fonction des types de signaux que 
l’étape accepte. Par exemple, l’étape Alignement interactif ne peut être 
utilisée que sur des signaux du domaine temporel. Par conséquent, 
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l’étape sélectionne comme entrées les deux signaux du domaine 
temporel créés dans le projet. 

Remarque Pour changer les signaux en entrée d’une étape, sélectionnez différents signaux 
dans le menu déroulant des signaux compatibles sur la page Entrée ou Entrée/Sortie de 
l’onglet Configuration de l’étape ou cliquez sur la flèche vers le bas qui apparaît à côté 
du nom de l’entrée de l’étape dans Vue du projet.

2. Cliquez sur le signal rouge dans le graphe Signaux en entrée et 
faites-le glisser vers un autre point du graphe. Le graphe Signal 
résultant de la comparaison se met à jour pour afficher la nouvelle 
différence calculée entre les signaux.

Vous pouvez faire glisser, étendre et réduire des signaux sur le graphe.

3. Essayez d’aligner les fronts montants de deux signaux en faisant 
glisser un signal dans le graphe. Cliquez sur un signal pour définir un 
point d’ancrage et maintenez la touche <Alt> enfoncée tout en faisant 
glisser le signal pour l’étendre autour de ce point d’ancrage dans le 
sens des x et des y.

Sur la page Alignement de l’onglet Configuration de l’étape, l’étape 
calcule et affiche le gain des x et des y et les valeurs d’offset dont vous 
avez besoin pour atteindre les spécifications d’alignement lorsque 
vous faites glisser les signaux.

4. Sélectionnez Auto - Créneau dans le menu déroulant Mode pour 
aligner les signaux. LabVIEW SignalExpress calcule l’alignement en 
utilisant des algorithmes intégrés.

Le graphe Signal résultant de la comparaison sur l’onglet 
Configuration de l’étape affiche la différence entre les deux signaux.

5. Sur la page Entrée/Sortie, cochez l’option Exporter les signaux 
alignés pour ajouter les signaux aux sorties de l’étape.

6. Passez à l’onglet Affichage des données.

7. Cliquez sur le bouton Ajouter un affichage pour ajouter un troisième 
affichage.

8. Faites glisser les sorties référence alignée et test aligné de l’étape 
Alignement interactif dans le nouveau graphe pour afficher les signaux 
alignés.

9. Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.
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Types de signaux dans LabVIEW SignalExpress
Certaines étapes, comme l’étape Arithmétique, peuvent fonctionner avec 
plusieurs types de signaux. Par exemple, vous pouvez utiliser l’étape 
Arithmétique pour manipuler des signaux des domaines fréquentiel et 
temporel. L’étape Arithmétique adapte son comportement en fonction du 
type de signaux en entrée que vous sélectionnez pour cette étape. Par 
exemple, si vous ajoutez deux signaux du domaine temporel, LabVIEW 
SignalExpress ajoute uniquement leur amplitude. Toutefois, si vous 
ajoutez deux signaux de phase du domaine fréquentiel, LabVIEW 
SignalExpress ajoute le seuil de décalage approprié.

Reportez-vous à l’Aide LabVIEW SignalExpress pour obtenir des 
informations complémentaires sur des types de signaux en sélectionnant 
Aide»Aide LabVIEW SignalExpress, en cliquant sur l’onglet 
Rechercher et en entrant "types de signaux".

Exportation et impression de signaux
Vous pouvez utiliser LabVIEW SignalExpress pour documenter des 
signaux ou continuer des analyses dans d’autres applications logicielles. 
Cette section vous apprend comment exporter des signaux, notamment en 
les envoyant dans un fichier ASCII, en envoyant les données dans 
Microsoft Excel, en imprimant des signaux et en utilisant la fonctionnalité 
de documentation intégrée pour documenter le projet LabVIEW 
SignalExpress.

Enregistrement de signaux dans un fichier
Effectuez les étapes suivantes pour enregistrer un signal du projet Mes 
signaux.seproj dans un fichier.

1. Cliquez sur le bouton Ajouter une étape, montré à gauche, pour 
afficher la palette Ajouter une étape.

2. Sélectionnez Charger/Enregistrer des signaux»Signaux 
analogiques»Enregistrer au format ASCII//LVM pour ajouter 
l’étape Enregistrer au format ASCII//LVM à la Vue du projet. L’onglet 
Configuration de l’étape de l’étape Enregistrer au format 
ASCII//LVM apparaît.

3. Cliquez sur la page Signaux de l’onglet Configuration de l’étape et 
sélectionnez filtered step dans le menu déroulant Données en entrée.
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4. Sur la page Paramètres du fichier, spécifiez où enregistrer le fichier 
texte que vous créez. Cliquez sur le bouton Parcourir à côté du champ 
Chemin du fichier à exporter, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et entrez signal 
filtré.txt comme nom de fichier.

5. Sélectionnez Remplacer dans le menu déroulant Si le fichier existe.

6. Sélectionnez ASCII générique (.txt) dans le menu déroulant Type du 
fichier à exporter.

Vous pouvez utiliser l’étape Charger/Enregistrer les signaux pour 
enregistrer des données dans un fichier chaque fois que le projet 
s’exécute.

7. Cliquez sur la flèche vers le bas du bouton Exécuter et sélectionnez 
Exécuter une fois pour exécuter le projet et enregistrer le signal 
résultant dans le fichier ASCII spécifié.

8. Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.

9. Sélectionnez Fichier»Fermer le projet pour fermer le projet.

10. Naviguez vers le fichier signal filtré.txt et ouvrez-le dans un 
éditeur de texte pour voir les valeurs du signal. Dans LabVIEW 
SignalExpress, vous pouvez utiliser l’étape Charger un fichier ASCII 
pour réimporter le signal dans un projet.

Exportation de signaux dans Microsoft Excel
Pour exporter des données de signaux dans Microsoft Excel, lancez Excel 
et faites glisser le signal en sortie d’une étape de LabVIEW SignalExpress 
dans un fichier tableur Excel. Vous pouvez aussi cliquer avec le bouton 
droit sur un affichage de l’onglet Affichage des données et sélectionner 
Exporter vers»Microsoft Excel pour exporter toutes les données de 
l’affichage.

Impression de signaux
Pour imprimer une image d’un graphe, ouvrez l’onglet Affichage des 
données et sélectionnez Fichier»Imprimer»Imprimer : Affichage des 
données.
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Création de rapports dans LabVIEW SignalExpress
Sélectionnez Affichage»Documentation du projet pour afficher l’onglet 
Documentation du projet. Vous pouvez utiliser cet onglet pour décrire un 
projet en utilisant du texte et des images comme des graphes. Vous pouvez 
faire glisser une sortie d’étape de la Vue du projet vers l’onglet 
Documentation du projet pour afficher un graphe du signal en sortie. Si 
le projet est en cours d’exécution, le graphe sur l’onglet Documentation 
du projet se met automatiquement à jour pour représenter la valeur 
actuelle de la sortie de l’étape. 

Pour imprimer la documentation, affichez l’onglet Documentation du 
projet et sélectionnez Fichier»Imprimer»Imprimer la documentation 
ou cliquez sur le bouton Imprimer la documentation. Pour exporter la 
documentation au format HTML, affichez l’onglet Documentation du 
projet et sélectionnez Fichier»Exporter»Exporter la documentation en 
HTML.
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4
Enregistrement des données

Vous pouvez utiliser LabVIEW SignalExpress pour enregistrer dans un 
fichier journal, enregistrer et analyser vos mesures. Vous pouvez 
enregistrer n’importe quelle sortie d’étape du domaine temporel, double, de 
type entier non signé 32 bits ou booléen. Vous pouvez aussi analyser et 
traiter les données ainsi enregistrées en les relisant avec les étapes 
d’analyse. 

Ce chapitre vous apprend à enregistrer des données en utilisant les 
fonctionnalités d’enregistrement de données intégrées à LabVIEW 
SignalExpress. Vous apprendrez à enregistrer un signal spécifié, à relire ce 
signal et à l’analyser en utilisant des étapes d’analyse. Vous allez également 
apprendre à utiliser l’onglet Options d’enregistrement pour enregistrer 
des signaux en fonction de conditions de démarrage et d’arrêt spécifiées. 

Enregistrement d’un signal
Vous pouvez utiliser le bouton Enregistrer pour configurer un processus 
d’enregistrement de données. 

Effectuez les étapes suivantes pour spécifier le signal à enregistrer et 
l’enregistrer.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur 
Logging.seproj.

Ce projet utilise l’étape Créer un signal analogique pour générer un 
signal sur la base d’une formule.

2. Cliquez sur le bouton Enregistrer, illustré à gauche, pour ouvrir la 
boîte de dialogue Sélection des signaux à enregistrer.

La boîte de dialogue Sélection des signaux à enregistrer affiche les 
signaux dans le projet disponible pour l’enregistrement. Vous pouvez 
sélectionner un ou plusieurs signaux à enregistrer. Vous pouvez aussi 
spécifier un nom et une description pour l’enregistrement.

3. Cochez la case signal pour enregistrer le signal de la formule généré 
par l’étape Créer un signal analogique.
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4. Cliquez sur le bouton OK pour fermer la boîte de dialogue Sélection 
des signaux à enregistrer et commencer l’enregistrement du signal. 
L’enregistrement se poursuit jusqu’à ce que vous cliquiez sur le bouton 
Arrêter.

5. Cliquez sur le bouton Arrêter, montré à gauche, pour arrêter le projet. 
Si c’est la première fois que vous enregistrez un signal, la boîte de 
dialogue Premier journal terminé apparaît. Cliquez sur le bouton OK 
pour fermer la boîte de dialogue.

Les données enregistrées apparaissent dans la fenêtre Données 
enregistrées au bas de la Vue du projet, comme le montre la figure 4-1.

Figure 4-1.  Fenêtre Données enregistrées

Par défaut, LabVIEW SignalExpress nomme les données enregistrées 
d’après la date et l’heure de leur enregistrement. LabVIEW 
SignalExpress enregistre des données au format de fichier .tdms dans 
le répertoire que vous spécifiez dans la boîte de dialogue Options. 

6. Sélectionnez Outils»Options puis sélectionnez l’option 
Enregistrement pour spécifier le répertoire dans lequel LabVIEW 
SignalExpress enregistre les données et pour personnaliser différentes 
préférences pour les données enregistrées.

7. Cliquez sur le bouton OK pour fermer la boîte de dialogue Options.

8. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le 
projet sous Mon enregistrement.seproj dans le répertoire 
SignalExpress\Examples\Tutorial. 
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Affichage d’un signal enregistré dans un journal
Effectuez les étapes suivantes pour afficher les données enregistrées dans 
un fichier journal.

1. Si l’onglet Affichage des données n’est pas visible, sélectionnez 
Affichage»Affichage des données pour afficher l’onglet Affichage 
des données. 

2. La fenêtre Données enregistrées présente la liste de toutes les données 
enregistrées dans le projet actuel. Sélectionnez le journal de données 
que vous venez d’enregistrer dans la fenêtre Données enregistrées et 
faites-le glisser dans l’onglet Affichage des données. L’onglet 
Affichage des données affiche les données enregistrées et un graphe 
d’aperçu, comme le montre la figure 4-2. Il se peut que le signal qui 
apparaît sur l’onglet Affichage des données diffère du signal montré 
sur la figure 4-2 en fonction de la durée de votre enregistrement.

Figure 4-2.  Logging.seproj

1 Données enregistrées 2 Graphe d’aperçu

1

2
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Le graphe d’aperçu offre la possibilité de zoomer sur les données et de 
les faire défiler horizontalement dans l’onglet Affichage des données. 
Le graphe d’aperçu apparaît par défaut lorsque vous affichez des 
données enregistrées. Lorsque vous affichez des données en direct ou 
non enregistrées, cliquez avec le bouton droit sur un affichage de 
l’onglet Affichage des données et sélectionnez Éléments visibles»
Aperçu dans le menu local pour afficher le graphe d’aperçu.

3. Cliquez sur le bouton Zoom avant à côté du graphe d’aperçu pour 
effectuer un zoom avant sur le signal enregistré. Les curseurs sur le 
graphe d’aperçu montrent le sous-ensemble de données actuellement 
affiché sur l’onglet Affichage des données. Utilisez la barre de 
défilement en dessous du graphe d’aperçu pour faire défiler les 
données. Cliquez sur le curseur et faites-le glisser sur le graphe 
d’aperçu pour agrandir ou réduire le sous-ensemble des données 
affichées.

Enregistrement de signaux avec des conditions de 
démarrage et d’arrêt prédéfinies

Vous pouvez configurer des conditions de démarrage et d’arrêt que les 
signaux doivent respecter avant que LabVIEW SignalExpress les 
enregistre ou arrête de les enregistrer. Effectuez les étapes suivantes pour 
enregistrer les données en fonction de conditions de démarrage et d’arrêt.

1. Si l’onglet Options d’enregistrement n’est pas visible, sélectionnez 
Affichage»Options d’enregistrement pour ouvrir l’onglet Options 
d’enregistrement.

2. Sélectionnez Sélection des signaux dans la liste de Catégorie de 
l’onglet Options d’enregistrement.
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3. Cochez la case du signal dans la colonne Enregistrer, comme le 
montre la figure 4-3.

Figure 4-3.  Sélection des signaux

Le bouton Enregistrer devient le bouton Enregistrer pendant 
l’exécution, montré à gauche. Assurez-vous que le bouton 
Enregistrer pendant l’exécution est enclenché. Quand le bouton 
Enregistrer pendant l’exécution est enclenché, LabVIEW 
SignalExpress enregistre le signal sélectionné quand vous cliquez sur 
le bouton Exécuter.

4. Sélectionnez Conditions de démarrage dans la liste Catégorie de 
l’onglet Options d’enregistrement. 

5. Cliquez sur le bouton Ajouter situé sous la Liste des conditions de 
démarrage pour personnaliser une condition de démarrage pour une 
tâche d’enregistrement.

a. Dans le menu déroulant Type de condition, assurez-vous que 
Déclenchement du signal est sélectionné pour spécifier que 
LabVIEW SignalExpress commence l’enregistrement quand le 
signal en entrée remplit la condition spécifiée.

b. Dans le menu déroulant Signal, assurez-vous que signal est 
sélectionné.
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c. Dans le menu déroulant Type de déclenchement, vérifiez que 
l’option Pente montante est sélectionnée pour spécifier le début 
de l’enregistrement du signal en fonction de la valeur du front du 
signal sur la pente positive.

d. Entrez 1 dans le champ Valeur de déclenchement pour 
commencer l’enregistrement quand le signal passe 1 sur une pente 
montante.

6. Sélectionnez Conditions d’arrêt dans la liste Catégorie de l’onglet 
Options d’enregistrement.

7. Cliquez sur le bouton Ajouter situé sous la Liste des conditions 
d’arrêt pour personnaliser la condition d’arrêt d’une tâche 
d’enregistrement.

a. Dans le menu déroulant Type de condition, vérifiez que l’option 
Durée est sélectionnée pour spécifier que LabVIEW 
SignalExpress arrête l’enregistrement après un laps de temps 
défini.

b. Dans la commande Durée, assurez-vous que 5 apparaît pour 
indiquer d’enregistrer le signal pendant 5 secondes à partir du 
moment où le signal remplit la condition de démarrage.

8. Cliquez sur le bouton Exécuter, montré à gauche. LabVIEW 
SignalExpress commence à enregistrer le signal quand celui-ci atteint 
le niveau 1 sur une pente montante et continue à l’enregistrer pendant 
5 secondes. 

Les indicateurs suivants dans la section État de l’enregistrement de 
l’onglet Options d’enregistrement se met à jour pendant que le projet 
s’exécute.

• Enregistrement affiche activé quand le signal remplit la 
condition de démarrage et que l’enregistrement est en cours. 

• Infos sur le disque affiche l’espace disque disponible sur 
l’ordinateur pour le journal. 

• Taille estimée du journal affiche la taille du fichier journal sur le 
disque.

• Temps d’enreg. restant affiche pendant combien de temps vous 
pouvez continuer l’enregistrement du journal avant d’être à cours 
d’espace sur le disque.

• Journal en cours démarré à affiche le temps de départ du journal 
actuel.
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Les pages Conditions de démarrage, Conditions d’arrêt, Alarmes 
et Événements de l’onglet Options d’enregistrement comprennent 
aussi des indicateurs qui affichent l’état des conditions de démarrage, 
des conditions d’arrêt, des alarmes et des événements que vous 
configurez.

Analyse des signaux enregistrés
Une fois que vous avez enregistré un signal, vous pouvez repasser les 
données enregistrées ou exécuter le signal enregistré via les étapes 
d’analyse, comme vous pouvez le faire avec les données en direct. 
Effectuez les étapes suivantes pour analyser un signal enregistré.

1. Repérez le menu déroulant Zone de travail au-dessus de la Vue du 
projet, comme le montre la figure 4-4. Cliquez sur la flèche vers le bas 
et sélectionnez Relecture pour passer à la zone de travail de Relecture.

Figure 4-4.  Menu déroulant Zone de travail

Utilisez des zones de travail pour effectuer plusieurs étapes LabVIEW 
SignalExpress à partir du même projet. Vous pouvez acquérir des 
données, traiter des signaux, enregistrer les données dans un fichier 
journal et effectuer des mesures sur les données enregistrées sans 
devoir ouvrir un nouveau projet. Lorsque vous enregistrez un projet, 
LabVIEW SignalExpress enregistre toutes les zones de travail qui s’y 
trouvent dans le même fichier de projet.

La zone de travail par défaut, Surveillance/Enregistrement, vous 
permet de prendre des mesures, d’analyser des données en direct et 
d’enregistrer des données. La zone de travail Relecture vous permet 
d’utiliser des données enregistrées dans la zone de travail 
Surveillance/Enregistrement comme entrée d’une étape d’analyse.

2. Cliquez sur le bouton Ajouter une étape, montré à gauche, et 
sélectionnez l’étape Filtre en sélectionnant Traitement»Signaux 
analogiques»Filtre. LabVIEW SignalExpress sélectionne 
automatiquement le premier signal que vous avez enregistré comme 
entrée de l’étape Filtre.

3. Passez à l’onglet Affichage des données, faites glisser la sortie 
filtered data de l’étape Filtre vers l’Affichage des données pour 
afficher le signal résultant.
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4. Cliquez sur le bouton Exécuter. L’onglet Affichage des données 
affiche le signal filtré résultant et LabVIEW SignalExpress relit tout le 
journal.

Relecture avancée
Vous pouvez utiliser l’onglet Options de relecture pour configurer des 
options de relecture des données avancées. L’onglet Options de relecture 
affiche un aperçu des données enregistrées et vous permet de sélectionner 
un sous-ensemble de ces données à relire ou à exécuter via des étapes 
d’analyse.

1. Sélectionnez Affichage»Options de relecture pour afficher l’onglet 
Options de relecture, comme le montre la figure 4-5. 

Figure 4-5.  Fenêtre Options de relecture

2. Dans la liste déroulante Signal enregistré, sélectionnez signal dans le 
deuxième journal que vous avez créé.

3. Entrez 1 dans le champ Temps de début (s) pour relire ou analyser un 
sous-ensemble du signal enregistré qui commence une seconde après 
le début du journal. 

4. Entrez 4 dans le champ Temps de fin (s) pour relire ou analyser un 
sous-ensemble du signal enregistré qui commence quatre secondes 
après le début du journal. Si la durée du journal est inférieure à 4 
secondes, entrez la valeur appropriée dans le champ Temps de fin (s). 
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5. Dans la liste déroulante Signal enregistré, cliquez avec le bouton droit 
sur le signal du deuxième journal et sélectionnez Activer dans le menu 
local pour définir le signal comme journal actif.

Remarque Vous pouvez aussi cliquer avec le bouton droit sur un journal dans la fenêtre 
Données enregistrées et sélectionner Rendre le journal actif dans le menu local pour 
définir ce journal comme le journal actif.

6. Passez à l’onglet Affichage des données. L’affichage graphe sur 
l’onglet Affichage des données fait automatiquement apparaître le 
deuxième journal quand vous définissez ce signal comme le signal 
actif. 

7. Cliquez sur le bouton Exécuter, montré à gauche. LabVIEW 
SignalExpress filtre le sous-ensemble du signal que vous avez spécifié 
dans l’onglet Options de relecture et affiche le signal filtré résultant 
dans l’onglet Affichage des données.

Reportez-vous à l’Aide LabVIEW SignalExpress pour obtenir des 
informations complémentaires sur l’enregistrement de données, comme la 
spécification de conditions d’alarme, d’événements et les options de 
relecture.
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5
Réalisation de mesures de 
balayage

Vous pouvez utiliser LabVIEW SignalExpress pour automatiser les 
mesures afin de caractériser et valider des systèmes en créant des 
opérations de balayage. Un système peut être quelque chose que vous créez 
que vous voulez caractériser et valider avec LabVIEW SignalExpress. Vous 
pouvez utiliser les mesures de balayage pour rassembler des données de 
systèmes en fonction d’une gamme de conditions pour documenter leurs 
performances. Par exemple, vous pouvez utiliser des opérations de 
balayage pour faire varier la fréquence d’un signal d’impulsion ou le niveau 
d’une tension d’alimentation tout en prenant des mesures pour définir les 
caractéristiques des systèmes.

Ce chapitre vous apprend comment configurer des opérations de balayage 
en utilisant l’étape Balayage dans LabVIEW SignalExpress. Vous allez 
apprendre comment définir les caractéristiques des performances d’un 
filtre en balayant une gamme des valeurs de fréquence et en mesurant la 
sortie du filtre. Vous allez aussi apprendre à afficher les résultats du 
balayage et effectuer des balayages multidimensionnels pour effectuer des 
mesures plus complexes.

Définition de sorties et de gammes de balayage 
Vous pouvez utiliser l’étape Balayage dans LabVIEW SignalExpress pour 
définir des mesures automatisées dans le cadre d’opérations de balayage 
complexes et susceptibles d’être répétées.

Effectuez les étapes suivantes pour définir une gamme de fréquence à 
balayer dans un projet d’exemple utilisant un filtre.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur 
Sweep.seproj.

2. Cliquez sur le bouton Exécuter, montré à gauche, pour exécuter le 
projet en continu.
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Le projet génère un signal d’impulsion sinusoïdal à l’étape Créer un 
signal analogique, ce signal passe ensuite dans un filtre passe-bande 
elliptique à l’étape Filtre, mesure le niveau Veff de la sortie du filtre à 
l’étape Amplitude et niveaux et convertit le niveau en décibels (dB) à 
l’étape Formule. L’étape Filtre agit comme une unité simulée en cours 
de test, le projet n’utilise donc pas de matériel. Toutefois, vous pouvez 
aussi balayer des signaux physiques générés à partir d’un générateur 
de fonctions, de l’analyseur de signaux dynamiques, d’un périphérique 
d’E/S multifonction (MIO) ou d’un générateur de signaux arbitraires 
National Instruments.

3. Cliquez sur le bouton Arrêter pour arrêter le projet.

4. Cliquez sur le bouton Ajouter une étape, montré à gauche, et 
sélectionnez Contrôle d’exécution»Balayage pour ajouter l’étape 
Balayage à la Vue du projet.

5. Sur l’onglet Configuration de l’étape, cliquez sur le bouton Ajouter 
pour afficher la liste des paramètres balayables à partir de chaque étape 
du projet, comme le montre la figure 5-1.

Figure 5-1.  Boîte de dialogue Sélection du paramètre de balayage

6. Sélectionnez le paramètre Fréquence (Hz) sous Créer un signal 
analogique et cliquez sur le bouton OK.

L’étape Balayage comprend l’étape Créer un signal analogique qui 
fournit le signal à balayer.

7. Sur la page Configuration du balayage de l’onglet Configuration de 
l’étape, sélectionnez Exponentiel dans le menu déroulant Type.

8. Entrez 1k dans le champ Départ : Fréquence (Hz), et entrez 40k dans 
le champ Arrêt : Fréquence (Hz).
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9. Entrez 150 dans le champ Nombre de points.

La page Configuration du balayage apparaît comme le montre la 
figure 5-2.

Figure 5-2.  Onglet Configuration de l’étape Balayage

Vous utilisez l’étape Balayage pour spécifier une gamme de valeurs sur 
laquelle effectuer des itérations dans le paramètre Fréquence (Hz) de 
l’étape Créer un signal analogique. L’étape Créer un signal analogique 
utilise la gamme de fréquence définie pour générer un signal 
sinusoïdal à chacune de ces fréquences. Vous pouvez utiliser l’étape 
Balayage pour effectuer des itérations sur toute valeur d’un paramètre 
susceptible d’être balayé de n’importe quelle étape d’un projet 
elle-même susceptible d’être balayée.

10. Passez à la page Sortie du balayage.

11. Cliquez sur le bouton Ajouter pour afficher la liste des sorties pouvant 
être balayées pour chaque étape du projet.
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12. Sélectionnez la sortie response amplitude in dB sous Formule et 
cliquez sur le bouton OK pour tracer cette mesure par rapport au 
paramètre Fréquence (Hz) balayé.

L’étape Balayage crée une boucle autour de toutes les étapes de la Vue 
du projet pour inclure toutes les étapes dans l’opération de balayage.

Exécution de mesures balayées
Effectuez les étapes suivantes pour exécuter la mesure de balayage.

1. Passez à l’onglet Affichage des données, cliquez sur la flèche vers le 
bas du bouton Exécuter et sélectionnez Exécuter une fois pour 
exécuter la mesure balayée.

La sortie blanche stimulus signal sur l’affichage graphe itère dans la 
gamme de fréquences spécifiée.

2. Faites glisser le signal response amplitude in dB vs. Fréquence du 
bas de la boucle de balayage vers l’Affichage des données pour 
afficher la sortie du balayage.



Chapitre 5 Réalisation de mesures de balayage

© National Instruments Corporation 5-5 Initiation à LabVIEW SignalExpress

LabVIEW SignalExpress crée un nouvel affichage graphe. Les 
données d’une opération de balayage sont représentées dans un tableau 
XY qui requiert un affichage séparé, comme le montre la figure 5-3.

Figure 5-3.  Sweep.seproj

3. Sélectionnez l’option Exécuter une fois pour exécuter à nouveau le 
balayage.

La réponse en fréquence de l’étape Filtre est tracée sur le nouvel 
affichage graphe pendant que le projet s’exécute. Le graphe montre la 
fonction de transfert du filtre, ou la sortie d’amplitude exprimée en 
décibels par rapport à la fréquence.
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Remarque Par défaut, LabVIEW SignalExpress ne réinitialise pas les affichages sur 
l’onglet Affichage des données entre les itérations d’un balayage. Dans la mesure où la 
réponse en fréquence de l’étape Filtre est la même à chaque itération, le graphe qui affiche 
le signal ne semble pas se mettre à jour quand vous exécutez le projet. Vous pouvez utiliser 
la page Données de la boîte de dialogue Options pour indiquer si LabVIEW SignalExpress 
supprime le résultat du balayage sur les affichages entre des itérations d’un balayage. 
Sélectionnez Outils»Options pour afficher la boîte de dialogue Options.

4. Double-cliquez sur l’étape Filtre pour afficher les spécifications du 
filtre dans l’onglet Configuration de l’étape.

La réponse en fréquence du filtre dans le graphe Réponse en 
amplitude du filtre (dB) correspond au graphe de l’Affichage des 
données.

5. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le 
projet sous Mon balayage.seproj dans le répertoire 
SignalExpress\Examples\Tutorial.

Vous pouvez utiliser l’étape Balayage pour balayer plusieurs paramètres 
simultanément en ajoutant des paramètres supplémentaires sur la page 
Configuration du balayage de l’onglet Configuration de l’étape de 
l’étape Balayage. Le balayage simultané de plusieurs paramètres est appelé 
balayage parallèle. Par exemple, si vous voulez varier l’amplitude d’un 
signal de stimulus, vous pouvez exécuter un balayage en parallèle pour 
optimiser la précision de l’acquisition en variant la gamme en entrée d’un 
numériseur ou d’un périphérique MIO tout en variant le niveau du signal. 
À mesure que le niveau du signal augmente, vous pouvez augmenter la 
gamme d’entrée du périphérique de mesure pour vous assurer que vous 
utilisez toute la résolution pour la mesure.

Exécution de balayages multidimensionnels
Utilisez des balayages multidimensionnels ou imbriqués pour effectuer des 
itérations sur une gamme tout en faisant varier une autre gamme. Par 
exemple, si vous voulez effectuer des itérations sur des fréquences d’un 
signal d’impulsion à différentes amplitudes, exécutez un balayage 
imbriqué. Vous pouvez définir l’amplitude au niveau 1 et effectuer des 
itérations sur des fréquences, puis définir l’amplitude au niveau 2 et 
effectuer des itérations sur des fréquences, et ainsi de suite. Vous pouvez 
construire un balayage imbriqué en cliquant avec le bouton droit sur l’étape 
Balayage dans un projet en sélectionnant Ajouter un balayage imbriqué 
dans le menu local pour ajouter une autre boucle de balayage. 
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Effectuez les étapes suivantes pour exécuter un projet d’exemple de 
balayage imbriqué.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur 
Nested Sweep.seproj.

2. Cliquez sur le bouton Exécuter pour exécuter le projet.

Chaque itération de la boucle de balayage interne balaie la fréquence 
du signal d’impulsion. La boucle de balayage externe fait varier les 
fréquences de coupure basse et haute de l’étape Filtre. Chaque itération 
apparaît en temps réel sur l’affichage graphe supérieur, puis apparaît 
sur l’affichage graphe inférieur pour montrer tous les balayages à 
chaque configuration de la fréquence de coupure, comme le montre la 
figure 5-4.

Figure 5-4.  Nested Sweep.seproj

3. Cliquez sur le bouton Arrêter, montré à gauche, pour arrêter le projet.
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6
Extension des projets LabVIEW 
SignalExpress avec LabVIEW

Vous pouvez utiliser LabVIEW SignalExpress pour définir des mesures 
automatisées en utilisant les étapes intégrées pour acquérir, générer ou 
analyser des signaux. Vous pouvez étendre la fonctionnalité des projets 
LabVIEW SignalExpress en utilisant LabVIEW des façons suivantes :

• Construisez un VI dans LabVIEW et importez-le dans LabVIEW 
SignalExpress pour fournir une fonctionnalité d’étape personnalisée et 
étendre le nombre d’étapes disponibles dans LabVIEW SignalExpress.

• Convertissez un projet LabVIEW SignalExpress en un diagramme 
LabVIEW pour poursuivre le développement dans LabVIEW.

Vous devez avoir LabVIEW 7.1 ou une version ultérieure pour effectuer les 
exercices de ce chapitre.

Importation de VIs LabVIEW dans LabVIEW 
SignalExpress sous forme d’étapes

Utilisez l’étape Exécuter un VI LabVIEW dans LabVIEW SignalExpress 
pour appeler des VIs LabVIEW personnalisés. Vous pouvez appeler un 
VI LabVIEW à partir de LabVIEW SignalExpress pour qu’il :

• Contrôle des instruments GPIB

• Contrôle du matériel National Instruments non supporté par LabVIEW 
SignalExpress

• Lise ou écrive des données dans davantage de formats de fichier

• Affiche des instructions destinées à l’opérateur dans une boîte de 
dialogue locale

• Définisse un algorithme de mesure
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Effectuez les étapes suivantes pour importer un VI LabVIEW avec l’étape 
Exécuter un VI LabVIEW. 

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur User 
Step.seproj.

Ce projet utilise l’étape Créer un signal analogique pour générer un 
signal.

2. Cliquez sur le bouton Ajouter une étape, montré à gauche, et 
sélectionnez Exécuter un VI LabVIEW»Exécuter un VI 
LabVIEW  8.6. 

Le VI que vous exécutez dans cet exercice a été enregistré avec 
LabVIEW 8.6. Vous devez utiliser la version de l’étape Exécuter un VI 
LabVIEW qui correspond à la version de LabVIEW dans laquelle vous 
avez enregistré le VI.

3. Sur l’onglet Configuration de l’étape, cliquez sur le bouton Parcourir 
dans la section Sélectionnez un VI et sélectionnez 
Limiter-LV86.vi dans le répertoire LabVIEW SignalExpress\
Examples\Tutorial. Le VI Limiter-LV86 accepte un signal du 
domaine temporel comme entrée, écrête le signal au-dessus et en 
dessous des valeurs que vous spécifiez dans la boîte de dialogue 
Configuration de l’étape, et renvoie le signal écrêté en sortie.

Lorsque vous importez un VI LabVIEW, LabVIEW SignalExpress 
mappe les entrées du VI comme paramètres et les sorties du VI comme 
signaux en sortie dans LabVIEW SignalExpress.

Vous pouvez définir si les entrées des VIs deviennent des signaux en 
entrée ou des paramètres. Un signal en entrée apparaît dans la Vue du 
projet comme une entrée d’une étape, ce qui signifie que vous pouvez 
transmettre des signaux à un VI sous la forme d’entrées. Un paramètre 
est une valeur que vous pouvez configurer dans l’onglet 
Configuration de l’étape d’une étape. Vous pouvez aussi balayer des 
paramètres de manière dynamique en utilisant l’étape Balayage. Dans 
ce projet, le VI possède un signal en entrée Signal temporel en entrée 
et les paramètres scalaires Limite supérieure et Limite inférieure.
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Assurez-vous que l’onglet Configuration de l’étape apparaît comme 
dans la figure 8-1.

Figure 6-1.  Onglet de configuration de l’étape VI Limiter

4. Cliquez sur le bouton Exécuter, montré à gauche, pour exécuter le 
projet. 

5. Passez à l’onglet Affichage des données et faites glisser le signal en 
sortie Clipped waveform out de l’étape Exécuter un VI LabVIEW 8.6 
vers l’onglet Affichage des données.

6. Double-cliquez sur l’étape Exécuter un VI LabVIEW 8.6 pour afficher 
l’onglet Configuration de l’étape.

7. Sélectionnez la page Configurer le VI pour afficher le VI. 

8. Entrez de nouvelles valeurs dans les champs Limite supérieure et 
Limite inférieure. Par exemple, entrez 100 dans le champ Limite 
supérieure.

9. Passez à l’onglet Affichage des données. Le signal Clipped 
waveform out change pour refléter les modifications effectuées.

10. Cliquez sur le bouton Arrêter, montré à gauche, pour arrêter le projet.
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11. Sélectionnez Fichier»Enregistrer sous et enregistrez le projet sous 
Mon étape utilisateur.seproj.

12. Sélectionnez Fichier»Fermer le projet pour fermer le projet.

Reportez-vous à l’Aide LabVIEW SignalExpress pour obtenir davantage 
d’informations sur l’utilisation de VIs LabVIEW dans LabVIEW 
SignalExpress et sur la construction de VIs qui fonctionnent sous 
LabVIEW SignalExpress.

Conversion de projets LabVIEW SignalExpress en 
diagrammes LabVIEW

LabVIEW SignalExpress peut convertir des projets LabVIEW 
SignalExpress en diagrammes LabVIEW.

Remarque Pour convertir un projet LabVIEW SignalExpress en VI LabVIEW, le système 
de développement complet de LabVIEW 7.1 ou une version ultérieure doit être installée.

Effectuez les étapes suivantes pour convertir un projet LabVIEW 
SignalExpress en diagramme LabVIEW.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial\Solutions et 
double-cliquez sur Mon premier projet.seproj.

2. Sélectionnez Outils»Générer le code»Diagramme LabVIEW.

3. Spécifiez un nom de fichier et un emplacement pour le VI LabVIEW 
et cliquez sur le bouton OK. LabVIEW SignalExpress génère le 
nouveau VI et l’ouvre dans la dernière version de LabVIEW ouverte 
sur votre machine.

Le diagramme LabVIEW résultant reflète l’exécution du projet dans 
LabVIEW SignalExpress. Le diagramme LabVIEW comprend des 
VIs Express LabVIEW câblés entre eux. Chaque VI Express 
correspond à une étape dans le projet LabVIEW SignalExpress. Vous 
pouvez double-cliquer sur un VI Express pour afficher une boîte de 
dialogue de configuration identique à l’onglet Configuration de 
l’étape dans LabVIEW SignalExpress. Vous pouvez également 
effectuer un clic droit sur un VI Express et sélectionner Ouvrir la 
face-avant dans le menu local pour convertir le VI Express en un 
sous-VI LabVIEW. Vous pouvez afficher le diagramme LabVIEW 
pour voir comment il s’exécute et modifier la fonctionnalité du VI. 
Lorsque vous convertissez un VI Express en sous-VI, vous ne pouvez 
plus convertir le sous-VI en VI Express.
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Remarque Lorsque vous convertissez un projet LabVIEW SignalExpress comportant un 
enregistrement dans un fichier journal, LabVIEW SignalExpress génère un diagramme 
LabVIEW avec un VI Express. Vous ne pouvez pas convertir le VI Express généré en un 
sous-VI.
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7
Et maintenant ?

Reportez-vous aux ressources suivantes pour obtenir de plus amples 
informations sur LabVIEW SignalExpress.

Projets d’exemple LabVIEW SignalExpress
LabVIEW SignalExpress offre une variété de projets d’exemple qui 
démontrent davantage de possibilités de LabVIEW SignalExpress. Ces 
projets sont situés dans le répertoire SignalExpress\Examples. Passez 
ces exemples en revue pour en savoir plus sur les fonctionnalités de 
LabVIEW SignalExpress ou pour démarrer avec un projet qui s’approche 
de vos exigences.

Utilisation du matériel avec LabVIEW SignalExpress
LabVIEW SignalExpress supporte de nombreux périphériques National 
Instruments d’acquisition et de génération de signaux. Vous pouvez 
générer ou acquérir des signaux analogiques dans LabVIEW SignalExpress 
en utilisant des numériseurs haute vitesse, des périphériques d’acquisition 
de signaux dynamiques, des générateurs de waveform arbitraires et des 
générateurs de fonctions ou des périphériques MIO National Instruments. 
Vous pouvez aussi synchroniser plusieurs périphériques dans un système 
en partageant des signaux d’horloge et de déclenchement entre des 
périphériques. Reportez-vous à l’Aide LabVIEW SignalExpress en 
sélectionnant Aide»Aide LabVIEW SignalExpress pour obtenir des 
informations complémentaires sur l’utilisation de périphériques avec 
LabVIEW SignalExpress.

Ressources Web
Reportez-vous au site Web de National Instruments sur ni.com/france/
signalexpress pour obtenir des ressources telles que des projets 
d’exemple, de la documentation technique et des VIs LabVIEW écrits pour 
être utilisés dans LabVIEW SignalExpress.

http://www.ni.com/signalexpress
http://www.ni.com/signalexpress
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A
Support technique et services

Visitez les sections suivantes du site Web primé de National Instruments 
sur ni.com pour obtenir une assistance technique et des services 
professionnels :

• Support — Les ressources de support technique en ligne sur 
ni.com/support comprennent notamment :

– Ressources d’auto-assistance technique — Visitez 
ni.com/support pour obtenir des réponses et des solutions, 
vous procurer des drivers et des mises à jour de logiciels, faire des 
recherches dans la Base de connaissances, accéder aux manuels 
sur les produits et aux assistants de dépannage pas à pas, ou 
obtenir des milliers d’exemples de programmes, des tutoriels, des 
notes d’application, des drivers d’instruments et bien plus encore. 
Les utilisateurs enregistrés bénéficient également de l’accès à NI 
Discussion Forums, sur ni.com/forums. Pour accéder au forum 
français, cliquez sur le menu déroulant “Select Community” et 
sélectionnez “Français”. Les ingénieurs d’applications de NI se 
font fort de répondre à toutes les questions qui leur sont adressées.

– Abonnement SSP (Standard Service Program) — Ce 
programme confère à ses membres un accès direct par téléphone 
et e-mail aux ingénieurs d’applications de NI et leur permet 
d’obtenir un support technique individuel, ainsi qu’un accès 
privilégié aux modules de formation à la demande par le biais du 
Services Resource Center. NI offre un abonnement gratuit d’un 
an à partir de la date d’achat. Au bout d’un an, vous pouvez 
renouveler votre abonnement pour continuer à profiter de ces 
avantages. 

Pour obtenir des informations sur d’autres options de support 
technique dans votre région, visitez ni.com/services ou 
contactez votre filiale locale en utilisant les coordonnées qui 
se trouvent sur ni.com/contact. 

• Formations et certifications — Visitez ni.com/france et cliquez 
sur Formations et Certifications sur le volet de gauche pour obtenir des 
informations détaillées sur les programmes proposés. Vous pouvez 
également vous inscrire à des cours de formation dispensés par des 
instructeurs un peu partout dans le monde.
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• Intégrateurs — Si vous devez concilier délais serrés, ressources 
techniques limitées et toute autre contrainte, nous vous invitons à faire 
appel aux intégrateurs du Programme National Instruments Alliance 
Partner. Pour en savoir plus, appelez votre filiale locale ou visitez le 
site ni.com/alliance.

Si vous n’avez pas trouvé la réponse à vos questions sur ni.com, contactez 
votre filiale locale ou le siège social de NI. Les numéros de téléphone des 
filiales figurent au début de ce manuel. Vous pouvez également visiter la 
page des filiales internationales sur ni.com/niglobal afin d’accéder au 
site Web local de votre filiale, qui contient les informations les plus à jour 
pour contacter le support technique par téléphone, fax ou e-mail, ainsi que 
les dates des événements à venir.
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DER SOFTWAREPRODUKTE DURCH ENTGEGENWIRKENDE FAKTOREN, EINSCHLIESSLICH Z.B. 
SPANNUNGSUNTERSCHIEDEN BEI DER STROMVERSORGUNG, FEHLFUNKTIONEN DER COMPUTER-HARDWARE, 
FEHLENDER EIGNUNG DER SOFTWARE FÜR DAS COMPUTER-BETRIEBSSYSTEM, FEHLENDER EIGNUNG VON 
ÜBERSETZUNGS- UND ENTWICKLUNGSSOFTWARE, DIE ZUR ENTWICKLUNG EINER ANWENDUNG EINGESETZT WERDEN, 
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UNVORHERGESEHENEN EINSATZES ODER MISSBRAUCHS ODER FEHLERN DES ANWENDERS ODER DES 



ANWENDUNGSENTWICKLERS (ENTGEGENWIRKENDE FAKTOREN WIE DIESE WERDEN NACHSTEHEND 
ZUSAMMENFASSEND “SYSTEMFEHLER” GENANNT) BEEINTRÄCHTIGT WERDEN. JEDE ANWENDUNG, BEI DER EIN 
SYSTEMFEHLER EIN RISIKO FÜR SACHWERTE ODER PERSONEN DARSTELLT (EINSCHLIESSLICH DER GEFAHR 
KÖRPERLICHER SCHÄDEN UND TOD), SOLLTE AUFGRUND DER GEFAHR VON SYSTEMFEHLERN NICHT LEDIGLICH AUF 
EINE FORM VON ELEKTRONISCHEM SYSTEM GESTÜTZT WERDEN. UM SCHÄDEN UND, U.U. TÖDLICHE, VERLETZUNGEN 
ZU VERMEIDEN, SOLLTE DER NUTZER ODER ANWENDUNGSENTWICKLER ANGEMESSENE SICHERHEITSMASSNAHMEN 
ERGREIFEN, UM SYSTEMFEHLERN VORZUBEUGEN. HIERZU GEHÖREN UNTER ANDEREM SICHERUNGS- ODER 
ABSCHALTMECHANISMEN. DA JEDES ENDNUTZERSYSTEM DEN KUNDENBEDÜRFNISSEN ANGEPASST IST UND SICH VON 
DEM TESTUMFELD UNTERSCHEIDET, UND DA EIN NUTZER ODER ANWENDUNGSENTWICKLER SOFTWAREPRODUKTE 
VON NATIONAL INSTRUMENTS IN VERBINDUNG MIT ANDEREN PRODUKTEN IN EINER VON NATIONAL INSTRUMENTS 
NICHT GETESTETEN ODER VORHERGESEHENEN FORM EINSETZEN KANN, TRÄGT DER NUTZER BZW. DER 
ANWENDUNGSENTWICKLER DIE LETZTENDLICHE VERANTWORTUNG FÜR DIE ÜBERPRÜFUNG UND AUSWERTUNG DER 
EIGNUNG VON NATIONAL INSTRUMENTS PRODUKTEN, WENN PRODUKTE VON NATIONAL INSTRUMENTS IN EIN SYSTEM 
ODER EINE ANWENDUNG INTEGRIERT WERDEN. DIES ERFORDERT U.A. DIE ENTSPRECHENDE ENTWICKLUNG UND 
VERWENDUNG SOWIE EINHALTUNG EINER ENTSPRECHENDEN SICHERHEITSSTUFE BEI EINEM SOLCHEN SYSTEM ODER 
EINER SOLCHEN ANWENDUNG.
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Zu diesem Handbuch

In diesem Handbuch erhalten Sie eine Einführung in die interaktive 
Messung mit LabVIEW SignalExpress und die Grundfunktionen des 
Programms zum Erfassen und Analysieren von Signalen.

Die im Buch enthaltenen Übungen sollen Ihnen den Einstieg in LabVIEW 
SignalExpress erleichtern. Sie lernen damit die Konfiguration von Schrit-
ten, das Ausführen von Projekten, die Arbeit mit Signalen, das wiederholte 
Messen mit variablen Parametern, das Protokollieren von Daten sowie die 
Erweiterung von LabVIEW SignalExpress durch die grafische Program-
mierumgebung LabVIEW.

Symbole und Darstellungen
In diesem Handbuch werden die folgenden Symbole und Darstellungen 
verwendet:

» Das Symbol » kennzeichnet die Reihenfolge, in der Menüpunkte und Dia-
logfeldoptionen anzuklicken sind. So wird zum Beispiel mit der Abfolge 
Datei»Seite einrichten»Optionen angezeigt, dass zunächst das Menü 
Datei zu öffnen ist, daraus der Menüpunkt Seite einrichten auszuwählen 
und anschließend die Seite Optionen anzuklicken ist.

Dieses Zeichen steht für einen Hinweis auf wichtige Informationen.

Dieses Symbol steht für einen Tipp.

fett In fettgedruckter Schrift sind Elemente dargestellt, die ausgewählt oder 
angeklickt werden müssen, wie Menüpunkte oder Optionen in Dialogfel-
dern. Bei fettgedrucktem Text kann es sich auch um die Namen von Ein- 
und Ausgängen, Parameternamen, Dialogfelder, Bereiche in Dialogfeldern 
und Menünamen handeln.

kursiv Variablen, Hervorhebungen, Querverweise und erstmals genannte Fachaus-
drücke sind durch Kursivschrift gekennzeichnet. Ebenfalls kursiv sind 
Textstellen gedruckt, an denen Wörter oder Werte einzusetzen sind.

monospace In Monospace-Schrift (nicht proportionaler Schrift) ist Text dargestellt, der 
über die Tastatur einzugeben ist. Diese Darstellungsweise wird ebenfalls 
für Laufwerke, Pfade, Verzeichnisse, Programme, Unterprogramme, Sub-
routinen, Gerätenamen, Funktionen, Operationen, Variablen sowie 
Dateinamen und -erweiterungen verwendet.
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Literaturhinweise
Wenn Sie beim Lesen dieses Handbuchs weitere Fragen haben, werden 
diese möglicherweise in der Hilfe zu LabVIEW SignalExpress unter 
Hilfe»LabVIEW SignalExpress Hilfe beantwortet.
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1
Erste Schritte mit LabVIEW 
SignalExpress

Mit den innovativen Produkten von National Instruments haben Wissen-
schaftler und Ingenieure die Möglichkeit, mit der Industrienorm ent-
sprechenden Computern und Plattformen automatisierte Messsysteme zu 
erstellen. Dazu bietet National Instruments technologisch führende Pro-
grammierumgebungen wie die grafische Entwicklungsumgebung 
LabVIEW, die ANSI-C-Programmierumgebung LabWindows™/CVI™ 
oder Measurement Studio zur Programmierung in Microsoft Visual Studio 
an. Diese Programmierumgebungen arbeiten sowohl herkömmlichen 
Messgeräten als auch mit virtuellen Messgeräten, die mittels der Messkar-
ten von National Instruments auf dem Computer emuliert werden, so dass 
Sie reale und virtuelle Messgeräte zu technisch anspruchvollen Systemen 
kombinieren können.

Mit LabVIEW SignalExpress können Sie interaktiv virtuelle Messsysteme 
erstellen und ohne jegliche Programmierung sofort mit der Messung begin-
nen. Signale werden interaktiv erfasst, erzeugt, analysiert, verglichen, 
importiert und gespeichert. So können Sie zum Beispiel vorgegebene Werte 
in einem Schritt mit Messwerten vergleichen. LabVIEW SignalExpress 
macht damit die Einfachheit und die Möglichkeiten virtueller Messanlagen 
auch solchen Nutzern zugänglich, die Signale ohne Programmierung von 
Anwendungen messen und analysieren möchten. Die Programmfunktionen 
können auch ausgebaut werden, indem Sie ein eigenes VI (virtuelles Instru-
ment) aus der LabVIEW-Entwicklungsumgebung importieren oder ein 
LabVIEW-SignalExpress-Projekt in ein LabVIEW-Blockdiagramm 
umwandeln, so dass Sie in LabVIEW weiter am Projekt arbeiten können. 
Weitere Informationen zu fortgeschrittenen Funktionen in LabVIEW 
SignalExpress finden Sie in Kapitel 6, Erweitern von LabVIEW-SignalEx-
press- Projekten durch LabVIEW.

Dieses Kapitel enthält Angaben zu den Systemanforderungen, zur Installa-
tion, zu verfügbaren Versionen und zu Optionen zur Lizenzierung für 
LabVIEW SignalExpress.
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Installieren von LabVIEW SignalExpress
Bevor Sie mit den Übungen dieses Handbuchs beginnen, muss LabVIEW 
SignalExpress installiert werden. Die Installation das Programms dauert 
etwa 10 Minuten.

Systemanforderungen
Für die Ausführung von LabVIEW SignalExpress wird folgende System-
konfiguration empfohlen:

• 512 MB Arbeitsspeicher

• Pentium 4 oder gleichwertiger Prozessor (mindestens Pentium III oder 
Celeron mit 600 MHz)

Installationshinweise
Gehen Sie zur Installation von LabVIEW SignalExpress unter 
Windows 2000/XP/Vista wie folgt vor:

Hinweis Wenn Sie LabVIEW SignalExpress bereits von der DVD mit LabVIEW 8.6 
installiert haben, müssen Sie das Programm nicht wie nachfolgend beschrieben neu instal-
lieren. Installationshinweise finden Sie in den LabVIEW-Versionshinweisen.

1. Schließen Sie alle Programme, bevor Sie das Installationsprogramm 
starten. Im Hintergrund laufende Programme, zum Beispiel Antiviren-
programme, verlängern unter Umständen die Installation.

2. Melden Sie sich als Administrator oder Anwender mit Administrator-
rechten an.

3. Legen Sie die Installations-CD für LabVIEW SignalExpress  ein und 
folgen Sie den Anweisungen.

Hinweis Wenn Sie keinen anderen Speicherort angeben, kopiert das Installationspro-
gramm von LabVIEW SignalExpress die Dateien in das Verzeichnis <Programme>\
National Instruments\SignalExpress.

4. Untersuchen Sie die Festplatte nach Abschluss der Installation auf 
Viren und aktivieren Sie die automatische Virenerkennung wieder.

Die in den folgenden Übungen verwendeten Beispielprojekte befinden 
sich im Verzeichnis <Programme>\National Instruments\
SignalExpress\Examples\Tutorial. Die Lösungen zu den 
einzelnen Übungen sind im Verzeichnis <Programme>\
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National Instruments\SignalExpress\Examples\Tutorial\

Solutions gespeichert.

Verfügbare Versionen von LabVIEW SignalExpress
LabVIEW SignalExpress ist als Full Edition und Limited Edition (LE) 
erhältlich. In der folgenden Tabelle sehen Sie die Programmfunktionen der 
beiden Versionen im Vergleich. 

Tabelle 1-1.  Unterschiede zwischen LabVIEW SignalExpress Full und LE

Full LE

Geräteunterstützung

Über 300 gängige Geräte ✓ —

Visualisierung und Dokumentation

Benutzerdefinierte grafische Darstellung ✓ ✓

Interaktive Cursor ✓ ✓

Speichern von Signalen in Dateien ✓ ✓

Drucken und Exportieren von Graphen ✓ ✓

Verschieben von Daten über Drag-and-Drop in 
Microsoft Excel, Word und WordPad

✓ ✓

Bedienmodus mit eingeschränkter Benutzerbearbeitung ✓ —

Signalverarbeitung

Softwarefilter ✓ —

Berechnungen an Skalaren und Signalverläufen ✓ —

Analoge und digitale Umrechnung ✓ —

Interaktive Signalvergleiche ✓ —

Laden von Simulationsdaten von PSPICE, Multisim und 
anderen SPICE-Programmen

✓ —

Zeit- und Frequenzmessungen

Amplitude und Pegel ✓ —

Timing und Übergang ✓ —
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Leistungsspektrum ✓ —

Frequenzgang ✓ —

Verzerrungsmessungen ✓ —

Grundfrequenz ermitteln ✓ —

Datenprotokollierung

Eingeschränkte Datenprotokollierung (ein Protokoll pro 
Projekt)

✓ ✓

Unbeschränkte Datenprotokollierung ✓ —

Alarm- und Ereignisprotokollierung ✓ —

Datenprotokollierung mit Start- oder Stoppbedingungen ✓ —

Automatische Messungen

Sweep-Parameter ✓ —

Grenzwerttest ✓ —

Software-Triggerung ✓ —

Ablaufsteuerung ✓ —

Zugriff auf Netzwerkdaten

Lesen/Schreiben von Umgebungsvariablen ✓ —

Tabelle 1-1.  Unterschiede zwischen LabVIEW SignalExpress Full und LE (Fortsetzung)

Full LE
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Optionen zur Lizenzierung für LabVIEW SignalExpress
Im folgenden Abschnitt werden die Lizenzbestimmungen für LabVIEW 
SignalExpress erläutert. Dieses Dokument ersetzt nicht die Softwarelizenz-
vereinbarung von National Instruments. Es dient lediglich als kurzer 
Überblick.

LabVIEW SignalExpress LE
Die eingeschränkte, nicht lizenzierte LE-Version von LabVIEW SignalEx-
press gewährt Ihnen Zugriff auf alle Programmfunktionen der Tabelle 1-1 
für 30 Tage. Danach wechselt LabVIEW SignalExpress in den nicht lizen-
zierten Modus. Wenn Sie innerhalb von 30 Tagen keine gültige Lizenz 
aktivieren, werden Projekte mit lizenzierten Schritten wie folgt behandelt:

• Bei jedem Ablegen eines lizenzierten Schritts wird ein Dialogfeld mit 
der Aufforderung angezeigt, die Software zu aktivieren. 

• Projekte können nicht gespeichert werden.

• Projekte werden nach 10 Minuten geschlossen.

Auf ni.com/signalexpress können Sie die Vollversion von LabVIEW 
SignalExpress erwerben.

LabVIEW Signal Express - Vollversion
Die Vollversion von LabVIEW SignalExpress bietet uneingeschränkten 
Zugriff auf alle in der Tabelle 1-1 aufgeführten Funktionen. Das Programm 
kann mit dem Lizenzmanager von National Instruments, dem Installations-
programm von LabVIEW SignalExpress oder auf der Website ni.com/
activate aktiviert werden.
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2
Arbeit mit Projekten

Mit LabVIEW SignalExpress werden Messungen in Form einer Reihe von 
Schritten ausgeführt, die Sie interaktiv auswählen und konfigurieren. Ein 
Schritt ist eine Funktion mit individuellen Einstellungen, mit der Daten 
erfasst, analysiert, geladen oder gespeichert werden können. Das Menü 
Schritt hinzufügen und die Palette Schritt hinzufügen enthalten die in 
LabVIEW SignalExpress verfügbaren Schritte. 

Die meisten Schritte verarbeiten Eingangssignale und erzeugen Ausgangs-
signale. Durch die Angabe von Werten auf der Registerkarte 
Schritteinstellungen können Sie die einzelnen Schritte konfigurieren. 
Eine gespeicherte Schrittfolge ergibt ein Projekt.

In diesem Kapitel lernen Sie, wie Projekte geladen und ausgeführt und 
Schritte in den Projekten konfiguriert werden.

Öffnen von Projekten
Zum Laden eines Beispielprojekts in LabVIEW SignalExpress gehen Sie 
wie folgt vor:

1. Starten Sie LabVIEW SignalExpress.

Beachten Sie, dass LabVIEW SignalExpress in verschiedene Ansich-
ten aufgeteilt ist, in denen verschiedene Arten von Informationen 
angezeigt werden. Die Hauptansicht wird in der Mitte des Programm-
fensters angezeigt und enthält Registerkarten. Wenn das Programm in 
der Standardkonfiguration geöffnet wird, enthält die Hauptansicht die 
Registerkarten Datenansicht, Aufnahmeoptionen und Projekt-
dokumentation. 

Neben der Hauptansicht sehen Sie verschiedene Zusatzansichten. 
Bei der Standardkonfiguration wird die Projektansicht links und die 
Kontexthilfe rechts angezeigt.

Hinweis Wenn LabVIEW SignalExpress unterstützte Hardware erkennt, erfolgt die 
Anzeige der Kanalansicht im unteren Bereich des Programmfensters.
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2. Wenn LabVIEW SignalExpress nicht in der Standardkonfiguration 
geöffnet wird, wählen Sie Ansicht»Original-Layout wiederherstel-
len, um zur Standardkonfiguration zurückzukehren. Über das Menü 
Ansicht kann die Anzeige von Registerkarten und Ansichten jederzeit 
angepasst werden.

3. Wählen Sie Hilfe»Beispiel öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
First Project.seproj. 

4. Sehen Sie sich in Ruhe den Aufbau von LabVIEW SignalExpress an 
(siehe Abbildung 2-1; die Kontexthilfe ist hier ausgeblendet). 

Abbildung 2-1.  First Project.seproj

Die Programmoberfläche von LabVIEW SignalExpress besteht aus 
Ansichten für unterschiedliche Arten von Angaben. Die Hauptansicht 
wird in der Mitte des Programmfensters angezeigt und enthält 

1 Schaltfläche “Ausführen”
2 Pulldown-Menü zur Auswahl des 

Arbeitsbereichs
3 Schritt

4 Eingangssignal
5 Ausgangssignal
6 Projektansicht

7 Fenster “Protokolldaten”
8 Hauptansicht mit angezeigter Datenansicht
9 Schaltfläche “Aufnahme”

5

8

5

1

3
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2
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Registerkarten wie die Datenansicht. Um die Hauptansicht herum 
gibt es Zusatzansichten mit eigenen Titelleisten. Die Projektansicht ist 
beispielsweise eine der Zusatzansichten.

Ausführen eines Projekts und Anzeigen von Signalen
In LabVIEW SignalExpress gibt es verschiedene Ausführungsmodi. Pro-
jekte können entweder einmal oder kontinuierlich durchlaufen, eine 
bestimmte Anzahl von Iterationen absolvieren oder eine bestimmte Zeit 
lang ausgeführt werden. Beim einmaligen Durchlauf führt LabVIEW 
SignalExpress alle Schritte im Projekt einmal aus. Beim kontinuierlichen 
Durchlauf führt LabVIEW SignalExpress alle Schritte im Projekt fortlau-
fend aus. Klicken Sie auf den Pfeil der Schaltfläche Ausführen (siehe Abb. 
links) und wählen Sie Ausführung konfigurieren, um den Ausführungs-
modus für ein Projekt festzulegen.

Die Anzeige der Datenansicht wird während der Ausführung kontinuier-
lich aktualisiert. Über die Registerkarte Schritteinstellungen können Sie 
Messkonfigurationen während der Ausführung ändern. Die resultierenden 
Daten werden dann sofort angezeigt. Projekte mit fortlaufender Ausfüh-
rung werden über die Schaltfläche Stopp (siehe Abb. links) angehalten. 
Die Stopp-Schaltfläche erscheint anstelle der Ausführen-Schaltfläche, 
wenn das Projekt läuft. 

Zum Starten des Beispielprojekts in SignalExpress und zum Anzeigen von 
Signalen gehen Sie wie folgt vor:

1. Klicken Sie auf die Schaltfläche Ausführen. Wenn das Dialogfeld 
Angaben zur Ausführung angezeigt wird, klicken Sie auf Ausfüh-
ren, um alle Schritte im Projekt kontinuierlich auszuführen.

Daraufhin wird ein Signal aus einer Textdatei geladen und es werden 
zwei Arten von Messungen vorgenommen: eine Amplituden- und 
Pegelmessung sowie eine Verzerrungsmessung. Diese Messungen 
werden jeweils von den Schritten “Amplitude und Pegel” und “Verzer-
rung” vorgenommen. Bei der Ausführung eines Projekts analysieren 
die Schritte die Eingangssignale und erzeugen als Ergebnis der Ana-
lyse neue Ausgangssignale. In diesem Projekt wird mit dem Schritt 
“Aus ASCII-Datei laden” eine verzerrte Sinuskurve geladen, die dann 
mit den Schritten “Amplitude und Pegel” und “Verzerrung” ausgewer-
tet wird. Beide Schritte erzeugen eine neue Kurve. Die Eingangs-
größen werden in der Projektansicht durch rote Pfeile und die Aus-
gangsgrößen durch blaue Pfeile gekennzeichnet.
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Im Graphen in der Datenansicht wird immer noch das geladene Zeit-
bereichssignal angezeigt. Graphen können Zeitbereichs-, Frequenz-
bereichs- und XY-Signale darstellen. 

2. Ziehen Sie das Ausgangssignal Exportiertes Spektrum des Schritts 
“Verzerrung” von der Projektansicht in die Datenansicht. 

LabVIEW SignalExpress erzeugt daraufhin in der Datenansicht einen 
neuen Graphen. LabVIEW SignalExpress zeigt das Signal Exportier-
tes Spektrum nicht im selben Graphen wie das Zeitbereichssignal an, 
da es sich bei Exportiertes Spektrum um ein Frequenzbereichssignal 
handelt. LabVIEW SignalExpress erkennt Signaltypen automatisch 
und zeigt sie entsprechend an.

Tipp Weitere Informationen zu Signaltypen finden Sie in der Hilfe zu LabVIEW 
SignalExpress, indem Sie Hilfe»LabVIEW SignalExpress Hilfe auswählen, auf die 
Registerkarte Suchen klicken und das Stichwort Signaltypen eingeben. In der Hilfe 
erfahren Sie mehr zu den einzelnen Komponenten von LabVIEW SignalExpress, wie 
Projekten, Schritten oder Signalen.

3. Ziehen Sie den Ausgang DC des Schritts “Amplitude und Pegel” in die 
Datenansicht. 

LabVIEW SignalExpress erzeugt daraufhin einen Graphen und eine 
Legende, um die Messergebnisse des Ausgangs DC darzustellen. Die 
Tabelle Legende zeigt den Wert jeder Ausgabe und die Farbe, in der 
LabVIEW SignalExpress den dazugehörigen Plot im benachbarten 
Graphen darstellt.

4. Ziehen Sie den Ausgang RMS des Schritts “Amplitude und Pegel” in 
die Tabelle Legende, um die Werte der RMS-Messung anzuzeigen.
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LabVIEW SignalExpress fügt der Tabelle daraufhin eine Zeile für das 
zweite Messergebnis hinzu. Das Projekt sollte wie in Abbildung 2-2 
aussehen.

Abbildung 2-2.  Ausgangsgrößen von First Project.seproj

Konfigurieren von Schritten
Ein Schritt ist eine konfigurierbare Funktion, mit der Daten erfasst, analy-
siert, geladen oder gespeichert werden können. Jeder Schritt verarbeitet 
Signale und gibt Signale aus. Durch die Angabe von Werten auf der Regi-
sterkarte Schritteinstellungen können Sie die einzelnen Schritte konfigu-
rieren. Sie können auch bei laufenden Projekten Änderungen an den Ein-
stellungen vornehmen, so dass Sie Ihre Messungen genau anpassen 
können, bis die gewünschten Ergebnisse in der Datenansicht dargestellt 
werden.
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Zur Konfiguration der Schritte “Verzerrung” und “Amplitude und Pegel” 
gehen Sie wie folgt vor:

1. Klicken Sie den Schritt “Verzerrung” in der Projektansicht doppelt an. 
LabVIEW SignalExpress zeigt die Registerkarte Schritteinstellungen 
für den Schritt “Verzerrung” wie in Abbildung 2-3 an.

Abbildung 2-3.  Registerkarte “Schritteinstellungen” für den Schritt “Verzerrung”

Auf der Seite Konfiguration der Registerkarte Schritteinstellungen 
zeigt das Feld Signale exportieren (Klirrfaktor) an, dass mit dem 
Schritt “Verzerrung” das Eingangssignal exportiert wird. Der Graph 
Exportiertes Signal zeigt eine Vorschau des Signals an. Ausgegebe-
nes Leistungsspektrum weist darauf hin, dass der Schritt ein 
Leistungsspektrum des Signals erstellt, um es in ein Frequenzspektrum 
umzuwandeln. Der Bereich Messergebnisse zeigt die Grundfrequenz 
und den Klirrfaktor des Signals an. Der Schritt erzeugt das exportierte 
Signal und drei Messergebnisse: das Spektrum, den Klirrfaktor und die 
Grundfrequenz des ursprünglichen Eingangssignals.
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2. Wenn die Kontexthilfe nicht auf der rechten Bildschirmhälfte ange-
zeigt wird, klicken Sie auf Hilfe»Kontexthilfe. Daraufhin sollten alle 
in der Hilfe enthaltenen Informationen zu einem Schritt angezeigt 
werden. 

In der oberen Hälfte der Kontexthilfe werden Informationen zum 
Schritt selbst angezeigt und in der unteren Hälfte sehen Sie Angaben 
zu einem bestimmten Parameter des Schritts, wenn Sie den Cursor 
darauf führen. Bewegen Sie den Cursor zum Parameter Klirr-
faktor (%), um Informationen dazu anzuzeigen.

3. Wählen Sie auf der Registerkarte Konfiguration aus dem Pulldown-
Menü Signale exportieren (Klirrfaktor) die Option Grundschwin-
gung aus.

Der Graph Ausgegebenes Leistungsspektrum zeigt nun nicht mehr 
das Frequenzbereichsspektrum des gesamten Signals, sondern nur 
noch der Grundschwingung an. Das vom Schritt “Verzerrung” ausge-
gebene Signal und der Graph des Ausgangs Exportiertes Spektrum 
in der Datenansicht werden entsprechend angepasst.

4. Wählen Sie aus dem Pulldown-Menü Signale exportieren (Klirrfak-
tor) die Option Nur Harmonische aus.

Der Graph Ausgegebenes Leistungsspektrum auf der Registerkarte 
Schritteinstellungen und der Graph des Ausgangs auf der Register-
karte Datenansicht zeigen nun das Spektrum der Harmonischen des 
Eingangssignals an.

5. Klicken Sie in der Projektansicht den Schritt “Amplitude und Pegel” 
an. 

Das Dialogfeld Schritteinstellungen zeigt nun die Einstellungen zum 
Schritt “Amplituden und Pegel” an.
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6. Wählen Sie die Registerkarte Eingabe/Ausgabe, so dass eine Liste der 
möglichen Ein- und Ausgabesignale für diesen Schritt angezeigt wird 
(vgl. Abbildung 2-4).

Abbildung 2-4.  Registerkarte “Schritteinstellungen” des Schritts 
“Amplituden und Pegel”

7. Aktivieren Sie die Optionen Positiven Spitzenwert ausgeben, Nega-
tiven Spitzenwert ausgeben und Spitze-Spitze-Wert ausgeben, so 
dass diese drei Werte ermittelt werden.

In der Projektansicht erscheinen nun drei zusätzliche Ausgänge.

8. Wechseln Sie zur Datenansicht.

9. Ziehen Sie die drei neuen Ausgänge von der Projektansicht in die 
Tabelle Legende. Die neuen Ausgaben werden dann im benachbarten 
Graphen angezeigt.

Hinweis Wenn das Projekt bereits für längere Zeit läuft, sollten Sie es eventuell anhalten 
und neu starten, um alle skalaren Signale im Graphen anzuzeigen. Signale in Graphen 
werden kumulativ aufgebaut. Neu hinzugefügte Signale enthalten daher entsprechend 
weniger Werte. 
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10. Klicken Sie auf die Schaltfläche Stopp, um das Projekt anzuhalten.

Beim Anklicken der Stopp-Schaltfläche beendet das Projekt noch den 
letzten Durchlauf und hält dann an. Wenn Sie auf den Pfeil der 
Stopp-Schaltfläche klicken und Abbrechen wählen, wird das Projekt 
mit sofortiger Wirkung gestoppt, ohne die noch ausstehenden Arbeits-
schritte abzuwarten.

11. Klicken Sie auf Datei»Speichern unter und speichern Sie das Projekt 
unter dem Namen My First Project.seproj im Verzeichnis 
SignalExpress\Examples\Tutorial.

12. Schließen Sie das Projekt über Datei»Projekt schließen.

Sortieren, Verschieben und Löschen von Schritten
Die meisten Schritte in Projekten von LabVIEW SignalExpress erfordern 
Eingangsdaten. Schritte können nur mit Signalen arbeiten, die von vorhe-
rigen Schritten in der Projektansicht ausgegeben wurden. Daher kann die 
Reihenfolge der Schritte in der Projektansicht die Funktionsfähigkeit von 
Projekten beeinflussen. 

Für Schritte mit einer Seite Eingabe oder Eingabe/Ausgabe auf der Regi-
sterkarte Schritteinstellungen werden im Menü Eingangssignal nur vom 
vorherigen Schritt ausgegebene Signale angezeigt, die kompatibel sind. 
Sobald das Ausgabesignal eines Schritts am Eingang des nächsten anliegt, 
werden die Schritte voneinander abhängig und nacheinander mit der glei-
chen Rate ausgeführt. Der zweite Schritt kann erst beginnen, wenn durch 
den ersten Schritt ein Signal erzeugt wurde.

Sie können die Schritte in der Projektansicht nach oben oder unten ziehen. 
Zum Löschen eines Schritts klicken Sie ihn in der Projektansicht mit der 
rechten Maustaste an und wählen Sie aus dem Kontextmenü die Option 
Löschen aus. Allerdings ändert sich beim Verschieben oder Löschen eines 
Schritts der Status des Signals. Beim Löschen eines Schritts, auf dessen 
Ausgangssignal ein anderer Schritt angewiesen ist, funktioniert das Projekt 
beispielsweise nicht mehr und in der Projektansicht erscheint eine entspre-
chende Fehlermeldung. Sie können Schritte innerhalb eines Projekts auch 
ausschneiden, kopieren oder einfügen, indem Sie die Tastenkombinationen 
<Strg + X>, <Strg + C> und <Strg + V> drücken oder einen Schritt in der 
Projektansicht anklicken und die Option Ausschneiden, Kopieren, Vor 
markiertem Schritt einfügen oder Nach markiertem Schritt einfügen 
auswählen.
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Umgang mit Fehlern und Warnungen
Bei einem Fehler während eines laufenden Projekts wird durch eine Feh-
leranzeige (vgl. Abbildung links) in der Projektansicht der Schritt 
angezeigt, bei dem der Fehler aufgetreten ist. Wenn Sie den fehlerhaften 
Schritt doppelt anklicken, erscheint am unteren Rand der Registerkarte 
Schritteinstellungen eine Kurzbeschreibung des Fehlers. Die vollständige 
Beschreibung wird beim Anklicken der Schaltfläche Details neben der 
Fehlermeldung angezeigt.

LabVIEW SignalExpress protokolliert alle Fehler und Warnungen wäh-
rend der Ausführung eines Projekts auf der Registerkarte Ereignis-
protokoll. Wählen Sie zur Anzeige der Registerkarte Ereignisprotokoll 
die Option Ansicht»Ereignisprotokoll. Weitere Informationen zu Fehlern 
und Warnungen finden Sie in der Hilfe zu LabVIEW SignalExpress, indem 
Sie Hilfe»LabVIEW-SignalExpress-Hilfe auswählen, auf die Register-
karte Suchen klicken und das Stichwort Fehler eingeben.



© National Instruments Corporation 3-1 Erste Schritte mit LabVIEW SignalExpress

3
Arbeit mit Signalen

In LabVIEW SignalExpress können Signale ohne Programmierung gene-
riert und analysiert werden. In diesem Kapitel erfahren Sie, wie in 
LabVIEW SignalExpress mit Signalen gearbeitet wird. Sie lernen, wie 
Signale grafisch dargestellt, aus Dateien importiert, interaktiv ausgerichtet, 
verglichen und in Dateien gespeichert werden.

Graphisches Darstellen von Signalen
Gehen Sie zum Darstellen der Signale in einem Beispielprojekt und zum 
visuellen Untersuchen der Signale anhand von Cursorn wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
Signals.seproj. In diesem Projekt wird der Schritt “Analoges 
Signal erstellen” so konfiguriert, dass er ein Rechtecksignal ausgibt, 
und der Schritt “Filter” wird auf einen Butterworth-Tiefpass 
eingestellt.

2. Ziehen Sie den Ausgang step signal des Schritts “Analoges Signal 
erstellen” in die Datenansicht.

3. Ziehen Sie den Ausgang filtered step des Schritts “Filter” in die 
Datenansicht.

Da das step signal und das Signal filtered step Zeitbereichssignale 
sind, erscheinen sie im selben Graphen. Wenn Sie zwei Signale unter-
schiedlichen Typs in denselben Graphen ziehen, erstellt LabVIEW 
SignalExpress automatisch eine neue Anzeige.

4. Klicken Sie auf die Schaltfläche Anzeige hinzufügen (vgl. Abbildung 
links), damit eine neue Anzeige erzeugt wird.

5. Ziehen Sie den Ausgang filtered step des Schritts “Filter” in die neue 
Anzeige.
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6. Klicken Sie die neue Anzeige mit der rechten Maustaste an und und 
wählen Sie aus dem Kontextmenü die Option Sichtbare Objekte»
Cursor aus, so dass zwei interaktive Cursor eingeblendet werden (vgl. 
Abbildung 3-1).

Abbildung 3-1.  Signals.seproj

Wenn Sie an den Cursorn ziehen, zeigt LabVIEW SignalExpress in der 
Cursor-Tabelle unten in der Datenansicht die x- und y-Werte der 
Cursor an.

7. Klicken Sie auf Datei»Speichern unter und speichern Sie das Projekt 
unter dem Namen My Signals.seproj im Verzeichnis 
SignalExpress\Examples\Tutorial.

Importieren von Signalen aus Dateien
Signale können aus Standarddateiformaten wie ASCII (durch Kommata 
oder Tabulatoren gegliedert) oder LabVIEW-Dateien für Messwerte 
(*.lvm-Dateien) importiert werden. Ebenso können simulierte Signale von 
Programmen zur Entwurfsautomatisierung (wie SPICE) einbezogen 
werden.
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Zum Importieren eines Signals aus einer Datei gehen Sie wie folgt vor:

1. Klicken Sie mit der rechten Maustaste in die Projektansicht und 
wählen Sie Signale laden/speichern»Analoge Signale»Aus 
ASCII-Datei laden aus dem Kontextmenü, um der Projektansicht den 
Schritt “Aus ASCII-Datei laden” hinzuzufügen. Daraufhin wird die 
Registerkarte Schritteinstelungen für den Schritt angezeigt. Der 
Schritt liest die Signale in der ASCII-Datei und stellt sie grafisch dar.

Hinweis Schritte können über das Menü Schritt hinzufügen, die Palette Schritt hinzu-
fügen oder das Kontextmenü der Projektansicht erstellt werden.

2. Klicken Sie auf der Registerkarte Schritteinstellungen auf die 
Schaltfläche “Durchsuchen” (vgl. Abbildung links). Wechseln Sie 
anschließend zum Verzeichnis SignalExpress\Examples\
Tutorial und klicken Sie die Datei Step Response.txt doppelt an.

In der Spalte 1 der Dateivorschau werden die Zeitwerte und in 
Spalte 2 die tatsächlichen Spannungswerte des Signals angezeigt.

3. Wechseln Sie auf der Registerkarte Schritteinstellungen zur Seite 
Signale importieren, um die Signale der Datei anzuzeigen.

4. Aktivieren Sie die Option Spalte 2, um das entsprechende Signal zu 
importieren, und deaktivieren Sie Spalte 1.

Auf der Registerkarte Schritteinstellungen wird nun unter Impor-
tiertes Signal eine Vorschau des Signals angezeigt.

5. Wählen Sie aus dem Pulldown-Menü x-Eingangswerte die Option 
Spalte 1 aus, um die Werte auf der x-Achse entsprechend einzustellen.

6. Wechseln Sie zur Datenansicht.

7. Erweitern Sie in der Projektansicht den Ausgang Step Response.txt 
des Schritts “Aus ASCII-Datei laden”.

8. Klicken Sie mit der rechten Maustaste auf den Ausgang Spalte 2 und 
wählen Sie aus dem Kontextmenü die Option Umbenennen.

9. Geben Sie step response ein und drücken Sie <Enter>, um den 
neuen Namen zu übernehmen.
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10. Ziehen Sie den neuen Ausgang step response des Schritts “Aus 
ASCII-Datei laden” in die untere Anzeige der Datenansicht.

Das Signal filtered step ähnelt der steigenden Flanke von step 
response (vgl. Abbildung 3-2).

Abbildung 3-2.  Signals of Signals.seproj

11. Speichern Sie das Projekt über Datei»Projekt speichern.

Ausrichten und Vergleichen von Signalen
Obwohl sowohl am Signal filtered step als auch am Signal step response 
ein Überschwingen an der steigenden Flanke zu verzeichnen ist, lässt sich 
die Ähnlichkeit zwischen beiden nur schwer abschätzen, da die Signale aus 
unterschiedlichen Quellen stammen und in Amplitude und Zeit nicht iden-
tisch sind. Sie können die Signale jedoch mit dem Schritt “Interaktive 
Ausrichtung” aneinander ausrichten und auswählen, welche Angaben für 
das Projekt eine Rolle spielen sollen.
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Zum Ausrichten zweier Signale im Projekt My Signals.seproj gehen 
Sie wie folgt vor:

1. Erweitern Sie den Ausgang Step Response.txt, klicken Sie mit der 
rechten Maustaste auf den den Ausgang step response und wählen Sie 
Senden an»Verarbeitung»Analoge Signale»Interaktive Ausrich-
tung aus dem Kontextmenü, um das Signal step response vom Schritt 
“Aus ASCII-Datei laden” in den Schritt “Interaktive Ausrichtung” zu 
übertragen.

Daraufhin werden die zwei neuesten Signale des Projekts als Ein-
gangssignale ausgewählt und im Graphen auf der Registerkarte 
Schritteinstellungen dargestellt (vgl. Abbildung 3-3).

Abbildung 3-3.  Schritteinstellungen für “Interaktive Ausrichtung”

Beim Hinzufügen von Schritten zu einem Projekt wählt LabVIEW 
SignalExpress die Eingangssignale je nach Signaltypen, mit denen der 
Schritt arbeitet. Der Schritt “Interaktive Ausrichtung” funktioniert bei-
spielsweise nur mit Signalverläufen im Zeitbereich. Daher werden für 
den Schritt die zwei letzten Zeitbereichssignale ausgewählt, die im 
Projekt erstellt wurden. 
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Hinweis Um die Eingangssignale eines Schritts zu ändern, wählen Sie aus dem 
Pulldown-Menü auf der Seite Eingabe oder Eingabe/Ausgabe der Registerkarte 
Schritteinstellungen ein anderes Signal aus oder klicken Sie auf den Pfeil neben den 
Schritteingangsnamen in der Projektansicht.

2. Klicken Sie im Graphen Eingangssignale das rote Signal an und 
ziehen Sie es an eine andere Stelle im Graphen. Daraufhin wird der 
Graph Signal nach Vergleich aktualisiert und der berechnete Unter-
schied zwischen beiden Signalen angezeigt.

Sie können das Signal verschieben, aufziehen und stauchen.

3. Versuchen Sie, die steigenden Flanken der beiden Signale in eine Linie 
zu bringen, indem Sie das Signal im Graphen verschieben. Klicken Sie 
ein Signal an, um einen Ankerpunkt zu setzen, und ziehen Sie bei 
gedrückter <Alt>-Taste am Signal, um es auf der x- oder y-Achse um 
den Ankerpunkt zu dehnen.

Auf der Seite Ausrichtung der Registerkarte Schritteinstellungen 
werden automatisch die Verstärkung (der Faktor) und der Offset (Sum-
mand) für den x- und y-Wert angezeigt.

4. Wählen Sie aus dem Pulldown-Menü Modus die Option Autom. 
Schritt aus, um die Signale in eine Linie zu bringen. LabVIEW 
SignalExpress berechnet die Ausrichtung mithilfe integrierter 
Algorithmen.

Der Graph Signal nach Vergleich auf der Registerkarte Schrittein-
stellungen zeigt den Unterschied zwischen den beiden Signalen an.

5. Aktivieren Sie auf der Seite Eingabe/Ausgabe die Option Ausgerich-
tete Signale ausgeben, um die Signale als Ausgangsgrößen des 
Schritts hinzuzufügen.

6. Wechseln Sie zur Datenansicht.

7. Klicken Sie auf die Schaltfläche Neue Anzeige, um eine dritte 
Anzeige hinzuzufügen.

8. Ziehen Sie die Ausgangssignale Bezugssignal ausgerichtet und Test-
signal ausgerichtet des Schritts “Interaktive Ausrichtung” in den 
neuen Graphen, um die ausgerichteten Signale anzuzeigen.

9. Speichern Sie das Projekt über Datei»Projekt speichern.
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Signaltypen in LabVIEW SignalExpress
Einige Schritte, zum Beispiel der Schritt “Arithmetik”, arbeiten mit ver-
schiedenen Signaltypen. Sie können mit dem Schritt “Arithmetik” 
Berechnungen an Zeit- und Frequenzbereichssignalen vornehmen. Je nach 
ausgewähltem Eingangssignal passt sich der Schritt entsprechend an. 
Wenn Sie zum Beispiel zwei Zeitbereichssignale addieren, werden nur die 
Amplituden addiert. Bei zwei Frequenzbereichssignalen addiert LabVIEW 
SignalExpress dagegen die entsprechende Phasenverschiebung.

Weitere Informationen zu Signaltypen finden Sie in der Hilfe zu LabVIEW 
SignalExpress, indem Sie Hilfe»LabVIEW SignalExpress Hilfe auswäh-
len, auf die Registerkarte Suchen klicken und das Stichwort Signaltypen 
eingeben.

Exportieren und Drucken von Signalen
Mithilfe von LabVIEW SignalExpress können Sie Signale beschreiben und 
in anderen Programmen weiter analysieren. In diesem Abschnitt lernen Sie, 
wie Signale exportiert (z. B. in eine ASCII-Datei), an Microsoft Excel 
übertragen, gedruckt oder mit der Dokumentationsfunktion von LabVIEW 
SignalExpress beschrieben werden.

Speichern von Signalen in Dateien
Zum Speichern eines Signals aus dem Projekt My Signals.seproj in 
einer Datei gehen Sie wie folgt vor:

1. Zur Anzeige der Palette Schritt hinzufügen klicken Sie die Schaltflä-
che Schritt hinzufügen an (vgl. Abbildung links).

2. Wählen Sie Signale laden/speichern»Als ASCII/LVM speichern, 
um diesen Schritt der Projektansicht hinzuzufügen. Daraufhin wird die 
Registerkarte Schritteinstellungen für den Schritt “Als ASCII/LVM 
speichern” angezeigt.

3. Klicken Sie auf der Registerkarte Schritteinstellungen auf die Seite 
Signale und wählen Sie aus dem Pulldown-Menü Eingangsdaten die 
Option filtered step aus.

4. Geben Sie auf der Seite Datei-Einstellungen an, wo die erstellte Text-
datei gespeichert werden soll. Klicken Sie neben dem Feld Pfad zur 
Exportdatei auf die Schaltfläche Durchsuchen, wechseln Sie zum 
Verzeichnis SignalExpress\Examples\Tutorial und geben Sie 
filtered signal.txt als Dateinamen an.
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5. Wählen Sie aus dem Pulldown-Menü Bei vorhandener Datei die 
Option Überschreiben aus.

6. Wählen Sie aus dem Pulldown-Menü Typ der Exportdatei die Option 
Allgemeine ASCII-Datei (*.txt) aus.

Mit dem Schritt “Signale laden/speichern” können Sie bei jeder Aus-
führung des Projekts Daten in Dateien speichern.

7. Klicken Sie auf den Pfeil der Schaltfläche Ausführen und wählen Sie 
Einmal ausführen, um das Projekt zu starten und das erzeugte Signal 
in der angegebenen ASCII-Datei zu speichern.

8. Speichern Sie das Projekt über Datei»Projekt speichern.

9. Schließen Sie das Projekt über Datei»Projekt schließen.

10. Öffnen Sie die Datei filtered signal.txt in einem Texteditor, 
um die Werte des Signals anzuzeigen. Mithilfe des Schritts “Aus 
ASCII-Datei laden” können die Signale wieder in ein Projekt in 
LabVIEW SignalExpress importiert werden.

Exportieren von Signalen nach Microsoft Excel
Um Signaldaten nach Microsoft Excel zu exportieren, starten Sie Excel und 
ziehen Sie das Ausgabesignal eines Schritts in LabVIEW SignalExpress in 
eine Excel-Tabelle. Sie können auch mit der rechten Maustaste in die 
Datenansicht klicken und die Option Exportieren in»Microsoft Excel 
wählen, um alle Daten der Anzeige zu importieren.

Drucken von Signalen
Zum Drucken eines Graphen öffnen Sie die Datenansicht und wählen Sie 
die Option Datei»Drucken»Datenansicht drucken.

Erstellen von Protokollen in LabVIEW SignalExpress
Über Ansicht»Projektdokumentation wird die Registerkarte Projektdo-
kumentation geöffnet. Hier können Sie ein Projekt mithilfe von Text und 
Abbildungen wie Graphen beschreiben. Wenn Sie ein Signal von der Pro-
jektansicht in die Registerkarte Projektdokumentation ziehen, wird es 
darin grafisch dargestellt. Wird das Projekt noch ausgeführt, wird auch der 
Graph in der Projektdokumentation automatisch aktualisiert. 

Zum Drucken der Dokumentation wechseln Sie zur Registerkarte Projekt-
dokumentation und wählen Sie Datei»Drucken»Dokumentation 
drucken oder klicken Sie auf die Schaltfläche Dokumentation drucken. 
Zum Umwandeln der Dokumentation in das HTML-Format wechseln Sie 
zur Registerkarte Projektdokumentation und wählen Sie Datei»
Exportieren»Dokumentation als HTML-Datei speichern.



© National Instruments Corporation 4-1 Erste Schritte mit LabVIEW SignalExpress

4
Protokollieren von Daten

Mit LabVIEW SignalExpress können Sie Messergebnisse aufzeichnen und 
auswerten. Sie können alle Arten von Zeitbereichssignalen bzw. Werten 
mit doppelter Genauigkeit sowie im vorzeichenlosen 32-Bit- und im boo-
leschen Format protokollieren. Außerdem können Sie protokollierte Werte 
analysieren und verarbeiten, indem Sie Analyseschritte darauf anwenden. 

In diesem Kapitel lernen Sie, wie Werte mit den entsprechenden Funktio-
nen in LabVIEW SignalExpress protokolliert werden. Sie erfahren, wie ein 
angegebenes Signal aufgenommen, wiedergegeben und mit den Analyse-
schritten ausgewertet wird. Außerdem wird beschrieben, wie mit der 
Registerkarte Aufnahmeoptionen Signale nach bestimmten Start- oder 
Stoppbedingungen protokolliert werden. 

Aufnehmen eines Signals
Mit der Schaltfläche Aufnehmen wird die Protokollierung konfiguriert. 

Zum Auswählen und Aufnehmen eines Signals gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
Logging.seproj.

In diesem Projekt wird mit dem Schritt “Analoges Signal erstellen” ein 
Signal anhand einer Formel erstellt.

2. Klicken Sie auf die Schaltfläche Aufnahme (vgl. Abbildung links), 
um das Dialogfeld Signalauswahl für Protokollierung zu öffnen.

Das Dialogfeld Signalauswahl für Protokollierung zeigt alle Signale 
im Projekt an, die aufgenommen werden können. Sie können ein 
Signal oder mehrere Signale auswählen. Außerdem kann das Protokoll 
hier benannt und beschrieben werden.

3. Aktivieren Sie die Option signal, um das berechnete Signal des 
Schritts “Analoges Signal erstellen” aufzunehmen.

4. Klicken Sie auf die Schaltfläche OK, um das Dialogfeld Signalaus-
wahl für Protokollierung zu schließen und die Aufnahme zu 
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beginnen. Die Aufnahme läuft bis zum Anklicken der Schaltfläche 
Stopp.

5. Klicken Sie auf die Schaltfläche Stopp (vgl. Abbildung links), um die 
Aufnahme anzuhalten. Wenn zuvor noch kein Signal aufgenommen 
wurde, wird das Dialogfeld Erstes Protokoll vollständig angezeigt. 
Klicken Sie auf OK.

Die aufgezeichneten Daten werden im Fenster Protokolldaten im 
unteren Bereich der Projektansicht angezeigt (vgl. Abbildung 4-1).

Abbildung 4-1.  Fenster “Protokolldaten”

Per Voreinstellung kennzeichnet LabVIEW SignalExpress die Werte 
mit dem Datum und der Zeit, zu der sie aufgezeichnet wurden. 
LabVIEW SignalExpress speichert protokollierte Werte in einer Datei 
im *.tdms-Format in dem unter Optionen angegebenen Verzeichnis. 

6. Zur Auswahl eines Verzeichnisses für protokollierte Werte wählen Sie 
Werkzeuge»Optionen und klicken Sie auf Protokollierung. Hier 
finden Sie auch alle anderen Einstellungen zur Protokollierung.

7. Klicken Sie anschließend zum Verlassen des Dialogfelds Optionen 
auf OK.

8. Klicken Sie auf Datei»Projekt speichern unter und speichern Sie das 
Projekt unter dem Namen My Logging.seproj im Verzeichnis 
SignalExpress\Examples\Tutorial.

Anzeigen aufgezeichneter Signale
Zum Anzeigen der aufgezeichneten Werte gehen Sie wie folgt vor:

1. Wenn die Datenansicht ausgeblendet ist, wählen Sie Ansicht»
Datenansicht. 

2. Unter Protokolldaten wird eine Liste aller aufgezeichneten Werte des 
Projekts angezeigt. Markieren Sie das Protokoll, das Sie gerade im 
Fenster Protokolldaten erstellt haben, und ziehen Sie es in die Daten-
ansicht. In der Datenansicht werden die Protokolldaten und eine 
Vorschau angezeigt (vgl. Abbildung 4-2). Das Signal in der Datenan-



Kapitel 4 Protokollieren von Daten

© National Instruments Corporation 4-3 Erste Schritte mit LabVIEW SignalExpress

sicht kann sich je nach Länge der Aufzeichnung vom Signal in 
Abbildung 4-2 unterscheiden.

Abbildung 4-2.  Logging.seproj

In der Vorschau können Sie in die Datenansicht hineinzoomen oder 
sich darin durch Hin- und Herziehen der Maus verschiedene 
Abschnitte ansehen. Die Vorschau wird bei der Anzeige aufgezeichne-
ter Werte immer als erstes geöffnet. Für aktuelle oder andere nicht 
aufgezeichnete Werte können Sie die Vorschau öffnen, indem Sie die 
Datenansicht mit der rechten Maustaste anklicken und Sichtbare 
Objekte»Vorschau auswählen.

3. Zum Vergrößern der aufgezeichneten Werte klicken Sie auf die Schalt-
fläche Heranzoomen neben der Vorschau. Die Cursor in der Vorschau 
deuten auf die Werte, die gerade in der Datenansicht angezeigt wer-
den. Mit der Bildlaufleiste unter der Vorschau können Sie durch die 
Werte scrollen. Durch Anklicken und Ziehen der Cursor können Sie 
mehr oder weniger Werte anzeigen.

1 Protokolldaten 2 Vorschau

1

2
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Protokollieren von Signalen mit festgelegten Start- und 
Stoppbedingungen

Mit Hilfe von Start- und Stoppbedingungen können Sie einen Zeitraum 
festlegen, während dessen LabVIEW SignalExpress Signale aufzeichnen 
soll. Gehen Sie dazu wie folgt vor:

1. Wenn die Registerkarte Aufnahmeoptionen ausgeblendet ist, wählen 
Sie Ansicht»Aufnahmeoptionen.

2. Wählen Sie auf der Registerkarte Aufnahmeoptionen aus der Liste 
Kategorie die Option Signalauswahl aus.

3. Setzen Sie dann neben dem Signal in der Spalte Aufnahme ein Häk-
chen (vgl. Abbildung 4-3).

Abbildung 4-3.  Signalauswahl

Die Schaltfläche Aufnahme wandelt sich daraufhin in Aufnahme 
während Ausführung um (vgl. Abbildung links). Die Schaltfläche 
Aufnahme während Ausführung muss angeklickt sein. Wenn Auf-
nahme während Ausführung gedrückt ist, zeichnet LabVIEW 
SignalExpress das ausgewählte Signal nach Anklicken von Ausfüh-
ren auf.
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4. Wählen Sie auf der Registerkarte Aufnahmeoptionen aus der Liste 
Kategorie die Option Startbedingungen aus. 

5. Klicken Sie auf die Schaltfläche Hinzufügen unter der Liste der 
Startbedingungen, um eine Bedingung für die Protokollierung 
festzulegen.

a. Stellen Sie sicher, dass im Pulldown-Menü Bedingungsart die 
Option Signal-Trigger ausgewählt ist. So wird festgelegt, dass 
LabVIEW SignalExpress die Aufnahme beginnt, wenn das Ein-
gangssignal die angegebene Bedingung erfüllt.

b. Im Pulldown-Menü Signal muss signal ausgewählt sein.

c. Unter Trigger-Typ muss Pos. Steigung ausgewählt sein. Mit der 
Aufnahme soll also begonnen werden, wenn das Signal die ange-
gebene Flanke bei positiver Steigung erreicht.

d. Geben Sie 1 unter Trigger-Wert ein. Die Protokollierung beginnt 
dann beim Wert 1 einer steigenden Flanke.

6. Wählen Sie auf der Registerkarte Aufnahmeoptionen aus der Liste 
Kategorie die Option Stoppbedingungen aus.

7. Klicken Sie auf die Schaltfläche Hinzufügen unter der Liste der 
Stoppbedingungen, um eine Bedingung für die Protokollierung 
festzulegen.

a. Stellen Sie sicher, dass im Pulldown-Menü Bedingungsart die 
Option Dauer ausgewählt ist, um anzugeben, dass die Aufnahme 
nach Ablauf einer bestimmten Zeit angehalten werden soll.

b. Geben Sie als Dauer den Wert 5 ein. Das Signal wird dann nach 
Erfüllen der Startbedingung fünf Sekunden lang aufgezeichnet.

8. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links). 
LabVIEW SignalExpress beginnt dann beim Übersteigen von Pegel 1 
an einer steigenden Flanke mit der Prokollierung und zeichnet das 
Signal fünf Sekunden lang auf. 

Folgende Anzeigen werden im Bereich Protokollierungsstatus der 
Registerkarte Aufnahmeoptionen während der Ausführung des Pro-
jekts aktualisiert:

• Aufnahme lautet EIN, wenn das Signal die Startbedingung erfüllt 
und die Protokollierung läuft. 

• Festplattenangaben zeigt an, wie viel Festplattenspeicher für die 
Protokollierung noch frei ist. 

• Geschätzte Protokollgröße zeigt die Größe der Protokolldatei 
an.
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• Verbleibende Zeit zeigt die Zeit an, die für die Protokollierung 
noch zur Verfügung steht, bis die Festplatte voll ist.

• Aktuelles Protokoll begann zeigt die Startzeit des aktuellen Pro-
tokolls an.

Die Seiten Startbedingungen, Stoppbedingungen, Alarme und 
Ereignisse der Registerkarte Aufnahmeoptionen enthalten auch 
Anzeigen für den Status von Start- und Stoppbedingungen, Alarmen 
und Ereignissen.

Analysieren aufgezeichneter Signale
Nach dem Aufzeichnen eines Signals können Sie dieses wieder abspielen 
und mit Analyseschritten auswerten. Zum Analysieren eines aufgezeichne-
ten Signals gehen Sie wie folgt vor:

1. Suchen Sie das Pulldown-Menü Arbeitsbereich über der Projektan-
sicht (vgl. Abbildung 4-4). Klicken Sie auf den Pfeil und wählen Sie 
Wiedergabe aus, um in den Wiedergabebereich zu wechseln.

Abbildung 4-4.  Pulldown-Menü zur Auswahl des Arbeitsbereichs

In Arbeitsbereichen können Sie im selben Projekt mehrere Arbeits-
schritte von LabVIEW SignalExpress ausführen. So können Sie z. B. 
Daten erfassen, Signale verarbeiten, Daten aufzeichnen und Messun-
gen an den aufgezeichneten Daten vornehmen, ohne dazu ein neues 
Projekt öffnen zu müssen. Beim Speichern eines Projekts speichert 
LabVIEW SignalExpress alle Arbeitsbereiche zum Projekt in dersel-
ben Datei.

Im voreingestellten Arbeitsbereich, “Anzeigen/Aufnehmen”, können 
Sie Messungen an Signalen durchführen, die Signale auswerten und 
aufzeichnen. Im Wiedergabebereich können im Arbeitsbereich 
“Anzeigen/Aufnehmen” aufgenommene Daten als Eingangswerte für 
eine Analyse verwendet werden.

2. Klicken Sie auf die Schaltfläche Schritt hinzufügen (vgl. Abbildung 
links) und wählen Sie Verarbeitung»Analoge Signale»Filter. 
LabVIEW SignalExpress legt an den Eingang des Schritts “Filter” 
automatisch das erste aufgezeichnete Signal an.
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3. Wechseln Sie zur Datenansicht und ziehen Sie das Ausgangssignal 
gefilterte Daten des Schritts “Filter” in die Datenansicht, um das 
resultierende Signal anzuzeigen.

4. Klicken Sie auf die Schaltfläche Ausführen. In der Datenansicht 
wird nun das gefilterte Signal angezeigt und LabVIEW SignalExpress 
spielt die gesamte Aufzeichnung ab.

Erweiterte Wiedergabe
Auf der Registerkarte Wiedergabeoptionen können Sie fortgeschrittene 
Optionen für die Datenwiedergabe konfigurieren. Die Registerkarte Wie-
dergabeoptionen zeigt eine Vorschau der aufgezeichneten Daten an und 
Sie können daraus einen Abschnitt auswählen, der mit den Analyseschrit-
ten ausgewertet werden soll.

1. Wählen Sie Ansicht»Wiedergabeoptionen, um zur Registerkarte 
Wiedergabeoptionen zu wechseln (vgl. Abbildung 4-5). 

Abbildung 4-5.  Ansicht “Wiedergabeoptionen”

2. Wählen Sie im Feld Protokolliertes Signal das signal der letzten Auf-
nahme aus.

3. Geben Sie als Startzeit (s) den Wert 1 ein. So werden alle Daten abge-
spielt oder ausgewertet, die eine Sekunde nach Beginn der 
Aufzeichnung aufgenommen wurden. 

4. Geben Sie als Stoppzeit (s) den Wert 4 ein. Damit werden alle Daten 
bis zum Ablauf von vier Sekunden nach Aufzeichnungsbeginn abge-
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spielt oder ausgewertet. Wenn das Protokoll kürzer als vier Sekunden 
ist, passen Sie die Stoppzeit (s) entsprechend an. 

5. Klicken Sie im Feld Protokolliertes Signal mit der rechten Maustaste 
auf signal (zweite Aufnahme) und wählen Sie Aktivieren aus dem 
Kontextmenü, um das Signal als aktives Protokoll festzulegen.

Hinweis Sie können auch ein Protokoll im Fenster Protokolldaten mit der rechten 
Maustaste anklicken und Protokoll aktiv schalten aus dem Kontextmenü wählen.

6. Wechseln Sie zur Datenansicht. Der Graph in der Datenansicht wird 
automatisch aktualisiert, so dass nach der Aktivierung des zweiten 
Protokolls das darin aufgezeichnete Signal angezeigt wird. 

7. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links). 
LabVIEW SignalExpress filtert nun den Bereich des Signals, den Sie 
in den Wiedergabeoptionen angegeben haben. Das gefilterte Signal 
wird in der Datenansicht angezeigt.

In der Hilfe zu LabVIEW SignalExpress sind weitere Optionen zur Auf-
zeichnung und Wiedergabe von Daten, z. B. anhand von Alarmbedin-
gungen, beschrieben.
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5
Messungen mit variierenden 
Größen

Mit LabVIEW SignalExpress können Sie Messungen mit dem so genann-
ten Sweep-Modus automatisieren, um Produktentwürfe zu testen und zu 
überprüfen, ob diese realen Bedingungen standhalten. In LabVIEW Signal-
Express können Sie beliebige Produktentwürfe validieren. Anhand von 
Sweep-Messungen können Sie Daten zu Produktentwürfen über einen 
Bereich von Konditionen hinweg gewinnen, um die Funktion der Entwürfe 
zu dokumentieren. So können Sie zum Beispiel die Frequenz eines ange-
legten Signals wobbeln oder eine Versorgungsspannung variieren, um 
Produktentwürfe auszutesten.

In diesem Kapitel lernen Sie, wie mit dem Sweep-Schritt in LabVIEW 
SignalExpress Messungen mit variierenden Parametern vorgenommen 
werden. Sie erfahren u. a., wie die Reaktion eines Filters auf eine Reihe ver-
schiedener Frequenzen gemessen wird. Es wird beschrieben, wie die 
Ergebnisse der Sweep-Messung angezeigt und parallele Sweeps für kom-
plexe Messungen vorgenommen werden.

Festlegen des Messbereichs und der Ausgangsgrößen
In LabVIEW SignalExpress können Sie Messungen durch komplexe, sich 
wiederholende Messungen mit variierenden Parametern automatisieren.

Zum Festlegen eines Frequenzbereichs, mit dem ein Filter in einem Bei-
spielprojekt gewobbelt werden soll, gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
Sweep.seproj.

2. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links), 
um die kontinuierliche Ausführung des Projekts zu starten.

Mit dem Schritt “Analoges Signal erstellen” wird ein Sinussignal 
generiert, das den Schritt “Filter” (als elliptischen Bandpassfilter kon-
figuriert) durchläuft. Anschließend wird mit dem Schritt “Amplitude 
und Pegel” der Effektivpegel des Filters gemessen und mithilfe des 
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Schritts “Formel” in Dezibel umgerechnet. Der Filterschritt soll den 
Prüfling simulieren, so dass das Projekt keine Hardware benötigt. Sie 
können aber auch ein tatsächliches Signal von einem Arbiträr- oder 
Funktionsgenerator, einer Multifunktionskarte von National Instru-
ments oder das Ergebnis einer Analyse dynamischer Signale 
verwenden.

3. Klicken Sie auf die Schaltfläche Stopp, um das Projekt anzuhalten.

4. Klicken Sie auf die Schaltfläche Schritt hinzufügen (vgl. Abbildung 
links) und wählen Sie Ausführungssteuerung»Sweep, um der Pro-
jektansicht den Schritt “Sweep” hinzuzufügen.

5. Klicken Sie auf der Registerkarte Schritteinstellungen auf die Schalt-
fläche Hinzufügen. Daraufhin wird zu jedem Schritt im Projekt eine 
Liste variierbarer Parameter angezeigt (vgl. Abbildung 5-1).

Abbildung 5-1.  Auswahlfeld der variierbaren Messparameter

6. Wählen Sie unter Analoges Signal erstellen die Option Frequenz 
(Hz) aus und klicken Sie auf OK.

Der Schritt “Sweep” umfasst den Schritt “Analoges Signal erstellen”, 
der das Signal für die Messung mit variierenden Parametern stellt.

7. Wählen Sie auf der Seite Sweep-Konfiguration der Registerkarte 
Schritteinstellungen aus dem Pulldown-Menü Typ die Option Expo-
nentiell aus.

8. Geben Sie 1k für Start: Frequenz (Hz) und 40k für Stopp: Fre-
quenz (Hz) ein.

9. Geben Sie unter Werteanzahl den Wert 150 ein.
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Die Seite Sweep-Konfiguration sollte Abbildung 5-2 entsprechen.

Abbildung 5-2.  Registerkarte “Schritteinstellungen” für den Schritt “Sweep”

Mit dem Schritt “Sweep” können Sie für den Parameter Frequenz 
(Hz) des Schritts “Analoges Signal erstellen” einen Bereich von 
Werten festlegen, die nacheinander durchlaufen werden sollen. Der 
Schritt “Analoges Signal erstellen” erzeugt dann anhand dieses 
Bereichs bei jeder der Frequenzen eine Sinusschwingung. Der 
Sweep-Schritt ist aber nicht auf das Wobbeln von Frequenzen 
beschränkt, sondern funktioniert auch mit anderen Schritten, sofern 
deren Parameter variierbar sind.

10. Wechseln Sie zur Seite Sweep-Ausgabe.

11. Klicken Sie auf die Schaltfläche Hinzufügen, um zu jedem Schritt 
eine Liste variierbarer Parameter anzuzeigen.

12. Wählen Sie den Ausgang response amplitude in dB unter Formel 
und klicken Sie auf OK, um die Messung dem gewobbelten Parameter 
Frequenz (Hz) gegenüberzustellen.

Mit dem Sweep-Schritt wird um alle anderen Schritte in der Projektan-
sicht eine Schleife gelegt, in der diese wiederholt werden.
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Messungen mit variierenden Größen
Beginnen Sie die Messung mit variierenden Parametern wie folgt:

1. Wechseln Sie zur Datenansicht und klicken Sie auf den Pfeil der 
Schaltfläche Ausführen. Wählen Sie dann die Option Einmal 
ausführen.

Der Ausgang stimulus signal des Graphen geht nun die Frequenzen 
im angegebenen Bereich nacheinander durch.

2. Ziehen Sie das Signal response amplitude in dB vs. Frequency am 
unteren Rand der Sweep-Schleife in die Datenansicht, damit das 
Ergebnis der Messung angezeigt wird.

LabVIEW SignalExpress erzeugt daraufhin einen neuen Graphen. Die 
Messung mit variierenden Parametern ergibt ein x-y-Array, für das ein 
gesonderter Graph benötigt wird (vgl. Abbildung 5-3).

Abbildung 5-3.  Sweep.seproj

3. Wählen Sie erneut die Option Einmal ausführen.

Der Frequenzgang des Filters wird auf dem neuen Graphen dargestellt. 
Der Graph zeigt die Übertragungsfunktion des Filters an, also die 
Amplitude in dB gegenüber der Frequenz.
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Hinweis Per Voreinstellung werden Anzeigen in der Datenansicht zwischen den Iteratio-
nen eines Sweeps nicht gelöscht. Da der Frequenzgang des Filterschritts für jede Iteration 
gleich ist, scheint es, als würde der Graph mit dem Signal während der Ausführung des 
Projekts nicht aktualisiert werden. Auf der Seite Daten des Dialogfelds Optionen können 
Sie festlegen, ob die Anzeigen zwischen den Iterationen eines Sweeps gelöscht werden sol-
len. Wählen Sie dazu Werkzeuge»Optionen, um das Dialogfeld Optionen anzuzeigen.

4. Klicken Sie den Schritt “Filter” doppelt an, so dass auf der Register-
karte Schritteinstellungen die Filterspezifikationen angezeigt 
werden.

Der unter Amplitudengang des Filters (dB) dargestellte Frequenz-
gang entspricht dem Graphen in der Datenansicht.

5. Klicken Sie auf Datei»Projekt speichern unter und speichern Sie das 
Projekt unter dem Namen My Sweep.seproj im Verzeichnis 
SignalExpress\Examples\Tutorial.

Sie können auch mehrere Parameter gleichzeitig variieren, indem Sie auf 
der Seite Sweep-Konfiguration der Registerkarte Schritteinstellungen 
des Schritts “Sweep” weitere Parameter auswählen. Ein Sweep mit mehre-
ren variierenden Parametern wird paralleler Sweep genannt. Wenn Sie zum 
Beispiel ein Signal mit wechselnder Amplitude anlegen möchten, erzielen 
Sie die höchste Messgenauigkeit, indem Sie den Eingangsbereich des 
A/D-Wandlers oder der MIO-Karte mit dem Signalpegel variieren lassen. 
Durch stetiges Anpassen des Eingangsbereichs des Messgeräts an den 
Signalpegel können Sie die ganze Auflösung des Geräts für die Messung 
nutzen.

Geschachtelte Messungen mit variierenden Parametern
Ebenso können zwei Sweeps ineinander verschachtelt werden. So können 
Sie zum Beispiel bei verschiedenen Amplituden durch die Frequenzen 
eines Signals wobbeln. Sie können beispielsweise die Amplitude auf den 
Pegel 1 setzen und alle Frequenzen durchlaufen, dann die Amplitude auf 2 
setzen und alle Frequenzen durchlaufen usw. Um eine geschachtelte Mes-
sung mit variierenden Parametern durchzuführen, klicken Sie einen 
Sweep-Schritt in einem Projekt mit der rechten Maustaste an und wählen 
Sie Multi-Sweep hinzufügen, um eine weitere Sweep-Schleife 
einzufügen. 
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Zum Öffnen eines Beispielprojekts, in dem geschachtelte Messungen mit 
variierenden Parametern demonstriert werden, gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
Nested Sweep.seproj.

2. Klicken Sie zum Starten des Projekts auf die Schaltfläche Ausführen.

Jedes Mal, wenn die innere Sweep-Schleife durchläuft, wird die 
Frequenz des anliegenden Signals gewobbelt. Mit der äußeren 
Sweep-Schleife werden die obere und untere Grenzfrequenz des 
Schritts “Filter” verändert. Jede Iteration wird verzögerungsfrei im 
oberen Graphen dargestellt. Im unteren Graphen erscheinen dazu die 
Messergebnisse bei jeder Änderung der Grenzfrequenz (vgl. 
Abbildung 5-4).

Abbildung 5-4.  Nested Sweep.seproj

3. Klicken Sie auf die Schaltfläche Stopp (vgl. Abbildung links), um das 
Projekt zu beenden.
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Erweitern von 
LabVIEW-SignalExpress- 
Projekten durch LabVIEW

Mit den Schritten zur Erfassung, Erzeugung, Analyse oder Aufzeichung 
von Daten können Sie mit LabVIEW SignalExpress automatisierte Mes-
sungen vornehmen. LabVIEW SignalExpress kann auf folgende Arten 
durch LabVIEW erweitert werden:

• Erstellen eines VIs in LabVIEW und Importieren des VIs in LabVIEW 
SignalExpress als neuen Schritt. So können Sie die Funktionen von 
LabVIEW SignalExpress beliebig erweitern.

• Umwandeln eines LabVIEW-SignalExpress-Projekts in ein 
LabVIEW-Blockdiagramm, um den Schritt in LabVIEW weiter 
auszubauen.

Für die Übungen in diesem Kapitel benötigen Sie eine LabVIEW-Version 
ab 7.1.

Importieren von VIs in LabVIEW SignalExpress als neue 
Schritte

Mit dem Schritt “LabVIEW-VI ausführen” können Sie beliebige 
LabVIEW-VIs von LabVIEW SignalExpress aus aufrufen. Dadurch sind 
folgende Funktionen möglich:

• Steuern von GPIB-Instrumenten

• Arbeit mit Hardware von National Instruments, die 
LabVIEW SignalExpress nicht unterstützt

• Arbeit mit zusätzlichen Dateiformaten

• Einblenden von Bedienungsanleitungen in Popup-Dialogfeldern

• Festlegen von Messalgorithmen
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Gehen Sie zum Importieren eines LabVIEW-VIs mit dem Schritt 
“LabVIEW-VI ausführen” wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
User Step.seproj.

In diesem Projekt wird mit dem Schritt “Analoges Signal erstellen” ein 
Signal erstellt.

2. Klicken Sie auf die Schaltfläche Schritt hinzufügen und wählen Sie 
LabVIEW-VI ausführen»VI ausführen - LabVIEW 8.6. 

Das in dieser Übung verwendete VI wurde in LabVIEW 8.6 gespei-
chert. Sie müssen immer die Version des Schritts “LabVIEW-VI 
ausführen” aufrufen, in der das VI gespeichert wurde.

3. Klicken Sie auf der Seite Einstellungen im Bereich VI auswählen auf 
die Suchschaltfläche und öffnen Sie das VI Limiter-LV86.vi im 
Verzeichnis LabVIEW SignalExpress\Examples\Tutorial. Das 
VI “Limiter-LV86” schneidet ein Zeitbereichssignal an den in den 
Schritteinstellungen festgelegten Werten ab.

Beim Importieren eines LabVIEW-VIs in LabVIEW SignalExpress 
werden die Eingänge des VIs als Schrittparameter und die Ausgänge 
des VIs als Ausgänge des Schritts interpretiert.

Bei den VI-Eingängen können Sie festlegen, ob diese Eingangssignale 
oder Parameter darstellen sollen. Ein Eingangssignal erscheint in der 
Projektansicht als Eingang eines Schritts, so dass Sie dem VI von 
außen Signale zuführen können. Parameter sind alle Schritteinstel-
lungen im Dialogfeld zu einem Schritt. Mit dem Sweep-Schritt 
können Sie auch bestimmte Parameter dynamisch verändern. Im vor-
liegenden Projekt liegt am VI ein Zeitbereichssignal an und es hat die 
Parameter Upper limit und Lower limit (beides Skalarwerte).
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Das Dialogfeld Schritteinstellungen sollte wie in Abbildung 6-1 
aussehen.

Abbildung 6-1.  Registerkarte “Schritteinstellungen” für Limiter-VI

4. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links), 
um das Projekt zu starten. 

5. Wechseln Sie zur Datenansicht und ziehen Sie das Signal Clipped 
waveform out des Schritts “VI ausführen - LabVIEW 8.6” in die 
Datenansicht.

6. Klicken Sie doppelt auf den Schritt “VI ausführen - LabVIEW 8.6”, 
um die Registerkarte Schritteinstellungen anzuzeigen.

7. Klicken Sie zur Anzeige des VIs auf die Seite VI konfigurieren. 

8. Ändern Sie die Werte für Upper limit und Lower limit. Geben Sie 
beispielsweise in Upper limit den Wert 100 ein.

9. Wechseln Sie zur Datenansicht. Das Signal Clipped waveform out 
wird nun in der Datenansicht den Änderungen entsprechend angezeigt.

10. Klicken Sie auf die Schaltfläche Stopp (vgl. Abbildung links), um das 
Projekt zu beenden.
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11. Wählen Sie Datei»Projekt speichern unter und geben Sie dem 
Projekt den Namen My User Step.seproj.

12. Schließen Sie das Projekt über Datei»Projekt schließen.

Informationen zum Verwenden von VIs in LabVIEW SignalExpress sowie 
zum Entwickeln von VIs, die gut für LabVIEW SignalExpress geeignet 
sind, finden Sie in der Hilfe zu LabVIEW SignalExpress.

Umwandeln von LabVIEW-SignalExpress-Projekten in 
LabVIEW-Blockdiagramme

LabVIEW-SignalExpress-Projekte können in LabVIEW-Blockdiagramme 
umgewandelt werden.

Hinweis Zur Umwandlung eines LabVIEW-SignalExpress-Projekts in ein LabVIEW-VI 
wird das LabVIEW Full Development System ab 7.1 benötigt.

Zum Umwandeln eines LabVIEW-SignalExpress-Projekts in ein 
LabVIEW-Blockdiagramm gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial\Solutions und klicken 
Sie doppelt auf My First Project.seproj.

2. Wählen Sie Werkzeuge»Programmcode erzeugen»LabVIEW-
Blockdiagramm.

3. Geben Sie einen Namen und Speicherort für das neue VI an und 
klicken Sie auf OK. LabVIEW SignalExpress erzeugt das neue VI und 
öffnet es in der zuletzt auf Ihrem Rechner geöffneten Version von 
LabVIEW.

Das erzeugte LabVIEW-Blockdiagramm spiegelt den Projektablauf in 
LabVIEW SignalExpress wider. Es besteht aus mehreren LabVIEW-
Express-VIs, die miteinander verbunden sind. Jedes Express-VI ent-
spricht einem Schritt im LabVIEW-SignalExpress-Projekt. Bei einem 
Doppelklick auf ein Express-VI werden die gleichen Schritteinstel-
lungen wie in LabVIEW SignalExpress angezeigt. Sie können die 
Express-VIs auch mit der rechten Maustaste anklicken und Frontpa-
nel öffnen auswählen, um das Express-VI in ein LabVIEW-SubVI 
umzuwandeln. Im Blockdiagramm können Sie die Ausführung des VIs 
sehen und das VI ändern. Die Umwandlung eines Express-VIs in ein 
SubVI ist nicht umkehrbar.

Hinweis Beim Umwandeln eines LabVIEW-SignalExpress-Projekts mit Datenprotokol-
lierung enthält das erzeugte Blockdiagramm nur ein Express-VI und dieses lässt sich nicht 
in ein SubVI umwandeln.
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Weitere Informationen

Weitere Informationen zu LabVIEW SignalExpress erhalten Sie durch:

LabVIEW-SignalExpress-Beispielprojekte
Zu LabVIEW SignalExpress gibt eine Vielzahl von Beispielprojekten, die 
die Funktionen von LabVIEW SignalExpress veranschaulichen. Die Pro-
jekte befinden sich im Verzeichnis SignalExpress\Examples. Mithilfe 
der Beispiele können Sie sich mit den Funktionen des Programms näher 
vertraut machen oder ein passendes Beispiel als Grundlage für ein eigenes 
Projekt verwenden.

Verwenden von Hardware mit LabVIEW SignalExpress
LabVIEW SignalExpress unterstützt zahlreiche Geräte von National 
Instruments zur Erfassung und Erzeugung von Signalen. LabVIEW 
SignalExpress arbeitet mit MIO-Karten, Karten zur Analyse dynamischer 
Signale, Hochgeschwindigkeits-A/D-Wandlern sowie Arbiträr- und Funk-
tionsgeneratoren von National Instruments. Sie können auch mehrere 
Geräte in einem System synchronisieren, indem Sie für alle Geräte densel-
ben Takt oder Trigger verwenden. Weitere Einzelheiten zur Verwendung 
von Hardware mit LabVIEW SignalExpress finden Sie in der Hilfe zu 
LabVIEW SignalExpress, die sich unter Hilfe»LabVIEW SignalExpress 
Hilfe befindet.

Online-Informationsquellen
Auf der Website ni.com/signalexpress finden Sie Beispielprojekte, 
technische Beschreibungen und LabVIEW-VIs für das Programm.

http://www.ni.com/signalexpress
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A
Technische Unterstützung und 
professioneller Service

Auf der Website ni.com/germany finden Sie umfassende Informationen 
über die folgenden professionellen Serviceleistungen und den technischen 
Support von National Instruments:

• Support—Auf ni.com/support/d finden Sie folgende Informa-
tionsquellen und Tools:

– Technische Ressourcen—Diese Website bietet Ihnen Soforthilfe 
bei Fragen und Problemen. Außerdem finden Sie hier Treiber, 
Updates, eine umfassende Wissensdatenbank (KnowledgeBase), 
Bedienungsanleitungen, Anleitungen zur Problemlösung, 
Tausende Beispielprogramme, autodidaktische Kurse und Appli-
cation Notes. Registrierte Nutzer können sich auch an den 
Diskussionsforen auf ni.com/forums (englisch) beteiligen. 
Jede im Forum eingereichte Frage wird garantiert beantwortet.

– Standard Service Program—Teilnehmer dieses Programms 
können sich telefonisch oder per E-Mail direkt mit unseren Appli-
kationsingenieuren in Verbindung setzen und jederzeit die 
Schulungseinheiten im Services Resource Center nutzen. Beim 
Erwerb eines Produkts von National Instruments sind Sie auto-
matisch ein Jahr lang zur Teilnahme am Standard Service Program 
berechtigt. Danach ist die Mitgliedschaft kostenpflichtig. 

Welche Art der technischen Unterstützung es in Ihrer Nähe gibt, 
erfahren Sie unter ni.com/services/d oder bei einer unserer 
Niederlassungen (ni.com/contact). 

• Training und Zertifizierung—Auf ni.com/training/d finden 
Sie Lehrmaterial und Informationen zur Zertifizierung. Hier können 
Sie sich auch für eine der weltweit angebotenen Software-Schulungen 
anmelden.

• Systemintegration—Wenn Sie aus Zeit- oder Personalmangel oder 
aus anderen Gründen bei einem Projekt in Verzug geraten, können 
Ihnen die Mitglieder des NI-Alliance-Programms weiterhelfen. Für 
Informationen zu diesem Programm setzen Sie sich entweder tele-
fonisch mit einer Niederlassung von National Instruments in Ihrer 
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Nähe in Verbindung, besuchen Sie die Website ni.com/alliance 
(englisch) oder klicken Sie auf ni.com/germany im Menü links auf 
den Link “Alliance Program”.

Sollten Sie nach dem Besuch unserer Website ni.com noch Fragen 
haben, wenden Sie sich bitte an eine Niederlassung von National Instru-
ments in Ihrer Nähe. Die Telefonnummern aller Niederlassungen finden 
Sie am Anfang dieses Handbuchs. Auf die Websites der einzelnen Nieder-
lassungen, auf denen Sie immer die aktuellen Kontaktinformationen, 
Telefonnummern des technischen Supports, E-Mail-Adressen sowie 
aktuelle Ereignisse und Veranstaltungen finden, gelangen Sie über 
ni.com/niglobal.
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このマニュアルについて

LabVIEW SignalExpress の対話式計測、および信号の集録と解析に使用

する LabVIEW SignalExpress 基本機能の習得について説明します。

本書には、LabVIEW SignalExpress で作業を開始する際に役立つ演習問

題などが含まれています。 これらの演習では、プロジェクトの実行方法、

ステップの構成方法、信号の操作方法、スイープ計測の構成方法、データ

のログ方法、LabVIEW のグラフィカルプログラミングを使用した

LabVIEW SignalExpress の拡張方法について説明します。

表記規則

このマニュアルでは、以下の表記規則を使用しています。

→ 矢印（→）は、ネストされたメニュー項目やダイアログボックスのオプ

ションを順に選択する操作を示します。 たとえば、ファイル→ページ設

定→オプションという順になっている場合は、まずファイルメニューをプ

ルダウンし、次にページ設定項目を選択して、最後のダイアログボックス

からオプションを選択します。

このアイコンは、注意すべき重要な情報を示します。

このアイコンは、ユーザへのアドバイスを表しています。

太字 太字のテキストは、メニュー項目やダイアログボックスなど、ソフトウェ

アでユーザが選択またはクリックする必要のある項目を示します。 また、

入出力名、パラメータ名、ダイアログボックスまたはその一部、メニュー

名も示します。

斜体 斜体のテキストは、変数、強調、相互参照、または重要な概念の説明を示

します。 また、ユーザが入力する必要がある語または値のプレースホルダ

も示します。

monospace このフォントのテキストは、キーボードから入力する必要があるテキスト

や文字を示します。 また、ディスクドライブ、パス、ディレクトリ、プロ

グラム、サブプログラム、サブルーチンなどの名称、デバイス名、関数、

操作、変数、ファイル名および拡張子の引用にも使用されます。

関連ドキュメント

詳細は、ヘルプ→ LabVIEW SignalExpress ヘルプを選択し、『LabVIEW 
SignalExpress ヘルプ』を参照してください。
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1
LabVIEW SignalExpress
スタートアップガイド

ナショナルインスツルメンツでは、科学者やエンジニア向けに業界標準の

コンピュータとプラットフォームで自動計測システムを構築するための革

新的なソリューションを提供しています。 たとえば、グラフィカルプログ

ラミングが可能な LabVIEW、ANCI C プログラミング対応の

LabWindowsTM/CVITM、Microsoft Visual Studio プログラミング対応の

Measurement Studio などの堅固で業界最先端の自動計測システム用プ

ログラミング環境がその例です。 これらのプログラミングツールをナショ

ナルインスツルメンツ製計測ハードウェアや従来型計測器へのインタ

フェースと組み合わせて使用することで、カスタム仕様の高機能な仮想計

測システムを構築することが可能です。

LabVIEW SignalExpress は、設計技術者が仮想計測を有効に活用するた

めに、プログラミングを行わずに対話式計測を実行するためのツールで

す。 LabVIEW SignalExpress では、信号の集録、生成、解析、比較、イ

ンポート、ログを対話式に行うことができます。 また、設計データと測定

データの比較を 1 つのステップで行えます。 LabVIEW SignalExpress を
使用すれば、信号の集録や解析が必要な際にプログラミングアプリケー

ションなしで、仮想計測器の使いやすさと性能を活用できます。 また、

LabVIEW 開発システムで作成したカスタム仮想計測器（VI）を

LabVIEW SignalExpress にインポートしたり、LabVIEW SignalExpress
プロジェクトを LabVIEW ブロックダイアグラムに変換して引き続き

LabVIEW で開発を行うことができます。 LabVIEW SignalExpress の高度

な機能の詳細については、第 6 章「LabVIEW で LabVIEW 
SignalExpress プロジェクトを拡張する」を参照してください。

この章では、LabVIEW SignalExpress のシステム要件、インストール手

順、バージョン、ライセンスオプションについて説明します。
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LabVIEW SignalExpress をインストールする

このマニュアルの演習を行うには、LabVIEW SignalExpress をインス

トールする必要があります。 LabVIEW SignalExpress は、セットアップ

プログラムを使用して約 10 分でインストールできます。

最小システム要件
LabVIEW SignalExpress の推奨システム要件は以下のとおりです。

• メモリ 512 MB

• Pentium 4 同等のプロセッサ（Pentium III または Celeron 600 MHz
以上）

インストール手順
LabVIEW SignalExpress を Windows 2000/XP/Vista にインストールす

るには、以下の手順に従ってください。

メモ LabVIEW 8.6 プラットフォーム DVD で LabVIEW SignalExpress をインストー

ル済みの場合は、このセクションで説明する媒体を使用して再インストールす

る必要はありません。 DVD からのインストール手順については、『LabVIEW リ

リースノート』を参照してください。

1. LabVIEW SignalExpress のインストーラを実行する前に、すべての

プログラムを終了してください。 ウィルススキャンユーティリティな

どバックグラウンドで実行されているアプリケーションも、インス

トーラの実行が遅くなる原因となる場合があります。

2. 管理者または管理者権限を持つユーザとしてログオンします。

3. LabVIEW SignalExpress のインストールメディアを挿入し、画面に

表示される指示に従います。

メモ LabVIEW SignalExpress のインストールプログラムは、インストール中に別の

場所を指定しない限り <Program Files>¥National Instruments¥

SignalExpressディレクトリにファイルをコピーします。

4. インストール後、一時的に無効にしたウィルス検出プログラムを有効

にし、ハードディスクにウィルスがないことを確認します。

このマニュアルで使用するサンプルプロジェクトは、
<Program Files>¥National Instruments¥SignalExpress¥

Examples¥Tutorialディレクトリにあります。 各演習の解答は、
<Program Files>¥National Instruments¥SignalExpress¥

Examples¥Tutorial¥Solutionsディレクトリにあります。
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LabVIEW SignalExpress バージョン

LabVIEW SignalExpress には、正規版と Limited Edition (LE) がありま

す。 各エディションで使用できる機能は、以下の表のとおりです。 

表 1-1 LabVIEW SignalExpress 正規版と LE の相違

正規版 LE

計測器のサポート

300 種以上の一般スタンドアロン計測器 ✓ —

表示とドキュメント

グラフのカスタマイズ ✓ ✓

対話的カーソル ✓ ✓

信号のファイル保存 ✓ ✓

グラフの印刷とエクスポート ✓ ✓

Microsoft Excel、Word、WordPad へのデータのドラッグ
アンドドロップ

✓ ✓

制限的なユーザ編集が可能なオペレータモード ✓ —

信号処理

ソフトウェアフィルタ ✓ —

スカラと波形の数学的演算 ✓ —

アナログ / デジタル変換 ✓ —

対話的な信号の比較 ✓ —

PSPICE、Multisim、SPICE パッケージからのシミュレー
ションデータのロード

✓ —

時間測定と周波数測定

振幅とレベル ✓ —

タイミングと過渡 ✓ —

パワースペクトル ✓ —

周波数応答 ✓ —

歪み計測 ✓ —

トーン抽出 ✓ —
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データロギング

制限付きデータロギング（各プロジェクトに 1 つのログ） ✓ ✓

制限なしデータロギング ✓ —

ログのアラームとイベント ✓ —

開始条件または停止条件付きロギング ✓ —

測定のオートメーション

パラメータのスイープ ✓ —

リミットテスト ✓ —

ソフトウェアトリガ ✓ —

シーケンス ✓ —

リモートデータアクセス

シェア変数の読み取り / 書き込み ✓ —

表 1-1 LabVIEW SignalExpress 正規版と LE の相違（続き）

正規版 LE
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LabVIEW SignalExpress ライセンスオプション

このセクションでは、LabVIEW SignalExpress のライセンス規定につい

て説明します。 ただし、このドキュメントは『ナショナルインスツルメン

ツソフトウェア使用許諾契約書』にとって代わるものではありません。 こ
のドキュメントは参照用としてのみ使用してください。

LabVIEW SignalExpress LE
LE は、ライセンスなしで使用できる LabVIEW SignalExpress の機能制

限付きのバージョンですが、使用開始から 30 日間は表 1-1 に示すすべて

の機能が使用できます。 30 日経過後は、LabVIEW SignalExpress がライ

センスなしのモードで実行されます。 30 日以内に有効なライセンスをア

クティブ化しないと、プロジェクトにライセンスを必要とするステップが

含まれている場合は以下の制限が課せられます。

• ライセンスを必要とするステップを追加するたびに、ソフトウェアの

アクティブ化を促すダイアログボックスが表示されます。 

• プロジェクトを保存できません。

• プロジェクトが 10 分ごとに閉じます。

LabVIEW SignalExpress の正規版は、ナショナルインスツルメンツの

ウェブサイト ni.com/signalexpressでご購入いただけます。

LabVIEW Signal Express 正規版
LabVIEW SignalExpress の正規版では、表 1-1 の機能をすべて使用でき

ます。 LabVIEW SignalExpress の正規版は、NI License Manager、
LabVIEW SignalExpress インストーラ、ナショナルインスツルメンツの

ウェブサイト（ni.com/activate）でアクティブ化できます。
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2
プロジェクトの操作

LabVIEW SignalExpress では、対話式計測環境でステップの追加や構成

を行い、測定処理を定義することができます。 ステップとは、信号の集録

や生成、解析、ロード、保存を行う構成可能な関数です。 ステップを追加

メニューとステップを追加パレットには、LabVIEW SignalExpress で使

用可能なステップが表示されます。 

ほとんどのステップは、入力信号を処理して、出力信号を生成します。各

ステップの動作は、ステップ設定タブで値を指定して設定することができ

ます。 構成したステップのシーケンスは、LabVIEW SignalExpress プロ

ジェクトとして保存できます。

この章では、既存のプロジェクトをロードまたは実行する方法と、プロ

ジェクトのステップを構成する方法について説明します。

プロジェクトを開く

LabVIEW SignalExpress でサンプルプロジェクトをロードするには、以

下の手順に従ってください。

1. LabVIEW SignalExpress を起動します。

LabVIEW SignalExpress は、さまざまな種類の情報を表示する複数

のビューに分けられています。 アプリケーションウィンドウの中央に

表示されるタブ付きのビューを、プライマリビューと呼びます。 
LabVIEW SignalExpress を初めて起動すると、プライマリビューに

デフォルトでデータビュータブ、記録オプションタブ、プロジェクト

ドキュメントタブが表示されます。 
プライマリビューの周りには、補助ビューが表示されます。 デフォル

トの構成では、左側にプロジェクトビュー、右側に詳細ヘルプが表示

されます。

メモ LabVIEW SignalExpress がサポートハードウェアデバイスを検出すると、アプ

リケーションウィンドウの下方にチャンネルビューが表示されます。

2. LabVIEW SignalExpress がデフォルトのレイアウトで表示されてい

ない場合は、表示→レイアウトをリセットを選択してデフォルトの構

成に戻すことができます。 タブやビューは、表示メニューから表示と
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非表示を切り替えたり、デフォルトのレイアウトにリセットすること

ができます。

3. ヘルプ→サンプルを開くを選択して SignalExpress¥Examples¥
Tutorialディレクトリにある First Project.seprojというサン

プルプロジェクトをダブルクリックして開きます。 

4. 図 2-1（詳細ヘルプウィンドウが閉じた状態）を参照して、

LabVIEW SignalExpress ウィンドウに表示されている各コンポーネ

ントを確認してください。 

図 2-1 First Project.seproj

LabVIEW SignalExpress は、さまざまな種類の情報を表示する複数

のビューに分けられています。 アプリケーションウィンドウの中央に

表示されるタブ付きのビュー（データビュータブなど）を、プライマ

リビューと呼びます。 プライマリビューの周りには、タイトルバー付

きの補助ビューが表示されます。 たとえば、プロジェクトビューは補

助ビューです。

1 実行ボタン

2 作業エリアプルダウンメニュー

3 ステップ

4 入力

5 出力

6 プロジェクトビュー

7 ログデータウィンドウ

8 プライマリビュー（データビュータブを選択した状態）

9 記録ボタン

5
8

5

3

4

2

91

6

7
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プロジェクトの実行と信号の表示

LabVIEW SignalExpress には、複数の実行モードがあります。 プロジェ

クトは、1 回だけ、指定する反復数、指定する時間、または連続的に実行

することができます。 1 回実行モードでは、プロジェクトのすべてのス

テップが１回実行されます。 連続実行モードでは、プロジェクトのすべて

のステップが連続的に実行されます。 プロジェクトの実行モードを設定す

るには、左に示す実行ボタンの下矢印をクリックして、プルダウンメ

ニューから実行方法を構成を選択します。

プロジェクト実行中は、データビュータブの表示が継続的に更新されま

す。 プロジェクト実行中に、ステップの設定タブの設定を変更して測定の

構成を変更すると、その結果が即時表示されます。 連続モードで実行され

ているプロジェクトは、ユーザが左に示す停止ボタンをクリックするまで

実行を継続します。 プロジェクトの実行中は、実行ボタンが停止ボタンに

変化します。 

サンプルプロジェクトを実行して信号を表示するには、以下の手順に従っ

てください。

1. 実行ボタンをクリックします。 実行情報ダイアログボックスが表示さ

れた場合は、ダイアログボックスの実行ボタンをクリックしてプロ

ジェクト内のすべてのステップを連続的に実行します。

プロジェクトはテキストファイルから信号をロードし、信号に対して

2 つの操作（振幅とレベル測定および歪み測定）を実行します。 これ

らの測定は、「振幅とレベル」ステップおよび「歪み」ステップで個

別に実行されます。 プロジェクトを実行すると、各ステップは入力信

号を解析し、解析結果から新しい出力信号を生成します。 このプロ

ジェクトでは、「ASCII からロード」ステップによって歪み正弦波が

ロードされ、「振幅とレベル」ステップと「歪み」ステップによって

この正弦波が解析され、これらの 2 つののステップから新しい出力

が返されます。 プロジェクトビューでは、入力は赤い矢印、出力は青

い矢印で表示されます。

データビュータブのグラフビューには、ロードされた時間領域信号が

表示されます。 グラフには、時間領域、周波数領域、または xy 信号

が表示されます。 

2. プロジェクトビューの「歪み」ステップのエクスポートされたスペク

トル出力信号をデータビュータブにドラッグします。 
データビュータブに新しいグラフが作成されます。 エクスポートされ

たスペクトル信号は周波数領域信号であるため、時間領域信号と同じ

グラフには表示されません。 LabVIEW SignalExpress は自動的に異

なる信号タイプを認識し、それぞれ適切な形式で表示します。
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ヒント 信号タイプの詳細については、ヘルプ→ LabVIEW SignalExpress ヘルプを選

択して『LabVIEW SignalExpress ヘルプ』を開き、検索タブで「信号タイプ」

と入力して適切なトピックを参照してください。 このヘルプには、LabVIEW 
SignalExpress のプロジェクト、ステップ、信号などの機能の詳細な説明が記

載されています。

3. 「振幅とレベル」ステップの dc 出力をデータビュータブにドラッグ

します。 

dc 出力のスカラ測定値を表すグラフと凡例の表が作成されます。 
凡例の表には、各出力の値と隣にあるグラフに出力をプロットする際

に使用される色が表示されます。

4. 「振幅とレベル」ステップの rms 出力を凡例の表へドラッグして、

スカラ RMS 測定値を表示します。

表に 2 つ目の測定結果を示す新しい行が追加されます。 プロジェクト

は図 2-2 のように表示されます。

図 2-2 First Project.seproj の出力
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ステップを構成する

ステップとは、信号の集録や生成、解析、ロード、保存を行う構成可能な

関数です。 ステップにより、入力信号が処理され、出力信号が生成されま

す。 LabVIEW SignalExpress の各ステップの動作は、ステップ設定タブ

で値を指定して設定することができます。 プロジェクトの実行中でも、ス

テップの構成を変更してその結果をデータビュータブに表示し、必要な測

定結果が得られるまで測定を調整することができます。

「歪み」ステップおよび「振幅とレベル」ステップを構成するには、以下

の手順に従ってください。

1. プロジェクトビューの「歪み」ステップをダブルクリックします。 
図 2-3 のように、「歪み」ステップのステップ設定タブが表示されま

す。

図 2-3 「歪み」ステップのステップ設定タブ

ステップ設定タブの構成ページでは、エクスポート信号 (THD) で
「歪み」ステップが入力信号をエクスポートすることを示しており、

エクスポートされた信号グラフには信号のプレビューが表示されてい

ます。 エクスポートされたパワースペクトルグラフは、このステップ

が入力信号に対してパワースペクトルを実行して周波数領域に変換す
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ることを示しています。また、測定結果には、信号の基本周波数と全

高調波歪み（THD）が表示されます。 このステップは出力としてエク

スポート信号と 3 つの測定値（スペクトル、THD、元の時間領域の

波形入力の基本周波数）を生成します。

2. 詳細ヘルプにはステップに関する詳細な情報が表示されます。詳細ヘ

ルプが画面の右側に表示されていない場合は、左に示すヘルプ→詳細

ヘルプを選択して表示できます。 
詳細ヘルプの上のセクションにはステップについての情報、下のセク

ションにはカーソルが現在置かれているパラメータ固有の詳細ヘルプ

が表示されます。 たとえば、カーソルを THD (%) パラメータに移動す

ると、このパラメータに関する情報が表示されます。

3. 構成ページ上で、エクスポート信号 (THD) プルダウンメニューから

基本トーンを選択します。

エクスポートされたパワースペクトルグラフが、入力信号全体の周波

数領域スペクトルの表示から、基本トーンだけの周波数スペクトルの

表示に変更されます。 「歪み」ステップの出力信号とデータビュータ

ブのエクスポートされたスペクトル出力のグラフの両方が、変更に応

じて更新されます。

4. エクスポート信号 (THD) プルダウンメニューから高調波のみを選択

します。

ステップ設定タブのエクスポートされたパワースペクトルのグラフと

データビュータブの出力のグラフの両方で、入力信号の高調波信号の

スペクトルの表示だけが変更されます。

5. プロジェクトビューの「振幅とレベル」ステップをクリックします。 
ステップ設定タブの内容が、「歪み」ステップの構成から「振幅とレ

ベル」ステップの構成に切り替わります。
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6. 入力 / 出力ページを選択すると、図 2-4 のように、このステップで選

択できる入出力のリストが表示されます。

図 2-4 「振幅とレベル」ステップのステップ設定タブ

7. + ピーク値をエクスポート、- ピーク値をエクスポート、ピーク -
ピーク値をエクスポートの各チェックボックスを有効にして、「振幅

とレベル」ステップからさらに 3 つの別の計測値が返されるよう設

定します。

新しい 3 つの出力がプロジェクトビューに表示されます。

8. データビュータブに切り替えます。

9. プロジェクトビューの 3 つの新しい出力をスカラ計測値の凡例の表

へドラッグします。 隣にあるグラフに新しい出力が表示されます。

メモ すでに一定の時間プロジェクトが実行されている場合は、すべてのスカラ信号

をグラフに表示するためには、プロジェクトの実行を停止して再度開始する必

要がある場合があります。 これは、LabVIEW SignalExpress がグラフに追加さ

れた信号のデータポイントを蓄積するため、新しく追加された信号にはグラフ

表示に必要な量のデータポイントがないためです。 
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10. 停止ボタンをクリックしてプロジェクトを停止します。

停止ボタンをクリックすると、現在の一連のステップ操作または反復

が完了した後でプロジェクトの実行は停止されます。 停止ボタンの下

矢印をクリックし、プルダウンメニューから中断を選択すると、プロ

ジェクトが現在の反復を最後まで実行することなく完全に停止しま

す。

11. ファイル→プロジェクトを別名で保存を選択し、プロジェクトを

My First Project.seprojという名前で SignalExpress¥

Examples¥Tutorialディレクトリに保存します。

12. ファイル→プロジェクトを閉じるを選択し、プロジェクトを閉じま

す。

ステップを並べ替え、移動、削除する

LabVIEW SignalExpress プロジェクトのほとんどのステップは、入力

データを必要とします。 各ステップは、プロジェクトビューでそれより前

にあるステップから出力される信号だけを処理できます。したがって、プ

ロジェクトビューでのステップの順序はプロジェクトの動作に影響しま

す。 

ステップ設定タブに入力ページまたは入力 / 出力ページがあるステップで

は、これらのページの入力信号プルダウンメニューにそのステップより前

にあるステップの有効な出力だけが表示されます。 ステップの出力が別の

ステップの入力になると、その 2 つのステップは相互依存となり、順番

に同じレートで実行されます。 最初のステップによって生成された出力信

号は、2 つ目のステップの入力として受け取られ、実行が開始されます。

プロジェクト内のステップは、プロジェクトビューで上下にドラッグして

移動できます。 ステップを削除するには、プロジェクトビューでステップ

を右クリックし、ショートカットメニューから削除を選択します。 ステッ

プを移動または削除すると、プロジェクトの信号のステータスが変更され

ます。 たとえば、出力信号を生成するステップを削除すると、そのステッ

プの出力信号が他のステップの入力として使用されている場合、プロジェ

クトにエラーが発生し、プロジェクトビューにエラーインディケータが表

示されます。 プロジェクト内のステップを切り取り、コピー、貼り付けす

るには、それぞれ <Ctrl-X>、<Ctrl-C>、<Ctrl-V> キーを押すか、プロジェ

クトビューのステップを右クリックしてショートカットメニューから切り

取り、コピー、選択したステップの前に貼り付けまたは選択したステップ

の後に貼り付けを選択します。
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エラーと警告を処理する

プロジェクトの実行中にエラーが発生すると、プロジェクトビューでエ

ラーが発生したステップに左に示すエラーインディケータが表示されま

す。 エラーが発生したステップをダブルクリックすると、ステップ設定タ

ブの下方にエラーの説明が表示されます。 エラーの説明の右側にある詳細

ボタンをクリックすると、エラーの詳細な説明が表示されます。

プロジェクトの実行中に発生するすべてのエラーおよび警告は、イベント

ログタブに記録されます。 イベントログタブを表示するには、表示→イベ

ントログを選択します。 エラーと警告の詳細を参照するには、ヘルプ→

LabVIEW SignalExpress ヘルプを選択して『LabVIEW SignalExpress
ヘルプ』を開き、検索タブで「エラー」と入力して適切なトピックを検索

してください。
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3
信号を操作する

LabVIEW SignalExpress では、プログラミングを行わずに信号の生成と

解析を行うことができます。 この章では、LabVIEW SignalExpress で信

号をグラフにプロットする方法、信号をファイルからインポートする方

法、2 つの信号を対話式にアライメントして比較する方法、信号をファイ

ルに保存する方法などについて説明します。

信号をグラフで表示する

サンプルプロジェクトの信号をプロットし、カーソルを使用して視覚的に

検証するには、以下の手順に従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥

Examples¥Tutorialディレクトリにある Signals.seprojをダブ

ルクリックします。 このプロジェクトでは、「アナログ信号を作成」

ステップで方形波を生成し、「フィルタ」ステップでローパスバタ

ワースフィルタを実行します。

2. 「アナログ信号を作成」ステップの step signal 出力をデータビュー

タブにドラッグします。

3. 「フィルタ」ステップの filtered step 出力をデータビュータブにド

ラッグします。

step signal と filtered step 信号は、どちらも時間領域信号である

ため、同じグラフビューに表示されます。 異なるタイプの信号を同じ

グラフにドラッグしてプロットしようとすると、新しいビューが自動

的に作成されます。

4. 左に示すビューを追加ボタンをクリックし、新しいビューを追加しま

す。

5. 「フィルタ」ステップの filtered step 出力を新しいビューにドラッグ

します。
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6. 新しいビューを右クリックし、ショートカットメニューから表示項

目→カーソルを選択して、図 3-1 のような 2 つの対話式カーソルを表

示します。

図 3-1 Signals.seproj

カーソルをドラッグすると、データビュータブの下方に表示されてい

るカーソル表の x 値と y 値が更新されます。

7. ファイル→プロジェクトを別名で保存を選択し、プロジェクトを

My Signals.seprojという名前で SignalExpress¥Examples¥

Tutorialディレクトリに保存します。
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信号をファイルからインポートする

信号は、カンマ区切りもしくはタブ区切りの ASCII ファイルなどの標準

的なファイル形式、また LabVIEW 計測データファイル（.lvm）からイ

ンポートできます。 また、SPICE シミュレータなどの電子設計オートメー

ションツールのシミュレーション結果から信号をインポートすることもで

きます。

信号をファイルからインポートするには、以下の手順に従ってください。

1. プロジェクトビューを右クリックし、ショートカットメニューから信

号をロード / 保存→アナログ信号→ ASCII からロードを選択してプ

ロジェクトビューに「ASCII からロード」ステップを追加します。 
「ASCII からロード」ステップのステップ設定タブが開きます。 この

ステップにより、ASCII 形式のファイルが読み込まれ、データが表示

されます。

メモ プロジェクトへのステップの追加は、ステップを追加メニュー、ステップを追

加パレット、プロジェクトビューを右クリックして表示されるショートカット

メニューから行うことができます。

2. ステップ設定ダイアログボックスで、左に示す参照ボタンをクリック

し、SignalExpress¥Examples¥Tutorialディレクトリにある

Step Response.txtをダブルクリックします。

ファイルプレビューセクションの列 1 はタイムスタンプデータ、列 2
は信号の実際の電圧値を示します。

3. ステップ設定タブの信号のインポートページを開き、ファイルに保存

されている信号を表示します。

4. 列 2 チェックボックスをオンにし、列 1 チェックボックスをオフに

します。

ステップ設定ダイアログボックスのインポートされた信号グラフに信

号のプレビューが表示されます。

5. X 入力値プルダウンメニューから列 1 を選択し、波形の x 軸データ

を適切な値に設定します。

6. データビュータブに切り替えます。

7. プロジェクトビューで、「ASCII からロード」ステップの Step 
Response.txt 出力を開きます。

8. 列 2 を右クリックして、ショートカットメニューから名前の変更

を選択します。

9. step responseと入力し、<Enter> キーを押して出力名を変更しま

す。
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10.「ASCII からロード」ステップの step response 出力をデータビュー

タブの下のビューにドラッグします。

図 3-2 のように、filtered step 信号は、step response 出力の立ち

上がりエッジと類似しています。

図 3-2 Signals.seproj の信号

11. ファイル→プロジェクトを保存を選択してプロジェクトを保存しま

す。

信号をアライメントおよび比較する

filtered step 信号も step response 出力も立ち上がりエッジでオーバー

シュートが見られますが、それぞれ信号ソースが異なるため振幅やタイミ

ングに相違があり、類似点を判定しにくい状態です。 このような場合、

「対話式アライメント」ステップを使用して 2 つの信号をアライメントし

て比較し、その結果からプロジェクトで必要な情報を選択してエクスポー

トすることができます。

My Signals.seprojプロジェクトの 2 つの信号をアライメントするに

は、以下の手順に従ってください。
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1. Step Response.txt 出力を開き、step response を右クリックして

ショートカットメニューから送信先→処理→アナログ信号→対話式ア

ライメントを選択して「ASCII からロード」ステップの step 
response 信号を「対話式アライメント」ステップに渡します。

図 3-3 のように、「対話式アライメント」ステップはプロジェクトの

最新の 2 つの信号を入力として選択し、ステップ設定タブのグラフ

にそれらの信号を表示します。

図 3-3 「対話式アライメント」ステップのステップ設定タブ

ステップをプロジェクトに追加すると、そのステップの入力信号が受

け入れ可能な信号タイプに基づいて自動的に選択されます。 たとえ

ば、「対話式アライメント」ステップでは、時間領域の波形信号のみ

を処理できます。 したがって、プロジェクトで作成された 2 つの最新

の時間領域信号が入力として選択されます。 

メモ ステップの入力信号を変更するには、ステップ設定タブの入力ページまたは入

力 / 出力ページのプルダウンメニュー、またはプロジェクトビューでステップ

の入力名の横に表示されている下矢印をクリックして、別の信号を選択します。

2. 入力信号グラフで赤い信号をクリックし、そのグラフ内の他のポイン

トへドラッグします。 比較結果信号グラフが更新され、新しく計算さ

れた信号の差異が表示されます。
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グラフ上の信号は、ドラッグ、拡張、縮小できます。

3. グラフ内で信号をドラッグして、2 つの信号の立ち上がりエッジをア

ライメントします。 信号をクリックしてアンカーポイントを設定し、

<Alt> キーを押したまま信号を x 軸と y 軸に沿ってアンカーポイント

の周囲でドラッグします。

信号をドラッグすると、ステップ設定タブのアライメントページで、

アライメント設定を満たすｘ 軸とｙ 軸のゲインとオフセットの値が

計算され、結果が表示されます。

4. モードプルダウンメニューから自動ステップを選択し、信号をアライ

メントします。 アライメントは LabVIEW SignalExpress の標準アル

ゴリズムに基づいて計算されます。

ステップ設定タブの比較結果信号グラフには、2 つの信号の相違が表

示されます。

5. 入力 / 出力ページのアライメントした信号をエクスポートチェック

ボックスをオンにして、信号をステップの出力に追加します。

6. データビュータブに切り替えます。

7. ビューを追加ボタンをクリックして 3 つ目のビューを追加します。

8. 「対話式アライメント」ステップのアライメントされた基準出力とア

ライメントされたテスト出力を新しいグラフにドラッグし、アライメ

ントされた信号を表示します。

9. ファイル→プロジェクトを保存を選択してプロジェクトを保存しま

す。

LabVIEW SignalExpress の信号タイプ

ステップの中には、「演算」ステップなど、複数の信号タイプを処理でき

るものがあります。 たとえば、「演算」ステップでは、時間領域または周

波数領域の波形を処理することができます。 この「演算」ステップは、選

択した入力信号のタイプに応じて異なる動作をします。 たとえば、2 つの

時間領域信号を追加すると、その振幅のみが追加されます。 これに対し、

2 つの周波数領域位相信号を追加すると、適切な位相シフトが追加されま

す。

信号タイプの詳細については、ヘルプ→ LabVIEW SignalExpress ヘルプ 
を選択して『LabVIEW SignalExpress ヘルプ』を開き、検索タブで「信

号タイプ」と入力して適切なトピックを参照してください。
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信号をエクスポートおよび印刷する

LabVIEW SignalExpress では、信号のドキュメントを作成したり、別の

ソフトウェアアプリケーションでさらに詳細な解析を行うことができま

す。 このセクションでは、信号のエクスポート、信号の ASCII ファイルへ

の保存、データの Microsoft Excel への送信、信号の印刷、標準のドキュ

メント機能を使用した LabVIEW SignalExpress プロジェクトのドキュメ

ント作成の方法について説明します。

信号をファイルに保存する
My Signals.seprojの信号をファイルへ保存するには、以下の手順に

従ってください。

1. ステップを追加ボタンをクリックしてステップを追加パレットを開き

ます。

2. 信号をロード / 保存→ ASCII/LVM に保存を選択してプロジェクト

ビューに「ASCII/LVM に保存」ステップを追加します。 
「ASCII/LVM に保存」ステップのステップ設定タブが開きます。

3. ステップ設定タブの信号ページをクリックし、入力データプルダウン

メニューから filtered step を選択します。

4. ファイル設定ページで、作成するテキストファイルの保存先を指定し

ます。 エクスポートファイルのパスフィールドの横にある参照ボタン

をクリックして SignalExpress¥Examples¥Tutorialディレクト

リを開き、ファイル名として filtered signal.txtと入力します。

5. ファイルが既存の場合プルダウンメニューから上書きを選択します。

6. ファイルタイプをエクスポートプルダウンメニューから汎用

ASCII(.txt) を選択します。

プロジェクトが実行されるたびに、「信号をロード / 保存」ステップ

を使用し、データをファイルへ保存します。

7. 実行ボタンの下矢印をクリックして 1 回実行を選択します。プロ

ジェクトが実行され、その結果得られた信号が指定した ASCII ファ

イルに保存されます。

8. ファイル→プロジェクトを保存を選択してプロジェクトを保存しま

す。

9. ファイル→プロジェクトを閉じるを選択し、プロジェクトを閉じま

す。

10. 任意のテキストエディタで filtered signal.txtを開き、信号の

値を確認します。 このファイルの信号は、「ASCII からロード」ス

テップを使用して LabVIEW SignalExpress に再度インポートするこ

とができます。
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Microsoft Excel へ信号をエクスポートする
Microsoft Excel へ信号データをエクスポートするには、Excel を起動し、

LabVIEW SignalExpress のステップの出力信号を Excel のスプレッド

シートへドラッグします。 または、データビュータブを右クリックして

エクスポート→ Microsoft Excel を選択してビューのすべてのデータを

エクスポートすることもできます。

信号を印刷する
グラフの画像を印刷するには、データビュータブを開き、ファイル→

印刷→データビューを印刷を選択します。

LabVIEW SignalExpress でレポートを作成する
表示→プロジェクトドキュメントを選択し、プロジェクトドキュメントタ

ブを表示します。 このタブでは、テキストまたはグラフなどの画像を使用

してプロジェクトのドキュメントを作成できます。 プロジェクトビューの

ステップの出力をプロジェクトドキュメントタブにドラッグすると、出力

信号のグラフが表示されます。 プロジェクト実行中の場合は、プロジェク

トドキュメントタブのグラフがステップの出力の最新値を反映するように

自動的に更新されます。 

ドキュメントを印刷するには、プロジェクトドキュメントタブを開き、

ファイル→印刷→ドキュメントを印刷を選択するか、ドキュメントを印刷

ボタンをクリックします。 ドキュメントを HTML へエクスポートするに

は、プロジェクトドキュメントタブを開き、ファイル→エクスポート→

ドキュメントを HTML にエクスポートを選択します。
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4
データをログする

LabVIEW SignalExpress では、測定値を記録して解析することができま

す。 あらゆる時間領域値、倍精度値、32 ビット符号なし整数、ブール値

のステップ出力を記録できます。 解析ステップでログデータを再生して、

解析、処理することもできます。 

この章では、LabVIEW SignalExpress で統合データロギング機能を使用

したデータの記録方法について説明します。 たとえば、指定した信号の記

録方法、信号の再生方法、解析のステップを使用した信号の解析方法につ

いて説明します。 また、記録オプションタブで指定した開始条件または停

止条件に基づいて信号をログする方法についても説明します。 

信号を記録する

記録ボタンでデータロギング処理を構成できます。 

記録する信号を指定して記録するには、以下の手順に従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥

Examples¥Tutorialディレクトリを参照して、Logging.seproj

をダブルクリックします。

このプロジェクトでは、「アナログ信号を作成」ステップを使用して

式に基づいて信号を生成します。

2. 左に示す記録ボタンをクリックし、選択した信号をログダイアログ

ボックスを開きます。

選択した信号をログダイアログボックスは、プロジェクトの記録可能

な信号を表示します。 1 つまたは複数の信号を記録するよう選択でき

ます。 ログの名前と説明を指定することもできます。

3. signal チェックボックスをオンにして、「アナログ信号を作成」ス

テップで生成されるフォーミュラ信号を記録します。

4. OK ボタンをクリックし、選択した信号をログダイアログボックスを

閉じて、信号の記録を開始します。 停止ボタンをクリックするまで、

ログ操作が継続されます。

5. 左に示す停止ボタンをクリックし、信号のログを停止します。 初めて

信号をログした場合は、最初のログ作成を完了ダイアログボックスが

表示されます。 OK ボタンをクリックして、ダイアログボックスを閉

じます。
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ログデータは、図 4-1 で示すようにプロジェクトビューの下方のログ

データウィンドウに表示されます。

図 4-1 ログデータウィンドウ

デフォルトでは、データを記録した日付と時間に応じて自動的にログ

データに名前が付けられます。 ログデータはオプションダイアログ

ボックスで指定したディレクトリに .tdmsファイル形式で保存され

ます。 

6. ログデータを保存するディレクトリを変更したり、ログデータの設定

をカスタマイズするには、ツール→オプション→ロギングオプション

を選択します。

7. OK ボタンをクリックしてオプションダイアログボックスを閉じま

す。

8. ファイル→プロジェクトを別名で保存を選択し、プロジェクトを

SignalExpress¥Examples¥Tutorialディレクトリに

My Logging.seprojという名前で保存します。

ログされた信号を表示する

ログデータを表示するには、以下の手順に従ってください。

1. データビュータブが非表示の場合、表示→データビューを選択して表

示することができます。 

2. ログデータウィンドウには、現在のプロジェクトのすべてのログデー

タが表示されます。 ログデータウィンドウで記録したデータログを選

択してデータビュータブへドラッグします。 図 4-2 のようにデータ

ビュータブにログデータとグラフプレビューが表示されます。 信号を

記録した時間の長さによっては、データビュータブに表示される信号

が図 4-2 の信号と異なる場合があります。
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図 4-2 Logging.seproj

グラフプレビューを使用して、データビュータブのデータにズームし

たり表示場所を変更することができます。 デフォルトでは、グラフプ

レビューはログデータを表示すると表示されます。 ライブデータまた

はログされていないデータのグラフプレビューを表示するには、デー

タビュータブのビューを右クリックしてショートカットメニューから

表示項目→プレビューを選択します。

3. ログ信号にズームするには、グラフプレビューの隣にあるズームイン

ボタンをクリックします。 グラフプレビューのカーソルは、データ

ビュータブに現在表示されているデータのサブセットを示します。 グ
ラフプレビューの下にあるスクロールバーで、データをスクロールし

ます。 グラフプレビューでカーソルをクリックしてドラッグすると、

表示されているデータのサブセットが増減します。

1 データをログする 2 グラフプレビュー

1

2



第 4 章 データをログする

LabVIEW SignalExpress スタートアップガイド 4-4 ni.com/jp

事前定義した開始 / 停止条件で信号をログする

信号があらかじめ指定した条件に一致したときに、信号の記録が開始また

は停止されるように設定することができます。 開始および停止条件に基づ

いてデータをログするには、以下の手順に従ってください。

1. 記録オプションタブが非表示の場合は、表示→記録オプションを選択

して表示することができます。

2. 記録オプションタブのカテゴリリストで信号選択を選択します。

3. 図 4-3 のように、正弦波の記録列にチェックマークを付けます。

図 4-3 信号選択

記録ボタンが左に示す実行中に記録ボタンに変わります。 実行中に記

録ボタンが押下された状態であることを確認します。 このボタンが押

下されている間は、実行または 1 回実行ボタンがクリックされたと

きに選択した信号が記録されます

4. 記録オプションタブのカテゴリリストで開始条件を選択します。 
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5. ロギングタスクの開始条件を変更するには、開始条件リストページで

追加ボタンをクリックします。

a. 条件タイププルダウンメニューで、信号トリガが選択されている

ことを確認します。この設定では、入力信号が指定された条件を

満たすと記録が開始されます。

b. 信号プルダウンメニューで、signal が選択されていることを確

認します。

c. トリガタイププルダウンメニューで、立ち上がりスロープが選択

されていることを確認します。この設定では、正のスロープでの

信号のエッジの値に基づいて信号の記録が開始されます。

d. トリガ値に 1と入力して、立ち上がりスロープで信号がレベル 1
を超えたときに記録が開始されるよう指定します。

6. 記録オプションタブのカテゴリリストで停止条件を選択します。

7. ロギングタスクの停止条件を変更するには、停止条件リストページで

追加ボタンをクリックします。

a. 条件タイププルダウンメニューで、持続時間が選択されているこ

とを確認します。この設定では、指定された時間が経過すると記

録が停止されます。

b. 持続時間フィールドに 5と入力して、信号が開始条件に一致し

てから 5 秒間記録するよう指定します。

8. 左に示す実行ボタンをクリックします。 立ち上がりスロープで信号が

レベル 1 を超えると信号の記録が開始され、5 秒間継続します。 
プロジェクトの実行中は、記録オプションタブのログの現在の状態

セクションの以下の表示が更新されます。

• 信号が開始条件を満たしてからロギングが実行されている間、

記録中が ON になります。 

• ディスク情報は、ログに使用できるコンピュータの有効なハード

ディスクスペースを表示します。 

• 現在の推定ログサイズは、ディスク上のログファイルのサイズを

示します。

• 残り記録時間は、使用可能なディスクスペースに対してログを継

続できる時間を示します。

• 現在のログ開始時間は現在のログが開始された時間を示します。

記録オプションタブの開始条件、停止条件、アラーム、イベントペー

ジには、設定された開始 / 停止条件、アラーム、イベントの状態を示

すインディケータが表示されます。
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ログされた信号を解析する

ログ信号は、再生したり、ライブデータと同様に解析ステップで処理する

ことができます。 ログされた信号を解析するには、以下の手順に従って下

さい。

1. プロジェクトビューの作業エリアプルダウンメニュー（図 4-4）で 下
矢印をクリックして再生を選択し、再生作業エリアに切り替えます。

図 4-4 作業エリアプルダウンメニュー

作業エリアは、同じプロジェクトで複数の LabVIEW SignalExpress
操作を実行する場合に使用します。 新規プロジェクトを開かずに、

データ集録、信号処理、データの記録、ログデータでの測定実行が可

能です。 プロジェクトを保存すると、プロジェクトのすべての作業エ

リアがプロジェクトファイルに保存されます。

デフォルトの監視 / 記録作業エリアでは、測定の実行、ライブデータ

の解析、データのログを行うことができます。 再生作業エリアでは、

監視 / 記録作業エリアでログしたデータを入力として解析ステップを

実行することができます。

2. 左に示すステップを追加ボタンをクリックし、処理→アナログ信号→

フィルタから「フィルタ」ステップを選択します。 最初のログ信号が

自動的に「フィルタ」ステップの入力として選択されます。

3. データビュータブに切り替え、「フィルタ」ステップの filtered data
出力をデータビュータブにドラッグします。

4. 実行ボタンをクリックします。 データビュータブに、結果として得ら

れたフィルタ済みの信号が表示され、ログ全体が再生されます。
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上級再生

再生オプションタブでは、ログデータの詳細な再生オプションを構成でき

ます。 再生オプションタブでは、ログデータのプレビューを表示し、再生

するデータのサブセットを選択したり、解析ステップでデータを処理する

ことができます。

1. 再生オプションタブ（図 4-5）を表示するには、表示→再生オプシ

ョンを選択します。 

図 4-5 再生オプションビュー

2. ログされた信号リストボックスで、作成した 2 番目のログから

signal を選択します。

3. 開始時間 (s) に 1と入力して、ログ開始から 1 秒後からのログ信号サ

ブセットを再生または解析するよう指定します。 

4. 停止時間 (s) フィールドに 4と入力して、ログ開始後から 4 秒後まで

の信号サブセットを再生または解析するよう指定します。 ログの長さ

が 4 秒未満の場合は、停止時間 (s) フィールドに適切な値を入力しま

す。 

5. ログされた信号リストボックスで 2 番目のログの signal を右クリッ

クし、ショートカットメニューからアクティブ化を選択してこの信号

をアクティブログに設定します。

メモ または、ログデータウィンドウでログを右クリックし、ショートカットメ

ニューからアクティブログに設定を選択してアクティブログに設定することも

できます。
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6. データビュータブに切り替えます。 2 番目のログの信号をアクティブ

にすると、データビュータブのグラフビューが、その信号を表示する

ように自動的に更新されます。 

7. 左に示す実行ボタンをクリックします。 LabVIEW SignalExpress は、

再生オプションタブで指定した信号のサブセットをフィルタ処理し、

データビュータブに結果として得られたフィルタ処理済み信号を表示

します。

アラーム条件、イベント、再生オプションの指定などのロギングデータの

詳細については、『LabVIEW SignalExpress ヘルプ』を参照してくださ

い。
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5
スイープ計測を行う

LabVIEW SignalExpress では、スイープ操作により測定を自動化し、特

性評価や設計検証を行うことができます。 この操作では、LabVIEW 
SignalExpress で作成するどのような設計でも特性化または検証できま

す。 スイープ計測値を使用して設計の特定の条件範囲におけるデータを収

集し、その設計の性能をドキュメント化することができます。 たとえば、

測定中にスイープ操作によって刺激信号の周波数や電源の電圧レベルを変

化させることで、設計を特性評価することができます。

この章では、LabVIEW SignalExpress で「スイープ」ステップを使用し

てスイープ操作を設定する方法について説明します。 特定の範囲で周波数

値をスイープしてフィルタ出力の測定を行うことで、フィルタの性能を評

価する方法、 スイープ結果の表示方法、より複雑な測定のための多次元ス

イープの実行方法についても説明します。

スイープの範囲と出力を定義する

「スイープ」ステップでは、複雑で反復的なスイープ操作の自動化を定義

することができます。

以下の手順に従って、サンプルプロジェクトでフィルタでのスイープ操作

を行うための周波数範囲を定義します。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥
Examples¥Tutorialディレクトリを参照して、Sweep.seprojを

ダブルクリックします。

2. 左に示す実行ボタンをクリックし、プロジェクトを連続的に実行しま

す。

このプロジェクトでは、「アナログ信号を作成」ステップにより正弦

波の刺激信号が生成されます。この信号は、「フィルタ」ステップに

より楕円バンドパスフィルタを介して渡され、「振幅とレベル」ス

テップによりフィルタ出力の RMS が測定され、「フォーミュラ」ス

テップによりデシベル（dB）に変換されます。 「フィルタ」ステッ

プは検査対象のシミュレーションユニットとして動作するため、ハー

ドウェアは使用されません。 ただし、ナショナルインスツルメンツの

任意波形発生器、関数発生器、ダイナミック信号アナライザ、または

マルチファンクション I/O（MIO）デバイスから生成される物理チャ

ンネルをスイープすることもできます。
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3. 停止ボタンをクリックしてプロジェクトを停止します。

4. 左に示すステップを追加ボタンをクリックし、実行制御→スイープを

選択してプロジェクトビューに「スイープ」ステップを追加します。

5. ステップ設定タブで追加ボタンをクリックし、図 5-1 に示すようなプ

ロジェクトの各ステップのスイープパラメータのリストを表示しま

す。

図 5-1 スイープパラメータ選択ダイアログボックス

6. アナログ信号を作成から周波数 (Hz) パラメータを選択し、OK ボタ

ンをクリックします。

「スイープ」ステップによって、スイープする信号を出力する「アナ

ログ信号を作成」ステップが囲まれます。

7. ステップ設定タブのスイープ構成ページで、タイププルダウンメ

ニューから指数を選択します。

8. 開始 : 周波数 (Hz) フィールドに 1kと入力し、終了 : 周波数 (Hz)
フィールドに 40kと入力します。



第 5 章 スイープ計測を行う

© National Instruments Corporation 5-3 LabVIEW SignalExpress スタートアップガイド

9. ポイント数フィールドに 150と入力します。

スイープ構成ページは図 5-2 のようになります。

図 5-2 「スイープ」ステップのステップ設定タブ

「スイープ」ステップを使用し、「アナログ信号を作成」ステップの周

波数パラメータの反復する各値の範囲を指定します。 「アナログ信号

を作成」ステップは、定義された周波数範囲の各周波数における正弦

波を生成します。「スイープ」ステップでは、プロジェクトのすべて

のスイープ可能なステップのスイープパラメータの各値に対して反復

するよう指定できます。

10. スイープ出力ページに切り替えます。

11. 追加ボタンをクリックし、プロジェクトの各ステップのスイープ出力

リストを表示します。

12. フォーミュラの response amplitude in dB 出力を選択して OK ボ

タンをクリックすると、この出力値がスイープされた周波数パラメー

タに対してプロットされます。

スイープ操作で使用するステップをすべて含めるため、「スイープ」

ステップはループを作成してプロジェクトビューの全ステップを囲み

ます。
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スイープ測定を実行する

スイープ計測を実行するには、以下の手順に従ってください。

1. データビュータブに切り替え、実行ボタンの下矢印をクリックして

1 回実行を選択してスイープ測定を実行します。

グラフ上で、白い stimulus signal 出力が指定された周波数範囲で反

復します。

2. スイープループの下の response amplitude in dB vs. Frequency
信号をデータビュータブにドラッグし、スイープの出力を表示しま

す。

新しいグラフビューが作成されます。 スイープ操作のデータは XY 配

列で、図 5-3 のように別のビューに表示されます。

図 5-3 Sweep.seproj

3. 1 回実行オプションを再度選択してスイープを実行します。

プロジェクトの実行中、新しいグラフビューに「フィルタ」ステップ

の周波数応答がプロットされます。 周波数に対するデシベルで表され

る振幅の出力、またはフィルタの転送関数がグラフに表示されます。
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メモ デフォルトでは、データビュータブの表示はスイープの反復ごとに消去されま

せん。 「フィルタ」ステップの周波数応答はどの反復でも同じであるため、プロ

ジェクトの実行中に信号を表示するグラフが更新されていないように見えます。 
オプションダイアログボックスのデータページで、スイープの反復ごとに

ビューを消去するかどうか選択できます。 オプションダイアログボックスを表示

するには、ツール→オプションを選択します。

4. 「フィルタ」ステップをダブルクリックし、ステップ設定タブでフィ

ルタ仕様を表示します。

Filter Magnitude Response (dB) グラフの周波数応答は、データ

ビューのグラフと一致します。

5. ファイル→プロジェクトを別名で保存を選択し、プロジェクトを

SignalExpress¥Examples¥Tutorialディレクトリに

My Sweep.seprojという名前で保存します。

「スイープ」ステップを使用し、複数のパラメータを同時にスイープする

には、スイープのステップ設定タブのスイープ構成ページで別のパラメー

タを追加します。 複数のパラメータを同時にスイープすることを、平行ス

イープと呼びます。 たとえば、刺激信号の振幅を変更するには、平行ス

イープを実行してデジタイザや MIO デバイスの信号レベルの変更に応じ

て入力範囲を調整することで、集録の精度を最大限に高めることができま

す。 信号レベルが上昇したら、測定デバイスの入力範囲を広げれば、その

測定に計測器がもつ分解能をフルに活かすことができます。

多次元スイープを実行する

多次元（ネスト）スイープを使用して、2 つのパラメータを順番にスイー

プすることができます。 刺激信号の周波数を様々な振幅でスイープするに

は、ネストスイープを実行します。 たとえば、振幅をレベル 1 から順番に

設定して、それぞれのレベルで各周波数をスイープすることができます。 
ネストスイープを作成するには、プロジェクトで「スイープ」ステップを

右クリックし、ショートカットメニューからネストスイープを追加を選択

して別のスイープループを追加します。 

ネストスイープのサンプルプロジェクトを実行するには、以下の手順に

従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥

Examples¥Tutorialディレクトリの Nested Sweep.seproj

をダブルクリックします。



第 5 章 スイープ計測を行う

LabVIEW SignalExpress スタートアップガイド 5-6 ni.com/jp

2. 実行ボタンをクリックして、プロジェクトを実行します。

内側のスイープループの各反復は、刺激信号の周波数をスイープしま

す。 外側のスイープループは、「フィルタ」ステップのカットオフ周

波数の上限と下限を変化させます。 図 5-4 で示すように、各反復がま

ず上のグラフにリアルタイムで表示され、その後下のグラフに各カッ

トオフ周波数設定でのスイープがすべて表示されます。

図 5-4 Nested Sweep.seproj

3. 左に示す停止ボタンをクリックし、プロジェクトを停止します。
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LabVIEW で LabVIEW 
SignalExpress プロジェクト
を拡張する

LabVIEW SignalExpress では、標準の信号の集録、生成、解析、ログス

テップを使用し、自動計測を定義することができます。 LabVIEW 
SignalExpress プロジェクトの機能は、以下の方法で LabVIEW を使用し

て拡張できます。

• LabVIEW で VI を作成して LabVIEW SignalExpress にインポートす

ることで、ステップ機能をカスタマイズしたり、LabVIEW 
SignalExpress で使用できるステップの数を拡張することができま

す。

• また LabVIEW SignalExpress プロジェクトを LabVIEW のブロック

ダイアグラムに変換し、引き続き LabVIEW で開発することができま

す。

本章の演習問題には、LabVIEW 7.1 以降のバージョンが必要です。

LabVIEW の VI をステップとして LabVIEW 
SignalExpress にインポートする

LabVIEW SignalExpress で「LabVIEW の VI を実行」ステップを使用し

て、カスタム仕様の LabVIEW の VI を呼び出すことができます。

LabVIEW SignalExpress から LabVIEW の VI を呼び出すことで、以下を

実現できます。

• GPIB 計測器を制御する

• LabVIEW SignalExpress でサポートされていないナショナルインス

ツルメンツのハードウェアを制御する

• 多様なファイル形式のデータを読み書きする

• 操作説明をポップアップダイアログボックスに表示する

• 測定アルゴリズムを定義する
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「LabVIEW の VI を実行」ステップで LabVIEW から VI をインポートす

るには、以下の手順に従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥
Examples¥Tutorialディレクトリの User Step.seprojをダブル

クリックします。

このプロジェクトでは、「アナログ信号を作成」ステップで信号を生

成します。

2. ステップを追加ボタンをクリックして、LabVIEW の VI を実行→

LabVIEW 8.6 の VI を実行を選択します。 
この演習で実行する VI は LabVIEW 8.6 形式で保存されています。 
「LabVIEW の VI を実行」ステップは、VI が保存された LabVIEW
バージョンに一致するものを使用する必要があります。

3. ステップ設定タブで VI を選択セクションの参照ボタンをクリックし、

LabVIEW SignalExpress¥Examples¥Tutorialディレクトリにあ

る Limiter-LV86.viを選択します。 Limiter-LV86 VI は時間領域波形

を入力として受け入れ、ステップ設定タブで指定した信号範囲の上限

を超えた値と下限を下回った値をクリップし、クリップした波形を出

力信号として返します。

LabVIEW SignalExpress に LabVIEW の VI をインポートすると、VI
の入力はパラメータとして、出力は出力信号としてマップされます。

VI の入力を入力信号またはパラメータのどちらに変換するか定義で

きます。 入力信号は、プロジェクトビューでステップの入力として表

示されるため、信号を入力として VI に渡すことができます。 パラ

メータは、ステップのステップ設定タブで構成できる値です。 パラ

メータは「スイープ」ステップを使用して動的にスイープすることも

できます。 このプロジェクトでは、VI に入力信号の時間波形入力、お

よびスカラパラメータの上限と下限があります。
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ステップ設定タブは図 8-1 のように表示されます。

図 6-1 Limiter VI のステップ設定タブ

4. 左に示す実行ボタンをクリックし、プロジェクトを実行します。 

5. データビュータブに切り替え、「LabVIEW 8.6 VI を実行」ステップの

Clipped waveform out 出力をデータビュータブにドラッグします。

6. 「LabVIEW 8.6 VI を実行」ステップをダブルクリックしてステップ設

定タブを表示します。

7. VI を構成タブを選択して VI を表示します。 

8. 上限および下限フィールドに新しい値を入力します。 たとえば、上限

フィールドに 100と入力します。

9. データビュータブに切り替えます。 Clipped waveform out 信号に

変更内容が反映されます。

10. 左に示す停止ボタンをクリックしてプロジェクトを停止します。

11. ファイル→プロジェクトを別名で保存を選択し、My User 

Step.seprojという名前でプロジェクトを保存します。

12. ファイル→プロジェクトを閉じるを選択し、プロジェクトを閉じま

す。
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LabVIEW SignalExpress での LabVIEW の VI の使用方法や、LabVIEW 
SignalExpress で正しく動作する VI の作成方法については、『LabVIEW 
SignalExpress ヘルプ』を参照してください。

LabVIEW SignalExpress プロジェクトを LabVIEW
のブロックダイアグラムに変換する

LabVIEW SignalExpress プロジェクトは、LabVIEW のブロックダイア

グラムに変換できます。

メモ LabVIEW SignalExpress プロジェクトを LabVIEW の VI に変換するには、

LabVIEW 7.1 開発システム以降が必要です。

LabVIEW SignalExpress プロジェクトを LabVIEW のブロックダイアグ

ラムに変換するには、以下の手順に従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥

Examples¥Tutorial¥Solutionsディレクトリを参照して、My 

First Project.seprojをダブルクリックします。

2. ツール→コード生成→ LabVIEW ダイアグラムを選択します。

3. 新しい LabVIEW の VI のファイル名と場所を指定し、OK ボタンを

クリックします。 LabVIEW SignalExpress によって新しい VI が生成

され、コンピュータにインストールされている最新バージョンの

LabVIEW で開きます。

生成された LabVIEW のブロックダイアグラムには、LabVIEW 
SignalExpress でのプロジェクトの実行が反映されます。 LabVIEW
のブロックダイアグラムは、配線された LabVIEW Express VI から構

成されます。 各 Express VI は、LabVIEW SignalExpress プロジェク

トの各ステップに対応します。 Express VI をダブルクリックすると、

LabVIEW SignalExpress と同じステップ設定ダイアログボックスが

表示されます。 また、Express VI を右クリックし、ショートカットメ

ニューからフロントパネルを開くを選択すると、Express VI を
LabVIEW のサブ VI に変換できます。 ブロックダイアグラムを表示

し、LabVIEW のブロックダイアグラムでの実行状況の確認や VI の
機能変更を行うことができます。 Express VI をサブ VI に変換する場

合、そのサブ VI を Express VI に戻すことはできません。

メモ ログ機能が構成された LabVIEW SignalExpress プロジェクトを変換すると、は

1 つの Express VI を持つ LabVIEW のブロックダイアグラムが生成されます。 生
成された Express VI はサブ VI に変換できません。
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7
詳細情報

LabVIEW SignalExpress の詳細については、以下のリソースを参照して

ください。

LabVIEW SignalExpress サンプルプロジェクト

LabVIEW SignalExpress では、多くの機能を搭載した様々なサンプルプ

ロジェクトが用意されています。 これらのプロジェクトは

SignalExpress¥Examplesディレクトリにあります。 これらのサンプル

を参照して、ニーズに合ったプロジェクトを作成するためにより詳細な

LabVIEW SignalExpress の機能を習得することができます。

LabVIEW SignalExpress でハードウェアを使用する

LabVIEW SignalExpress では、さまざまなナショナルインスツルメンツ

製の信号集録 / 生成ハードウェアがサポートされています。 LabVIEW 
SignalExpress では、ナショナルインスツルメンツの MIO デバイス、ダ

イナミック信号集録デバイス、高速デジタイザ、任意波形発生器、関数発

生器デバイスを使用して、アナログ信号の生成や集録を行うことができま

す。 また、デバイス間でクロックを共有や信号をトリガすることで、シス

テムで複数デバイスを同期することもできます。 LabVIEW 
SignalExpress でのハードウェアの詳細な使用方法については、ヘルプ→

LabVIEW SignalExpress ヘルプを選択すると開く『LabVIEW 
SignalExpress ヘルプ』を参照してください。

ウェブリソース

サンプルプロジェクト、技術関連ドキュメント、LabVIEW 
SignalExpress で使用できる LabVIEW の VI などのリソースについては、

ナショナルインスツルメンツのウェブサイト ni.com/jp/

signalexpressを参照してください。

http://www.ni.com/signalexpress
http://www.ni.com/signalexpress
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A
技術サポートおよびプロフェッ
ショナルサービス

技術サポートおよびその他のサービスについては、NI のウェブサイト

（ni.com/jp）の下記のセクションを参照してください。

• サポート―技術サポート（ni.com/jp/support）には以下のリソー

スがあります。

– セルフヘルプリソース―質問に対する回答やソリューションが必
要な場合は、ナショナルインスツルメンツのウェブサイト
（ni.com/jp/support）でソフトウェアドライバとアップデー
ト、検索可能な技術サポートデータベース、製品マニュアル、
トラブルシューティングウィザード、種類豊富なサンプルプログ
ラム、チュートリアル、アプリケーションノート、計測器ドライ
バなどをご利用いただけます。 ユーザ登録されたお客様は、

NI ディスカッションフォーラム（ni.com/jp/dforum）にアク
セスすることもできます。 オンラインでのご質問には、ナショナ
ルインスツルメンツのアプリケーションエンジニアが必ず回答い
たします。

– 標準サポート・保守プログラム（SSP）―NI のアプリケーション
エンジニアによる電話または E メールでの個別サポート、サー
ビスリソースセンターからのオンデマンドトレーニングモジュー
ルのダウンロードが可能となるプログラムです。 このプログラム
には製品ご購入時にご加入いただき、その後 1 年ごとに契約更
新してサービスを継続することができます。 
その他の技術サポートオプションについては、ni.com/jp/
servicesをご覧いただくか、ni.com/contactからお問い合
わせください。 

• トレーニングと認定―自習形式のコースキットやインストラクタによ

る実践コースなどのトレーニングおよび認定プログラムについては、

ni.com/jp/trainingを 参照してください。

• システムインテグレーション―時間の制約がある場合や社内の技術リ

ソースが不足している場合、またはプロジェクトで簡単に解消しない

問題がある場合などは、ナショナルインスツルメンツのアライアンス

パートナーによるサービスをご利用いただけます。 詳しくは、NI 営業

所にお電話いただくか、ni.com/jp/allianceをご覧ください。
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NI のウェブサイト（ni.com/jp）を検索しても問題が解決しない場合は、

NI の国内営業所または米国本社までお問い合わせください。 海外支社の電

話番号は、このマニュアルの冒頭に記載されています。 また、NI ウェブサ

イトの Worldwide Offices セクション（ni.com/niglobal（英語））か

ら海外支社のウェブサイトにアクセスすることもできます。 各支社のサイ

トでは、お問い合わせ先、サポート電話番号、E メールアドレス、現行の

イベント等に関する最新情報を提供しています。
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